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1.1 License Agreement

OpenGL® is a registered trademark of Silicon Graphics, Inc. (SGI).
Windows® is a registered trademark of Microsoft Corporation.
ENERCALC 3D is a trademark of ENERCALC, Inc.

Copyright 2010-2019 by ENERCALC.  All rights reserved.

1.2 Terms and Conventions

The convention for commands in this documentation is Main Menu > Sub-Menu.  For
example, Model Editing > Undo means the Undo command from the Model Editing
item in the main menu.

Model View:  A window in the program that contains the graphical display of the
model.

Report View:  A window in the program that contains the text or graphical report.

Structural Command:  A command in the program that affects the results for a
model.

Member:  A beam or frame element.  It also refers to a truss when the element has
full moment releases at two ends.  The term “beam element”, “frame element” and
“member” are used interchangeably in this program. 

Shell: a four-node shell finite element.  It includes membrane action and plate bending
action.  It is sometimes called a plate.

Brick: an eight-node solid finite element.
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Entity: A node, member, shell or brick.

Element:  A member or finite element (shell or brick).

Object:  A node or finite element (shell or brick) or its dependent.

Dependent:  A structural entity whose existence depends upon the existence of
another structural entity.  For example, a support is a dependent of a node; a moment
release is a dependent of a member (beam element).  All loads are dependents of
nodes or members or finite elements.

Parent:  A structural entity which may have dependents.  Nodes and elements may
be parents.  For example, a node may be a parent of a support or a member.  A
member may be a parent of a moment release.

Distance List:  A comma separated list that specifies multiple distances.  For
example, a distance list of “12,2@14,3@10” will generate distances of 12, 14, 14, 10,
10, and 10 in length units.

Orphaned Node:  A node that is not connected to any elements.

DOFs:  Degrees of freedom.

64-bit floating point (double precision):  The solver that uses 64-bit (8 bytes)
floating-point arithmetic.  The 64-bit floating point (double precision) is the standard
solver in almost all structural analysis programs.

128-bit floating point (quad precision):  The solver that uses 128-bit (16 bytes)
floating-point arithmetic.  The 128-bit floating point (quad precision) is extremely
accurate and is uniquely available in ENERCALC 3D.

1.3 Introduction

Built from the ground up, ENERCALC 3D is a powerful structural design / finite
element analysis software tool designed for structural engineers of all skill levels.
ENERCALC 3D is reliable, easy to use, and affordable. The software is designed for
accuracy and simplicity, allowing engineers to get the job done without being
overwhelmed by useless features.

The program includes the following frame and finite elements:



19

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

ENERCALC 3D

- 2D and 3D beam and truss element (also called member).  The element can be
linear, tension-only or compression-only.

- 3D four-node shell element, with thick (MITC4) plate and thin (Kirchhoff) plate
bending and plane membrane stress (compatible and incompatible)
formulations.

- 3D eight-node solid element (brick) with compatible and incompatible
formulations.

- Linear and nonlinear nodal, line, and surface spring elements.
- Rigid diaphragm.

The program includes the following analysis and design options:
- Static linear analysis.
- Geometric nonlinear (P-Delta) analysis.
- Standard 64-bit floating point (double precision) and extremely accurate 128-bit

floating point (quad precision) skyline solvers.
- Lightning fast sparse solver based on Intel PARDISO solver.
- Nodal, point, line, and surface forces; point moments; self-weight.
- Forced displacements on supports.
- Member moment releases.
- Concrete beam, column and slab/wall designs according to ACI 318-

02/05/08/11/14.

- Steel beam and column design according to AISC 14th Edition LRFD.

The program provides the following main user interface features:
- Multiple views with different display settings.
- Graphically drawing nodes, members and finite elements, area loads and rigid

diaphragms via mouse-click.
- Versatile spreadsheets for input data and results.
- Powerful automatic model generations for continuous beams; 2D and 3D

frames; 2D and 3D shells; arc beams and non-prismatic beams.
- Quality 3D graphical rendering with hidden line or surface removal based on

OpenGL®
- Loading diagram; moment and shear diagram for members; contours for shells

and solids; deflection diagram.
- Flexible editing features such as undo/redo, duplicate, move, scale, delete,

revolve, extrude, splitting members, sub-mesh shells, node and element
merging.

- Real time panning, zooming and rotating.
- Many different selection methods such as point/window/cross select, select by

IDs, select by properties, with options to freeze or thaw parts of a model.
- Flexible annotations for input and results.
- Text and graphical reports in html format.  Graphical report may contain

multiple images.  Text report may be saved in plain text format.
- Print previews for graphical and text reports
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1.3.1 Graphical User Interface (GUI)

ENERCALC 3D has a modern graphical user interface (Figure 0.1).  It includes
menus, multiple toolbars, multiple views and a status bar.

`

Figure 0.1

1.3.2 Spreadsheet Navigation

The program uses spreadsheets (grid control, see Figure 0.2) extensively for data
input and output.  It offers multiple ways to navigate within a spreadsheet as specified
in the following table.
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Figure 0.2

Key Action 

up arrow Moves active cell up one row 

down
a
r
r
o
w
 

Moves active cell down one row 

right
a
r

Moves active cell right one column 
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Key Action 

r
o
w
 

left arrow Moves active cell left one column 

Shift+arro
w
k
e
y
 

Extends selection in direction of arrow key 

Page Up Moves active cell one page up 

Page
D
o
w
n
 

Moves active cell one page down 

Ctrl+Page
U
p
 

Moves active cell one page left

Ctrl+Page
D
o
w
n
 

Moves active cell one page right

Home Moves active cell to first cell in row 

End Moves active cell to last cell in row that contains
data 

Ctrl+Home Moves active cell to first row, first column 

Ctrl+End Moves active cell to last row and column that
contain data 

Tab Moves active cell to next cell to the right (or at
end of row moves to beginning of next row) 

Shift+Tab Moves active cell to next cell to the left (or at
beginning of row moves up to end of row above) 
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Key Action 

Shift+spac
e
 

Selects current row 

Ctrl+space
 

Selects current column 

Shift+Ctrl+
s
p
a
c
e
 

Selects entire sheet 

Ctrl+X or
S
h
i
f
t
+
D
e
l
 

Cuts current selection or active cell's data to
Clipboard 

Ctrl+V or
S
h
i
f
t
+
I
n
s
 

Pastes Clipboard contents into active cell 

Ctrl+C or
C
t
r
l
+
I
n

Copies current selection or active cell's data to
Clipboard 
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Key Action 

s
 

Enter Active cell moves down

Esc If sheet is in edit mode, previous cell value
replaces new value and edit mode is turned off 

F2 If edit mode is on, cell value is cleared 



Menus
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2 Menus

2.1 Model

The Model menu provides commands that are related to files.  It also provides
commands related to text and graphical reports.  

The program generates text reports for input and output, or graphical reports for
captured images in PDF file format.  Report files may be viewed as separate
windows within the program.  

The Model menu changes its layout depending upon the view type of the current
window.  For example, when the current window is a report view, commands related
to printing are provided.  

2.1.1 Save Only

When the current window is a model view, Model > Save Only saves the model.  If
the model has not been saved before, the Save As dialog box will be displayed
prompting you to enter a file name.

2.1.2 Save & Close

Saves the current model data, closes the model and redisplays the Model Manager
window.

2.1.3 Close without Saving

Model > Close without Saving provides a way to close the current model and return to
the Model Manager without saving the current model.

2.1.4 Print Text Report

Model > Print Text Report allows you to preview and print a report for the model using
the current report configuration options.

2.1.5 Envelope Report

Analysis Result > Envelope Report allows you to print enveloped diagrams of multiple
load combinations on members (Figure 1.1).  You may give a name to the type of
envelope.  You have the option to print an envelope report on selected members only.
 Two charts are printed on each page.  You have the option to select the diagram
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type for each chart.  For example, you may select the major moment Mz diagram for
chart one and the major shear Vy diagram for the second chart.

Figure 1.1

2.1.6 Print Current View

Model > Print Current View allows you to preview and print the current model view.
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2.1.7 Print Options

Model > Print Options prompts you with the following dialog box (Figure 1.2).  It
allows you to generate a report for input and/or output data in html file format.  

The command provides different options to control the contents of the report.  For
example, you may generate a report for selected nodes or elements only. After
clicking the OK button, the graphical report will be displayed in a report view within the
web browser.  You may then print the report to a PDF file.

Figure 1.2

2.1.8 General Information

Model > General Information prompts you with the following dialog box (Figure 1.3). 
It allows you to
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Figure 1.3

2.1.9 Frame Item Counts

Model > Frame Item Counts displays the key statistics about the model (Figure 1.4).
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Figure 1.4

2.1.10 View Log File

Model > View Log File allows you to view the log file generated during the solution
process
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2.2 Edit

The Edit main menu provides commands to edit or modify the model.

2.2.1 Undo

Edit > Undo undoes the previous structural command.  By default, you may undo up to
10 levels.  You may set a different number of undo levels by running Settings > Data
Options.  Non-structural commands such as zooming or panning may not be undone. 
More undo levels requires more computer memory.

2.2.2 Redo

Edit > Redo reverses the previous undo command.  

2.2.3 Lock Model

Edit > Lock Model locks the model so that you cannot modify it.  You may still access
non-structural commands such as zooming and panning while the model is locked. 
The model may be automatically locked after an analysis is performed successfully. 
To do that, just click Settings > Preferences.

2.2.4 Duplicate

Edit > Duplicate prompts you with the following dialog box (Figure 2.1).  It allows you
make one copy of the selected parts of a model to a different location.  You may
specify copydistances along the X, Y or Z directions.  Nodal or element dependents
(except loads) are copied together with their parents automatically.  For example,
when a member is copied, moment releases on that member are copied also.  You
have the option to copy the loads attached to the selected nodes or elements.  You
have the option to automatically merge nodes and elements after copying.  You
should check this option unless duplicate nodes are explicitly permitted. 
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Figure 2.1

2.2.5 Array

Edit > Array prompts you with the following dialog box (Figure 2.2).  It allows you
make one or more copy of the selected parts of a model to a different location.  You
may specify the step size along the X, Y or Z directions.  Nodal or element
dependents (except loads) are copied together with their parents automatically.  For
example, when a member is copied, moment releases on that member are copied
also.  You have the option to copy the loads attached to the selected nodes or
elements.  You have the option to automatically merge nodes and elements after
copying.  You should check this option unless duplicate nodes are explicitly permitted. 
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Figure 2.2

2.2.6 Mirror

Edit > Mirror prompts you with the following dialog box (Figure 2.3).  It allows you to
mirror the selected parts of a model to a different location by defining a mirror plane. 
Nodal or element dependents (except loads) are mirrored together with their parents
automatically.  For example, when a member is mirrored, moment releases on that
member are mirrored also.  You have the option to copy the loads attached to the
selected nodes or elements.  You have the option to automatically merge nodes and
elements after copying.  You should check this option unless duplicate nodes are
explicitly permitted. 
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Figure 2.3

2.2.7 Move

Edit > Move prompts you with the above dialog box (Figure 2.4).  It lets you move
selected parts of a model to a different location.  You may specify move distances
along the X, Y or Z directions.  Nodal or element dependents such as loads are
moved together with selected nodes or elements automatically.  You have the option
to automatically merge nodes and elements after moving.  You should check this
option unless duplicate nodes are explicitly permitted. 
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Figure 2.4

Note:  When using this command, be sure to select the intended entities AND THEIR
NODES, before executing the command.  If the entities are selected without their
nodes, the command will not work.

2.2.8 Rotate

Edit > Rotate prompts you with the following dialog box (Figure 2.5).  It lets you rotate
selected parts of a model by an angle about one of the global axes.  Nodal or element
dependents such as loads are moved together with the elements.  You have the
option to automatically merge nodes and elements after rotating.  You should check
this option unless duplicate nodes are explicitly permitted. 
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Figure 2.5

Note:  When using this command, be sure to select the intended entities AND THEIR
NODES, before executing the command.  If the entities are selected without their
nodes, the command will not work.

2.2.9 Scale

Edit > Scale prompts you with the above dialog box (Figure 2.6).  It lets you scale
selected parts of a model in the X, Y or Z directions.  You may specify the
coordinates of a base point and scales for the three global directions.  

The following formula is used to perform the scaling in the program.

Xnew = Xbase + (Xold - Xbase) * scale

Where Xnew represents the nodal coordinates after scaling, Xold represents the

nodal coordinates before scaling and Xbase represents coordinates of the base point.
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Figure 2.6

Note:  When using this command, be sure to select the intended entities AND THEIR
NODES, before executing the command.  If the entities are selected without their
nodes, the command will not work.

2.2.10 Delete

Edit > Delete prompts you with the following dialog box (Figure 2.7).  It allows you to
delete selected nodes or elements or their dependents.  Loads are deleted based on
their visibilities in the model view.  Dependents such as loads will be deleted if their
parent nodes or elements are deleted. 
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Figure 2.7

2.2.11 Extrude

Edit > Extrude provides various methods of creating entities by starting with a
selected set and extruding them by specified distances.

2.2.11.1 Extrude > Extrude Nodes to Members

Edit > Extrude > Extrude Nodes to Members prompts you with the following dialog
box (Figure 2.8).  It generates a series of members by extruding selected nodes
along a global direction.

You may specify a distance list and an extrusion direction for the generation of
beams.  The distance list is a comma separated list that specifies multiple distances. 
For example, a distance list of “12,2@14,3@10” will generate distances of 12, 14,
14, 10, 10 and 10 in length units.  You have the option to automatically merge nodes
and elements after extrusion.  You should check this option unless duplicate nodes are
explicitly permitted. 
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Figure 2.8

The following members in Figure 4.30 are generated by extruding one node (the first
node) using the input from Figure 4.29.

Figure 2.9

2.2.11.2 Extrude > Extrude Members to Shells

Edit > Extrude > Extrude Members to Shells prompts you with the following dialog box
(Figure 2.10).  It generates a series of shells by extruding selected members along a
global direction. You may specify a distance list and an extrusion direction for the
generation of shells.  The extrusion direction must not be parallel to the selected
members.  You have the option to automatically merge nodes and elements after
extrusion.  You should check this option unless duplicate nodes are explicitly
permitted.  You also have the option to automatically delete selected members after
the extrusion. 
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Figure 2.10

The input in Figure 2.10 is applied to the members in Figure 2.11 to generate the
shells in Figure 2.12 by extruding.

members used for extruding

Figure 2.11

shells generated

Figure 2.12
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2.2.11.3 Extrude > Extrude Shells to Bricks

Edit > Extrude > Extrude Shells to Bricks prompts you with the following dialog box
(Figure 2.13).  It generates a series of bricks by extruding selected shells along a
global direction.  You may specify a distance list and an extrusion direction for the
generation of shells.  The extrusion direction must not be parallel to the selected
shells.  You have the option to automatically merge nodes and elements after
extrusion.  You should check this option unless duplicate nodes are explicitly
permitted.  You also have the option to automatically delete selected shells after the
extrusion. 

Figure 2.13

The input in Figure 2.13 is applied to the shells in Figure 2.14 to generate the bricks in
Figure 2.15 by extruding.
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shells used for extruding

Figure 2.14

bricks generated

Figure 2.15
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2.2.12 Revolve

Edit > Revolve provides various methods of creating entities by starting with a
selected set and revolving them through specified angles.

2.2.12.1 Revolve > Revolve Members to Shells

Edit > Revolve > Revolve Members to Shells prompts you with the following dialog
box (Figure 2.16).  It generates a series of shells by revolving selected members
about the global Y axis.  You may specify the number of segments, start and end
angles for revolving.  The program will merge nodes automatically.  You have the
option to automatically delete the selected members after revolving.

Figure 2.16

The input in Figure 2.16 is applied to the members in Figure 2.17 to generate the
shells in Figure 2.18 by revolving.
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members used for revolving

Figure 2.17

shells generated
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Figure 2.18

2.2.12.2 Revolve > Revolve Shells to Bricks

Edit > Revolve > Revolve Shells to Bricks prompts you with the following dialog box
(Figure 2.19).  It generates a series of bricks by revolving selected shell4s about the
global Y axis.  You may specify the number of segments, start and end angles for
revolving.  The program will merge nodes automatically.  You have the option to
automatically delete the selected shells after revolving.

Figure 2.19

The input in Figure 2.19 is applied to the shells in Figure 2.20 to generate the bricks in
Figure 2.21 by revolving.  Bricks are rendered in the figure.
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shells used for revolving

Figure 2.20

bricks generated

Figure 2.21

2.2.13 Split Members

Edit > Split Members prompts you with the following dialog box (Figure 2.22).  It
allows you to divide selected members by specifying 2 or more segments of equal
length or by providing a distance list.  Loads on the original members are assigned
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automatically to the generated members after splitting.  You have the option to
automatically merge nodes and elements after splitting.  

Figure 2.22

The input in Figure 2.22 is applied to the members in Figure 2.23 to generate the
members in Figure 2.24 by splitting.

members before splitting

Figure 2.23
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members after splitting

Figure 2.24

2.2.14 Sub-Mesh Shells

Edit > Sub-Mesh Shells prompts you with the following dialog box (Figure 2.25).  It
allows you to sub-mesh selected shells by specifying 2 or more segments along sides
1-2 & 4-3 and sides 2-3 & 1-4.  Loads on the original shells are assigned
automatically to the generated shells after sub-meshing.  You have the option to
merge nodes and elements after sub-meshing.  You should check this option unless
duplicate nodes are explicitly permitted.

Figure 2.25

The input in Figure 2.25 is applied to the shells in Figure 2.26 to generate the shells in
Figure 2.27 by meshing.
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shells before sub-meshing

Figure 2.26

shells after sub-meshing

Figure 2.27

2.2.15 Insert Nodes at Intersections of Selected Members

Edit > Insert Nodes at Intersections of Selected Members allows you to insert nodes
at all intersections of the selected members.  The newly created nodes are likely
isolated (orphaned) nodes, meaning they are not attached to intersecting members. 
Generally speaking, you should explode the members at these nodes.  The program
prompts you to do so at the end of this command.

2.2.16 Explode Selected Members at Nodes

Edit > Explode Selected Members at Nodes allows you to split selected members at
nodes which are located on but are not connected to these members.

Consider the following three figures: Figure 2.28 shows a shell with edge members on
four sides:
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Figure 2.28

Figure 2.29 shows shells generated by sub-meshing (2x2) the shell from Figure 4.49:

Figure 2.29

Figure 2.30 shows members generated by exploding members at nodes.  

Figure 2.30

Notice in Figure 2.30, the middle nodes on the edge are on but not connected to the
members.  The figures are rendered using the command View > Render, with the
rendering ratio of 80% for both members and shells.
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2.2.17 Renumber

Edit > Renumber offers options to renumber entities in the model.

2.2.17.1 Renumber > Auto Number All Nodes

Edit > Renumber > Auto Number All Nodes prompts you with the following dialog box
(Figure 2.31).  It allows you to renumber all nodes sequentially based on nodal
coordinates.

Figure 2.31

2.2.17.2 Renumber > Renumber Selected Nodes

Edit > Renumber > Renumber Selected Nodes prompts you with the following dialog
box (Figure 2.32).  It allows you to Renumber selected nodes based on the following
two modes:

a). Increment each selected node number by a delta (may be positive or negative). 
For example, if we have selected node numbers 2, 5, 8 and a delta of 2, the new
node numbers will be 4, 7, and 10.

b). Renumber each selected node from a new start number (must be positive) and a
step (may be positive or negative).  For example, if we have selected node numbers
2, 5, 8, a new start number of 1000 and a step of 2, the new node numbers will be
1000, 1002, 1004.

If renumbering is successful, nodal dependents such as loads, masses and springs
will be renumbered automatically.  The renumbering will be undone automatically if any
errors are encountered.



52

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Menus

Figure 2.32

2.2.17.3 Renumber > Renumber Selected Members/Shells/Bricks

Edit > Renumber > Renumber Members, Shells and Bricks commands are similar to
Renumber Nodes and are not repeated here.

2.2.18 Switch Coordinates

Edit > Switch Coordinates prompts you with the following dialog box (Figure 2.33).  It
allows you to switch the X and Z, or the Y and Z coordinates of the selected nodes. 
For example, you may generate a floor system on the XY (vertical) plane and then
switch coordinates to place the floor on the XZ (horizontal) plane.

Figure 2.33
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2.2.19 Reverse Node Order for Selected Elements

Edit > Reverse Node Order for Selected Elements allows you to reverse the nodes’
order for selected elements.  For members and shells, this command in effect
changes their local coordinate systems.  For bricks, this command may be used to
rectify a wrong nodal ordering which results in negative diagonals in element stiffness.

It is important to point out that dependents on the elements are not reversed or
changed accordingly.  After running this command, you should check on these
dependents such as loads and moment releases on members, loads on shells, etc.

2.2.20 Merge All Nodes & Elements

Edit > Merge All Nodes & Elements merges all nodes that are located within a
distance tolerance between two or more nodes, and merges all elements that share
the same nodes.  You may set the distance tolerance using the command Settings >
Data Options.

2.2.21 Remove All Orphaned Nodes

Edit > Remove All Orphaned Nodes removes all nodes that are not connected to any
elements.  Orphaned nodes make the model unstable.  They must be removed prior
to the solution. 

2.2.22 Element Local Angle

Edit > Element Local Angle prompts you with a dialog box to assign local angles to
the selected members and/or shells.  The element local angle is used to change the
element local coordinate system.

2.2.23 Match Local x-Axes for Shells

Edit > Match Local x-Axes for Shells prompts you with a dialog box to specify a
source shell.  The orientation of the local x-axes of the selected shells will be changed
to match the orientation of the local x-axis of the source shell.

2.2.24 3-Point Member Orientation

Edit > 3-Point Member Orientation prompts you with a dialog box to specify an X, Y,
and Z coordinate.  The orientation of selected members will be changed so the local
z-axis of all selected members is perpendicular to the plane formed by the two
member end coordinates and the specified X, Y, Z coordinate.
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2.2.25 Tension/Compression Only

Edit > Tension/Compression Only prompts you with a dialog box to assign nonlinearity
(linear, tension only or compression only) to the selected members.  The member
stiffness will be ignored if a tension only member is subjected to compressive forces
or if a compression only member is subjected to tensile forces. The presence of
tension only or compression only members makes the model nonlinear and requires
iterative solution for each load combination.

2.2.26 Convert Selected Members to Rigid Links

Edit > Convert Members to Rigid Links will convert selected members to rigid links. 

2.2.27 Self Weight Exclusion

Edit > Self Weight Exclusion allows self weight to be considered or ignored for
selected members, shells, and bricks. 

2.2.28 Element Activation

Edit > Element Activation allows members, shells, and/or bricks to be selectively
activated or deactivated.

This allows these modeling entities to remain in the model while studying the effects of
ignoring their structural contributions to the model.

2.2.29 Clear

Edit > Clear offers some options for clearing some data that could be using memory.

2.2.29.1 Clear > Clear Undo & Redo

Edit > Clear > Clear Undo & Redo clears the undo/redo buffer, thus frees up
computer memory.  It is a good idea to use this command before the solution so that
more memory may be committed to the solver.

2.2.29.2 Clear > Clear Results

Edit > Clear > Clear Results clears all results from computer memory.  You need to
re-solve the model to obtain new results.
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2.2.29.3 Clear > Clear Everything

Edit > Clear > Clear Everything clears all input and output (results) data from
computer memory.  You should think twice before running this command.

2.3 View

The View menu provides commands to graphically view inputs such as geometry and
loading; perform selections by various methods; and display outputs such as shear
and moment diagrams for members, and contours for shells and bricks.

2.3.1 Redraw

View > Redraw regenerates and redraws all graphics in the model view.

2.3.2 Restore Model

View > Restore restores original settings for the model view.  These settings include
zooming = 1.0, panning = 0, rotation = 0. 

2.3.3 Preset Views

You may place the model view in a preset orientation by selecting one of these
commands (Figure 3.1).

Front Back Left Right

Top Bottom Isometric

Figure 3.1
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2.3.4 Named Views

View > Named Views allows you to save the current view settings such as zooming
factor, panning distance or rotation angles so that you may recall the same view
settings later on.

2.3.5 Named Selections

View > Named Selections prompts you with the following dialog box (Figure 3.2).  It
allows you to save the currently selected items to a name.  You may use the
command View > Select by Properties > Selection Names to recall the previously
saved named selections.  This command is very useful to group related items.
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Figure 3.2

2.3.6 Zoom

The Zoom controls allow the model to be displayed at various scales.

2.3.6.1 Zoom > Zoom Extent

View > Zoom > Zoom Extent displays the entire model in the view.

2.3.6.2 Zoom > Zoom Window

View > Zoom > Zoom Window zooms in on a specific part of the model by clicking
and dragging the left mouse button.  The command remains in effect until another
command is selected, the right mouse button is clicked, or ESC is pressed.

2.3.6.3 Zoom > Zoom Object

View > Zoom > Zoom Object zooms in on a specific node, member, shell or brick. 
The command remains in effect until another command is selected, the right mouse
button is clicked, or ESC is pressed.

2.3.6.4 Zoom > Zoom Previous

View > Zoom > Zoom Previous lets you zoom back to the previous view.  You may
use this command after you zoom in or pan to view a portion of your model in greater
detail.

2.3.6.5 Zoom > Zoom In

View > Zoom > Zoom In zooms in on the model by a preset factor (1.25).  You may
use this command by pressing CTRL+UP arrow or CTRL+RIGHT arrow.

2.3.6.6 Zoom > Zoom Out

View > Zoom > Zoom Out zooms out on the model by a preset factor (1.25).  You
may use this command by pressing CTRL+DOWN arrow or CTRL+LEFT. 

2.3.7 Pan

The Pan controls allow the view of the model to be moved.
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2.3.7.1 Pan > Pan Screen

View > Pan > Pan Screen pans (moves) the model by clicking and dragging the left
mouse button.  The command remains in effect until another command is selected, the
right mouse button is clicked, or ESC is pressed.

2.3.7.2 Pan > Right

View > Pan > Right pans the model to the right by a preset screen distance.  You
may use this command by pressing CTRL+RIGHT arrow. 

2.3.7.3 Pan > Left

View > Pan > Left pans the model to the left by a preset screen distance.  You may
use this command by pressing CTRL+LEFT arrow. 

2.3.7.4 Pan > Up

View > Pan > Up pans the model to the top by a preset screen distance.  You may
use this command by pressing CTRL+UP arrow. 

2.3.7.5 Pan > Down

View > Pan > Down pans the model to the bottom by a preset screen distance.  You
may use this command by pressing CTRL+DOWN arrow. 

2.3.8 Rotate

The Rotate commands allow the view of the model to be spun around various axes.

2.3.8.1 Rotate > +X

View > Rotate > +X rotates the model view about X by a preset positive angle (5
degrees).  You may use this command by pressing SHIFT+DOWN arrow. 

2.3.8.2 Rotate > -X

View > Rotate > -X rotates the model view about X by a preset negative angle (5
degrees).  You may use this command by pressing SHIFT+UP arrow. 
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2.3.8.3 Rotate > +Y

View > Rotate > +Y rotates the model view about Y by a preset positive angle (5
degrees).  You may use this command by pressing SHIFT+RIGHT arrow. 

2.3.8.4 Rotate > -Y

View > Rotate > -Y rotates the model view about Y by a preset negative angle (5
degrees).  You may use this command by pressing SHIFT+LEFT arrow. 

2.3.8.5 Rotate > +Z

View > Rotate > +Z rotates the model view about Z by a preset positive angle (5
degrees).  You may use this command by pressing CTRL+SHIFT+UP arrow or
CTRL+SHIFT+RIGHT arrow

2.3.8.6 Rotate > -Z

View > Rotate > -Z rotates the model view about Z by a preset negative angle (5
degrees).  You may use this command by pressing CTRL+SHIFT+DOWN arrow or
CTRL+SHIFT+LEFT arrow

2.3.9 Real-Time Motion

The Real-Time Motion commands allow the model view to be grabbed and moved or
spun.

2.3.9.1 Real-Time Motion > Real-Time Pan

View > Real-Time Motion > Real-Time Pan allows you to pan the model view in real
time by clicking and dragging the left mouse button.  The command remains in effect
until another command is selected, the right mouse button is clicked, or ESC is
pressed.

2.3.9.2 Real-Time Motion > Real-Time Zoom

View > Real-Time Motion > Real-Time Zoom allows you to zoom in or out on the
model view in real time by clicking and dragging the left mouse button up or down. 
The command remains in effect until another command is selected, the right mouse
button is clicked, or ESC is pressed.
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2.3.9.3 Real-Time Motion > Real-Time Rotate

View > Real-Time Motion > Real-Time Rotate allows you to rotate the model view in
real time by clicking and dragging the left mouse button.  The command remains in
effect until another command is selected, the right mouse button is clicked, or ESC is
pressed.

2.3.10 Window/Point Select

View > Window/Point Select allows you to window-select or point-select nodes and
elements by clicking or clicking-dragging the left mouse button.  The Window/ Point
Select command is the default selection command in the program.

Point versus Window

The point-selection selects or unselects at most one node or element.  The window-
selection selects or unselects a group of nodes or elements within a rectangular
selection window.  

Window Drawn Right-to-Left versus Left-to-Right

If the selection window is drawn from left to right, then only entities that are entirely
within the selection rectangle will be selected/unselected.

If the selection window is drawn from right to left, then all entities that are crossed by
the selection rectangle will also be selected or unselected.  

Select versus Reverse Select

By default, the selection mode is REVERSE SELECT, that is, entities picked will be
selected if they are currently unselected and will be unselected if they are currently
selected.  However, the selection mode will be SELECT if CTRL is pressed while
selecting, that is, entities picked will always be selected.  

The selection of nodes and elements is an important activity in the program.  Most of
the commands apply only to selected nodes or elements.  For this reason, many
selection methods are provided in the program and are explained in the following
sections.
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2.3.11 Line Select

View > Line Select allows you to line-select elements by clicking-dragging the left
mouse button. The line-selection selects or unselects a group of entities that the
drawn line intersects.

2.3.12 Select by IDs

The Select by IDs tools offer many easy ways to quickly select multiple entities.

2.3.12.1 Select by IDs > Nodes

View > Select by IDs > Nodes prompts you with the following dialog box (Figure 3.3).
 It allows you to select nodes by specifying a range of node IDs.

Three selection modes are provided: “Select”, “Unselect”, “Reverse Select”.  The
“Select” mode will select nodes.  The “Unselect” mode will unselect nodes.  The
“Reverse Select” mode will select the unselected nodes and unselect the selected
nodes. 

Figure 3.3
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2.3.12.2 Select by IDs > Members

View > Select by IDs > Members prompts you with a dialog box to select members
by specifying a range of member IDs.

Three selection modes are provided: “Select”, “Unselect”, “Reverse Select”.  The
“Select” mode will select members.  The “Unselect” mode will unselect members.  The
“Reverse Select” mode will select the unselected members and unselect the selected
members.

2.3.12.3 Select by IDs > Shells

View > Select by IDs > Shells prompts you with a dialog box to select shells by
specifying a range of shell IDs.

Three selection modes are provided: “Select”, “Unselect”, “Reverse Select”.  The
“Select” mode will select shells.  The “Unselect” mode will unselect shells.  The
“Reverse Select” mode will select the unselected shells and unselect the selected
shells.

2.3.12.4 Select by IDs > Bricks

View > Select by IDs > Bricks prompts you with a dialog box to select bricks by
specifying a range of brick IDs.

Three selection modes are provided: “Select”, “Unselect”, “Reverse Select”.  The
“Select” mode will select bricks.  The “Unselect” mode will unselect bricks.  The
“Reverse Select” mode will select the unselected bricks and unselect the selected
bricks.

2.3.12.5 Select by IDs > Select All

View > Select by IDs > Select All selects all nodes and elements.  You may use this
command by pressing CTRL+A.

2.3.12.6 Select by IDs > Unselect All

View > Select by IDs > Unselect All unselects all nodes and elements.  You may use
this command by pressing ESC.  If you are in the middle of another command such as
zooming, press ESC twice to unselect all.

2.3.13 Select by Properties

The Select by Properties tools offer more ways to quickly select multiple entities.
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2.3.13.1 Select by Properties > Materials

View > Select by Properties > Materials prompts you with the following dialog boxes
(Figure 3.4).  It allows you to select/unselect elements that use the specified
materials.

Three selection modes are provided: “Select”, “Unselect”, “Reverse Select”.  The
“Select” mode will select elements.  The “Unselect” mode will unselect elements.  The
“Reverse Select” mode will select the unselected elements and unselect the selected
elements.

Figure 3.4

2.3.13.2 Select by Properties > Member Sections

View > Select by Properties > Member Sections prompts you with the following dialog
box (Figure 3.5).  It allows you to select/unselect members that use the specified
sections. 

Three selection modes are provided: “Select”, “Unselect”, “Reverse Select”.  The
“Select” mode will select elements.  The “Unselect” mode will unselect elements.  The
“Reverse Select” mode will select the unselected elements and unselect the selected
elements.
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Figure 3.5

2.3.13.3 Select by Properties > Member Orientations

View > Select by Properties > Orientations prompts you with the following dialog box
(Figure 3.6).  It allows you to select/unselect members based on their orientations to
the three global axes. For example, you may select/unselect all vertical columns by
checking the global Y direction.  The selection modes are similar to the ones used in
previous sections and are not repeated here.
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Figure 3.6

2.3.13.4 Select by Properties > Tension/Compression Only Members

View > Select by Properties > Tension/Compression Only Members allow you to
select all tension-only or compression-only members.

2.3.13.5 Select by Properties > Shell Thicknesses

View > Select by Properties > Shell Thicknesses prompt you with the following dialog
boxes (Figure 3.7).  It is similar to the one used in View > Select by Properties >
Member Sections.  The Select by Properties > Shell Thicknesses applies to shells
only.  Three selection modes are similar to the ones used in the previous section and
are not repeated here.
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Figure 3.7

2.3.13.6 Select by Properties > Orphaned Nodes

View > Select by Properties > Orphaned Nodes selects all orphaned nodes.

2.3.13.7 Select by Properties > Coordinates

View > Select by Properties > Coordinates prompts you with the following dialog box
(Figure 3.8).  It allows you to select/unselect nodes and elements based on nodal
coordinates.  Nodes are selected/unselected if their coordinates are within the
boundary of the minimum and maximum coordinates.  Elements are
selected/unselected if coordinates of their nodes are within the boundary of minimum
and maximum coordinates.  The selection modes are similar to the ones used in
previous sections and are not repeated here.
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Figure 3.8

2.3.13.8 Select by Properties > Selection Names

View > Select by Properties > Selection Names allows you to select/unselect nodes
and elements based on saved named selections.  You may assign (or save) named
selections from the Geometry menu.
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Figure 3.9

2.3.13.9 Select by Properties > Concrete Beam/Column/Plate Criteria

View > Select by Properties > Concrete Beam Criteria, Concrete Column Criteria and
Concrete Plate Criteria allows you to select member or plate elements based on their
design criteria.

2.3.13.10 Select by Properties > Steel Design Criteria

View > Select by Properties > Steel Design Criteria allows you to select members
based on a steel design criteria.

2.3.13.11 Select by Properties > Select/Unselect All

View > Select by Properties > Select All and Unselect All are the same as in View >
Select by IDs.  They are provided here for convenience.

2.3.14 Flip Selection

View > Flip Selection inverts the selection statuses of all entities in the entire model. 
The nodes and elements currently selected will be unselected and vice versa.
 

2.3.15 Freeze Selected

View > Freeze Selected freezes or hides the selected nodes, elements and their
dependents.  The frozen nodes or elements are not displayed and are not modifiable
unless the model integrity is at stake.  This command allows you to focus on some
particular parts of the model.  For example, if you want to work on a particular floor of
a three dimensional building, you may select the floor, flip the selection and freeze the
selected elements.

2.3.16 Freeze All Except Level

View > Freeze All Except Level freezes or hides the all nodes, elements and their
dependents except those on the specified level (Figure 3.10).  This command provides
a shortcut to the previous command when you would like to focus on elements of the
model in a horizontal plan view.  You must have levels defined (through menu Assign
Properties > Levels) before running this command.
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Figure 3.10

2.3.17 Freeze All Except Plane

View > Freeze All Except Plane freezes or hides all nodes, elements and their
dependents except those on the specified plane (Figure 3.11).  This command
provides a shortcut to the previous command when you would like to focus on
elements of the model in a plan view.  

Figure 3.11

2.3.18 Thaw

View > Thaw allows you to thaw all frozen (hidden) nodes, elements and their
dependents.

2.3.19 Load Diagram

View > Load Diagram prompts you with the following dialog box (Figure 3.12).  It
allows you to view loads of selected types in selected load cases.  You may have the
options to show load magnitudes or units.  The line load intervals may vary between 1
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and 16.  An interval between 2 to 6 is recommended.  Transparency may be set for
non-area loads and area loads so you can see objects underneath the loads.  The
displayed loads may be deleted.  The loads not displayed cannot be deleted unless
their parent nodes or elements are deleted.

Figure 3.12

2.3.20 Annotate

View > Annotate prompts you with the above dialog box (Figure 3.13).  It allows you
to view annotations for nodes and elements and their properties.  The element local
axes may also be displayed using this command.  Three annotation modes are
available.  You may annotate all entities, annotate selected entities, and erase existing
annotations.  For performance reasons, it is recommended that the annotations be
applied only for objects of interest.
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Figure 3.13

2.3.21 Query

View > Query lets you query extensive input and output information for a single node,
member or finite element (Figure 3.14).  For example, a node query will list node id,
nodal coordinates and nodal loads.  It will also list relevant support or nodal spring
information.  If there are analysis results, it will list nodal displacements, support or
spring reactions as well.
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Figure 3.14

2.3.22 Distance

View > Distance lets you click two locations and obtain the distance between the two
coordinates.

2.3.23 Render

View > Render offers rendering controls.
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2.3.23.1 Render > Render Options

View > Render > Render Options prompts you with the following dialog box (Figure
3.15).  It allows you to turn on or off the shading of the surfaces of members, shells
and bricks as though they were illuminated from multiple light sources.  It provides a
way for you to realistically visualize the image of the model.  For shells, you have the
option to render thickness as well as surface.

You have the option to apply different rendering percentages to different elements. 
Enter 100% for full rendering, 0% for no rendering, and anything in-between for partial
rendering.  The partial rendering (e.g. 50-80%) may be useful in identifying
connectivity of elements to nodes.

Figure 3.15

Note: Rendering a model can be expensive in terms of memory and time usage by
the program.  You should turn off the rendering when it is not necessary.

2.3.23.2 Render > Quick Render

View > Render > Quick Render turns rendering on or off.  You may use this command
by pressing F8.
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2.3.24 Result Diagrams

2.3.24.1 Result Diagrams > Shear and Moment Diagram

Analysis Results > Result Diagrams > Shear and Moment Diagram prompts you with
the following dialog box (Figure 3.16).  

Figure 3.16

It allows you to view the member shear (including axial force) diagram or moment
(including torsion) diagram for the selected load combination.  Only one shear or
moment diagram for the selected load combination may be displayed per window. 
However, you may display different shear or moment diagrams in multiple windows. 
To open a new window, click Window > New Window.

You have the option to show values and units for the diagram. You may show
diagrams on all members or on selected members only. You may also erase existing
diagrams. By default, no diagram is displayed even if an analysis has been performed
successfully.



75

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Menus

Figure 3.17

2.3.24.2 Result Diagrams > Deflection Diagram

Analysis Results > Result Diagrams > Deflection Diagram prompts you with the
following dialog box (Figure 3.18).  

Figure 3.18

It allows you to view the deflected shape of the model for the selected load
combination.  The deflected shape is constructed by adding nodal displacements to
nodal coordinates.  For members, you have the option to show the local y and/or z



76

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Menus

deflection as well.  You need to adjust the displacement magnification to view the
deflection properly.  The deflection displayed is for the selected load combination
only.  However, you may display deflections for different load combinations in multiple
windows.  To open a new window, click Window > New Window.  The deflection
values and units may be shown for the member local deflections.  You may choose to
have shadows of the undeformed shape and deformed shape hidden.  You cannot
perform mouse selection while the deflected shape is shown.  However, you may
open another window with the undeformed shape and perform mouse selection as
usual.

Figure 3.19

2.3.24.3 Result Diagrams > Contour Diagram

Analysis Results > Result Diagrams > Contour Diagram prompts you with the
following dialog box (Figure 3.20).  It allows you to view a result contour for shells
and/or bricks for the selected load combination.  

Four display modes are available.  They are Iso-Surface and Value, Iso-Surface only,
Value only, None or Erase.  The Iso-Surface provides color bands for the contour
component in different ranges.  The number of ranges (or colors) may be either 16 or
8.  Either top or bottom stresses may be specified for plate/shell elements.  The
Value (the absolute maximum) of the contour component may be shown for each
element.  The contour may be displayed in colors or gray scale.  The latter is useful
for people with color-impaired visions.

The contour components include:
· nodal displacements (Dx, Dy, Dz, Dox, Doy, and Doz)

· shell bending moments (Mxx, Myy, Mxy) and shears (Vxx, Vyy)
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· shell membrane normal forces (Fxx, Fyy) and in-plane shears (Fxy)

· shell and brick stresses (Sxx, Syy, Szz, Sxy, Sxz, Syz)

· surface spring reactions (SRx, SRy, SRz)

· shell principal moments (Mmax, Mmin) and shear (Vmax)

· shell principal membrane forces (Fmax, Fmin) 

· principal stresses (S1, S2, S3) for shells and bricks

· Von Mises stresses for shells and bricks

Figure 3.20

Only one contour component for the selected load combination may be displayed per
window.  However, you may display different contour components in multiple
windows.  To open a new window, click Window > New Window.

Four different modulations may be applied to values of the contour component.  They
are “Positive and Negative”, “Absolute”, “Positive Only”, “Negative Only”.  For
example, you may choose the contour component “Mxx” and the modulation “Negative
Only” to view only the negative moments Mxx of the plates.
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The following figure (Figure 9.6) shows a displacement (Dz) contour for a plate, with

display mode “Iso-Surface and Values” and value modulation of “Positive and
Negative”.

Figure 3.21

2.3.24.4 Result Diagrams > Unity Check

Analysis Results > Result Diagrams > Unity Check toggles on and off the colored
codes for concrete and steel beam-column unity check results.  The colors are coded
according to the following:

· Blue if design is safe
· Red if design is not safe.  

2.3.24.5 Result Diagrams > Response Animation

Analysis Results > Result Diagrams > Response Animation toggles on or off structural
responses (such as deflection, moment shear diagrams or stress contours) animation.
 Animation parameters may be set in Settings > Preferences.
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2.3.25 Options

2.3.25.1 Options > Drawing Grid

View > Options > Drawing Grid shows or hides the drawing grid.  You may set up the
grid by using the command Geometry > Drawing Grid.  The grid coordinates are
shown in the status bar while the mouse is moving in the model view.  You may use
this command by pressing F7.

2.3.25.2 Options > Global Axes

View > Options > Global Axes shows or hides the legend of the global axes in the
bottom-left corner of the window.  You may use this command by pressing F5. 

2.3.25.3 Options > Contour Legend

View > Options > Contour Legend shows or hides the contour legend.  The results
must exist for the contour legend to be displayed.

2.3.25.4 Options > Comment

View > Options > Comment allows you to insert a comment at a specified location
(Figure 3.23).  The comment must be less than 256 characters in length.  To remove
an existing comment, go to Tables > Comments and delete the comment entry.

Figure 3.23



80

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Menus

2.4 Geometry

The Geometry menu provides commands to draw individual nodes and elements
based on a drawing grid or existing nodes and parametrically generate models of
regular shape.

2.4.1 Materials

Geometry > Materials prompts you with the following dialog box (Figure 4.1).  It
allows you to define and/or assign materials to selected elements in the model.  An Id
is assigned automatically to each material by the program and may not be changed. 
You may assign a label with 127 maximum characters to each material for easy
identification.  The material properties include: 

· Young’s modulus (E),
·

· Weight density,
· Temperature coefficients.

The shear modulus (G) is calculated automatically. 

These material properties are used in the structural analysis of the model.  Material
properties related to design may be set from design menus.  For example, concrete
strength f'c and reinforcement strengths fy and fys may be defined from RC Design >
Design Criteria > RC Materials.  

You may add standard steel and concrete materials by clicking the “Std Materials”
button.  A standard material label starts with “Steel” or “Concrete”. 

You may add one or more materials by clicking the “New Rows” button.  You may
also print all materials in the list by clicking the “Print” button.  The “Assign active
material to currently selected elements” checkbox may be used to assign the active
material to selected elements.  The active material refers to the one that currently has
focus in the list in the dialog box.  In order for material assignments to take place,
members, shells or bricks must be selected beforehand.  

A more flexible way to assign material and other properties to entities is to use
Assign > Member Properties or Assign > Shell Properties command, which
allows you to continuously assign one or more properties to entities.

The program always has a default material labeled “Default”.  You may not delete this
material or change its label.  You may, however, change its properties.
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Figure 4.1

2.4.2 Member Sections

Geometry > Member Sections prompts you with the following dialog box (Figure 4.2).
 It allows you to define and/or assign sections to selected members in the model.  An
Id is assigned automatically to each section by the program and may not be changed.
 You may assign a label with 127 maximum characters to each section for easy
identification.  The section properties include:

· moment of inertia about major axis (Iz)

· moment of inertia about minor axis (Iy)

· torsional moment of inertia (J)
· section area (A)
· shear area in the local y direction (Ay)

· shear area in the local z direction (Az). 
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These properties are used in the analysis.  Other properties (B, H, Tf and Tw) are

dimensions for regular sections such as rectangular, circular, wide flange sections. 
These dimensional properties are used for graphic rendering only (not used in
analysis).

You may add one or more sections by clicking the “New Rows” button.  You may also
print all sections in the list by clicking the “Print” button.  The “Assign active section to
currently selected members” checkbox may be used to assign the active section to
selected members.  The active section refers to the one that currently has focus in the
list in the dialog box.  In order for section assignments to take place, members must
be selected beforehand.

A more flexible way to assign member properties is to use Assign > Member
Properties command, which allows you to continuously assign one or more
properties to members.

Note: The section property input does not include Ixy – the product of inertia.  For a
section where Ixy is not zero such as an angle, the principal axes of a cross section
are different from its geometric axes.  In such situations, you should enter section
properties in its principal axes and adjust the member element local angle
accordingly.

Figure 4.2

You may add a regular section by clicking the “Regular Section” button.  The program
displays the following dialog box (Figure 4.3).  Three regular sections are currently



83

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Menus

provided by the program, namely rectangular, circular, wide flange and Tee sections. 
The properties of these sections are calculated automatically.

Figure 4.3

Figure 4.4



84

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Menus

You may also add sections from the AISC steel shape table (Figure 4.4) or NDS
wood shape table.  You should not modify an AISC or NDS shape label or its
properties.

You may create one and only one rigid link section for use in the model by simply click
“Rigid Link” button.  A rigid link is a member that has very large sectional properties
(A, Ay, Az, Iz, Iy and J).  There can only be one rigid link section defined in the model
and it must be named as “RIGID_LINK”.  The properties for the RIGID_LINK section
must be set to 0’s on the member section dialog box.  The program will appropriately
calculate A, Ay, Az, Iz, Iy and J during the solution process. Self weight for rigid
links will be ignored by the program.

The program always has a default section labeled “Default”.  You may not delete this
section or change its label.  You may, however, change its properties.

2.4.3 Shell Thicknesses

Geometry > Shell Thicknesses prompts you with the following dialog box (Figure 4.5).
 It allows you to define and/or assign thicknesses to selected shells in the model.  An
Id is assigned automatically to each thickness by the program and may not be
changed.  You may assign a label with 127 maximum characters to each thickness for
easy identification.  The thickness properties include thickness only.
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Figure 4.5

You may add one or more thicknesses by clicking the “New Rows” button.  You may
also print all thicknesses in the list by clicking the “Print” button.  The “Assign active
thickness to currently selected shells” checkbox may be used to assign the active
thickness to selected shells.  The active thickness refers to the one that currently has
focus in the list in the dialog box.  In order for thickness assignments to take place,
shells must be selected beforehand.

A more flexible way to assign shell properties is to use Assign > Shell Properties
command, which allows you to continuously assign one or more properties to shells.

The program always has a default thickness labeled “Default”.  You may not delete
this thickness or change its label.  You may, however, change its properties.



86

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Menus

2.4.4 Levels

Geometry > Levels prompts you with the following dialog box (Figure 4.6).  It allows
you to define physical levels in the model.  Once levels are defined, you are able to
view a level plan by using the command View > Freeze All Except Level.  To unfreeze
the frozen parts of the model, click View > Thaw.

Figure 4.6

2.4.5 Drawing Grid

Geometry > Drawing Grid prompts you with the following dialog box (Figure 4.7).  It
allows you to generate a 1D, 2D or 3D rectangular grid for drawing or guidance.  The
distance list is a comma separated list that specifies multiple distances.  For example,
a distance list of “12, 2@14, 3@10” will generate distances of 12, 14, 14, 10, 10 and
10 in length units.  You may specify a distance list for the X, Y, or Z direction or any
combination of them.  
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Figure 4.7

You may specify an insertion point to translate and rotation parameters to rotate the
grid.  The drawing grid may be turned on or off by running the command View >
Options > Drawing Grid or by simply pressing F7.  You may regard the grid as a user
defined coordinate system that can be changed at any time.  The coordinates of the
grid intersection under the mouse are displayed in the status bar.  It helps you to
identify correct points when drawing nodes or elements.  The following example
(Figure 4.8) shows the use of this command.



88

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Menus

Figure 4.8

2.4.6 Object Snap

The Geometry > Object Snap pop-up menu provides options to snap node locations

at 1/2, 1/3, … 1/9th points on a member under the mouse cursor.  If you are drawing
elements, you also have the option to snap to the perpendicular point on a member
from the last point.  It is a good idea to turn off the drawing grid (by pressing F7) to
avoid snapping to grid points while any of the snap options is on.

Figure 4.9
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2.4.7 Draw Node

Geometry > Draw Node allows you to draw new nodes in the model.  To draw a
node, simply move the mouse, point to an intersection of the grid and click the left
mouse button.  You may also draw a node by entering nodal X, Y, and Z (optional)
coordinates in the command window via the keyboard.  This is very useful if you need
to draw nodes outside the grid interactions.  The command remains in effect until
another command is selected, the right mouse button is clicked, or ESC is pressed.

2.4.8 Draw Member

Geometry > Draw Member allows you to draw new members in the model.  To draw
a member, simply move the mouse and click the left mouse button from point to point
(Figure 4.10).  The clicked points must be intersections on the grid or existing nodes. 
These points become the element nodes.  New nodes are created if necessary. 
Members are drawn continuously.  Right clicking the mouse once lets you start
drawing members from a new location.  Remember, the start and end nodes
determine the default local coordinate system.  The members drawn have the current
section and material properties.  You may use the commands in the Geometry menu
to assign appropriate properties to them.

Figure 4.10
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You may also specify a node by entering nodal X, Y and Z (optional) coordinates in
the command window via the keyboard.  This is very useful if you need to specify
nodes outside the grid interactions.  In addition, you may specify a node by entering
an existing node number directly.  You can combine the use of keyboard and mouse
to draw members.

You may turn on annotations for nodes and members while drawing.  To do that, click
View > Annotate.  The command remains in effect until another command is selected,
the right mouse button is clicked twice, or ESC is pressed.

Figure 4.11

2.4.9 Draw Shell

Geometry > Draw Shell allows you to draw new shells in the model.  To draw a shell,
simply move the mouse and click the left mouse button from point to point (Figure
4.10).  The clicked points must be intersections on the grid or existing nodes.  These
points become the element nodes.  New nodes are created if necessary.  Remember,
the order of clicked points determines the default local coordinate system.  The
shells drawn have the current thickness and material properties.  You may use the
commands in the Geometry menu to assign appropriate properties to them.
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You may also specify a node by entering nodal X, Y, and Z (optional) coordinates in
the command window via the keyboard.  This is very useful if you need to specify
nodes outside the grid interactions.  In addition, you may specify a node by entering
an existing node number directly.  You can combine the use of keyboard and mouse
to draw shells.

You may turn on annotations for nodes and shells while drawing.  To do that, click
View > Annotate.  The command remains in effect until another command is selected,
the right mouse button is clicked, or ESC is pressed.

2.4.10 Draw Brick

Geometry > Draw Brick allows you to draw new bricks in the model.  To draw a brick,
simply move the mouse and click the left mouse button from point to point (Figure
4.11).  The grid must be set up in 3 dimensions.  The clicked points must be
intersections on the grid or existing nodes.  These points become the element nodes. 
New nodes are created if necessary.  Remember, the order of clicked points must be
such that the vector of the surface 1-2-3-4 points to the surface 5-6-7-8.  The bricks
drawn have the current material properties.  You may use the commands in the
Geometry menu to assign appropriate properties to them.

You may also specify a node by entering nodal X, Y, and Z coordinates in the
command window via the keyboard.  This is very useful if you need to specify nodes
outside the grid interactions.  In addition, you may specify a node by entering an
existing node number directly.  You can combine the use of keyboard and mouse to
draw bricks.
 
You may turn on annotations for nodes and bricks while drawing.  To do that, click
View > Annotate.  The command remains in effect until another command is selected,
the right mouse button is clicked, or ESC is pressed.
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Figure 4.11

It is generally not easy to draw bricks in 3 dimensions due to visualization difficulty. 
You may generate bricks based on shells using the commands such as Edit > Extrude
or Revolve.  You may also use spreadsheets to input nodes and bricks by running
Input Data > Nodes or Bricks. 

2.4.11 Generate

The Geometry > Generate pop-up menu provides commands to quickly generate
commonly used structural components in a model.  These commands may be used
multiple times to generate different parts in the model. 

2.4.11.1 Generate > Nodes from Grid

Geometry > Generate > Nodes from Grid will convert all grid points to nodes in one
sweep.  You may use this command as many times as you like.  You must merge
nodes manually if necessary.  The generated nodes may then be used to generate
members, shells, or bricks using the following three commands.

2.4.11.2 Generate > Members by Nodes

Geometry > Generate > Members by Nodes allows you to quickly generate new
members based on selected base members and existing nodes.  New members are
skipped if no valid nodes exist.  The following five figures (Figure 4.12 - 4.16) show
how this command may be used.

Figure 4.12
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Given one selected member and existing nodes in Figure 4.12 and using the input in
Figure 4.13, 10 new members in Figure 4.14 are generated.  

Figure 4.13

Figure 4.14

By selecting all 11 members in Figure 4.14 and using the input in Figure 4.15, 33 more
members are generated in Figure 4.16.
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Figure 4.15

Figure 4.16

2.4.11.3 Generate > Shells by Nodes

Geometry > Generate > Shells by Nodes allows you to quickly generate new shells
based on selected base shells and existing nodes.  New shells are skipped if no valid
nodes exist.  The concept in this command is similar to Generate > Members by
Nodes.
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2.4.11.4 Generate > Bricks by Nodes

Geometry > Generate > Bricks by Nodes allows you to quickly generate new bricks
based on selected base bricks and existing nodes.  New bricks are skipped if no valid
nodes exist.  The concept in this command is similar to Generate > Members by
Nodes.

2.4.11.5 Generate > Non-Prismatic Members

Geometry > Generate > Non-Prismatic Members prompts you with the following
dialog box (Figure 4.17).  It allows you to quickly convert each of the selected
prismatic members into multiple prismatic members to approximate a non-prismatic
member. The distance list is a comma separated list that specifies multiple distances.
 For example, a distance list of “12, 2@14, 3@10” will generate distances of 12, 14,
14, 10, 10 and 10 in length units.  The lengths of the selected prismatic members
must be consistent with the distance list.

Figure 4.18

The left and right haunches of the non-prismatic members may be of type linear,
parabolic or straight.  You must define the geometry (Figure 4.7) including middle
depth (DM), left depth (DL), right depth (DR), width, left length ratio (LL / L), right
length ratio (LR / L).  Each of the selected prismatic members will be exploded into
multiple prismatic members to approximate the non-prismatic member’s behavior. 
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Appropriate member sections will be automatically added and assigned in the model. 
Existing loads on the selected prismatic members will be assigned to the new
members appropriately.

Figure 4.19

2.4.11.6 Generate > Arc Members

Geometry > Generate > Arc Members prompts you with the following dialog box
(Figure 4.20).  It allows you to quickly generate members along an arc. You may
specify an arc radius, the start and end angles, and the number of segments.  You
may specify an insertion point to translate and rotation parameters to rotate the
generate shells.  The generated members have the default section and material
properties.  You may assign them appropriate properties using commands in the
Assign Properties menu.
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Figure 4.20
 
The following example (Figure 4.21) shows members generated along an arc using
the input from Figure 4.20.

Figure 4.21
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2.4.11.7 Generate > Circular Shells

Geometry > Generate > Circular Shells prompts you with the following dialog box
(Figure 4.22).  It allows you to quickly generate shells in a circle.  You may specify
the number of segments to control the fineness of the mesh.  Generally speaking, a
relatively fine mesh is recommended to minimize the discretization error along the
curved edge.  The generated shells are mostly rectangular in shape, with some
general quadrilaterals along the edge.  You should not use rectangular thin plate
formulation in the analysis.  You may specify an insertion point to translate and
rotation parameters to rotate the generated shells.  The generated shells have the
default thickness and material properties.  You may assign them appropriate
properties using commands in the Assign Properties menu.

Figure 4.22
 
The following example (Figure 4.23) shows shells generated in a circle using the input
from Figure 4.22.
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Figure 4.23

2.4.11.8 Generate > Rectangular Shells

Geometry > Generate > Rectangular Shells prompts you with the following dialog box
(Figure 4.24).  It allows you to quickly generate shells in a rectangle.  The distance list
is a comma separated list that specifies multiple distances.  For example, a distance
list of “12,2@14,3@10” will generate distances of 12, 14, 14, 10, 10 and 10 in length
units.  You may specify an insertion point to translate and rotation parameters to
rotate the generated shells.  The generated shells have the default thickness and
material properties.  You may assign them appropriate properties using commands in
the Assign Properties menu.
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Figure 4.24

This command can only generate shells in a rectangle.  To generate shells in a
general quadrilateral, you may first define one quadrilateral shell and then use the
command Edit > Sub-Mesh Shells to sub-divide it.

The following example (Figure 4.25) shows a 10x10 rectangular mesh of shells
generated using the input from Figure 4.24.
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Figure 4.25

2.4.11.9 Generate > Cylindrical Frames

Geometry > Generate > Cylindrical Frames prompts you with the following dialog box
(Figure 4.26).  It allows you to quickly generate 2D or 3D cylindrical frames.  The
distance list is a comma separated list that specifies multiple distances.  For example,
a distance list of “12, 2@14, 3@10” will generate distances of 12, 14, 14, 10, 10 and
10 in length unit.  You may leave the Y direction distance list empty, in which case, a
plane cylindrical frame will be generated.  You may specify pinned or fixed supports at
the bottom.  The generated members have the default section and material
properties.  You may assign them appropriate properties using commands in the
Assign menu.
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Figure 4.26

You have the option not to generate members.  In this way, you can generate nodes
on cylindrical system first.  Then you may use the command Generate > Shells
(Bricks) by Nodes to generate a system of shell (brick) elements.

Using the input in Figure 4.26, a 3D cylindrical frame in Figure 4.27 is generated.  You
may need to set the element local angles for columns for correct orientation. 
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Figure 4.27

2.4.11.10 Generate > Rectangular Frames

Geometry > Generate > Rectangular Frames prompts you with the following dialog
box (Figure 4.28).  It allows you to quickly generate 1D frames (continuous beams),
2D frames (plane frame or grillage) or 3D frames (space frames).  The distance list is
a comma separated list that specifies multiple distances.  For example, a distance list
of “12, 2@14, 3@10” will generate distances of 12, 14, 14, 10, 10 and 10 in length
unit.  You may leave appropriate distance list(s) blank to generate on a plane or along
a line.  You may specify pinned or fixed supports at the bottom.  The generated
members have the default section and material properties.  You may assign them
appropriate properties using commands in the Assign Properties menu.
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Figure 4.28

The following three examples show the uses of this command.  The first example
(Figure 4.29) is a continuous beam in the X direction generated using the input from
the dialog box above.  The first two spans are of 10 ft and the last three spans are of
15 ft.  The pinned supports are also generated automatically.

Figure 4.29

The second example (Figure 4.30) is a 2D frame on the XY plane with horizontal
spans 10, 10, 18, 10, 10 ft and vertical spans 15, 8, 8, 8 ft as shown in the
following.  
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Figure 4.30

A rectangular frame is first generated using the input from the following dialog box
(Figure 4.31).  
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Figure 4.31

The frame is then modified by selecting and deleting nodes 19, 24, 25, 26, 29, 30 and
horizontal members at the bottom (Figure 4.32).  Notice when a node is deleted,
elements (and their dependents such as loads) connected to that node are
automatically deleted also.

Figure 4.32

The third example (Figure 4.33) is a 3D frame with 6 spans in the X direction, 4 spans
in the Z direction, and 10 spans in the Y direction.  All spans are 10 ft.  The frame is
fixed at the bottom.  
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Figure 4.33

It is generated using the input from Figure 4.34.
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Figure 4.34

2.4.12 Element Local Angle

Geometry > Element Local Angle prompts you with a dialog box (Figure 4.35) to
assign local angles to the selected members and/or shells.  The element local angle is
used to change the element local coordinate system.
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Figure 4.35

2.4.13 3-Point Member Orientation

Geometry > 3-Point Member Orientation prompts you with a dialog box to specify an
X, Y, and Z coordinate.  The orientation of selected members will be changed so the
local z-axis of all selected members is perpendicular to the plane formed by the two
member end coordinates and the specified X, Y, Z coordinate.

2.4.14 Moment Releases

Geometry > Moment Releases prompts you with the following dialog box (Figure
4.36).  It allows you to assign moment releases to selected members in the model. 
Major or minor moment releases may be applied to the start and/or end ends of the
members.  Trusses are members with moments fully released at both ends.  The
program assigns appropriate moment releases automatically if the model type is of
“2D Truss” or “3D Truss”.  However, if the model contains both trusses and beams,
you should use the model type “2D Frame” or “3D Frame”, and assign appropriate
moment releases to members.  In order for moment release assignments to take
place, members must be selected beforehand.
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Figure 4.36

2.4.15 Rigid Offset

Geometry > Rigid Offset prompts you with the above dialog box (Figure 4.37).  It
allows you to assign rigid offsets to the selected members.  This command will
effectively break each selected member into two or three members, with either or
both ends being rigid links.

Figure 4.37

2.4.16 Tension/Compression Only

Geometry > Tension/Compression Only prompts you with the above dialog box
(Figure 4.38).  It allows you to assign nonlinearity (linear, tension only or compression
only) to the selected members.  The member stiffness will be ignored if a tension only
member is subjected to compressive forces or if a compression only member is
subjected to tensile forces. The presence of tension only or compression only
members makes the model nonlinear and requires iterative solution for each load
combination.
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Figure 4.38

2.4.17 Convert Members to Rigid Links

Geometry > Convert Members to Rigid Links will convert selected members to rigid
links. 

2.4.18 Element Activation

Geometry > Element Activation allows members, shells, and/or bricks to be
selectively activated or deactivated.

This allows these modeling entities to remain in the model while studying the effects of
ignoring their structural contributions to the model.

2.4.19 Supports

2.4.19.1 Support

Geometry > Supports > Support prompts you with the following dialog (Figure 4.39). 
 It allows you to assign supports (rigid boundary conditions) to selected nodes in the
model.  One or more of the six global degrees of freedom (DOFs) may be restrained.
 In addition, you may specify enforced displacements in the restrained DOFs.  The
enforced displacements may be used to model support settlements.  You may regard
them as special loads.  For normal supports, enforced displacements in the restrained
DOFs are zero.  The program provides three commonly used supports, namely,
pinned, fixed and roller.  In order for support assignments to take place, nodes must
be selected beforehand.  

After clicking “Assign”, you can start to continuously assign supports by window-
selecting nodes until you right click the mouse or press the ESC key.
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Figure 4.39

2.4.19.2 Inclined Roller

Geometry > Multi-DOF Constraints > Inclined Rollers prompts you with the following
dialog box (Figure 4.40).  It allows you to define an inclined roller support on XY, YZ
or XZ plane. An inclined roller can only move along the line between the reference
point (defined in the dialog) and the support location.  For example in Figure 4.44, the
roller is located at coordinate (8.0, 5.0, 0) and is inclined 30 degrees from the X-axis.
 We can use the reference point (8.0 + 10 * cos30, 5 + 10 * sin30, 0) = (16.666, 10,
0) to constrain the support.  An inclined roller is a type of multi-DOF constraint.  

A regular support and multi-DOF constraints may be applied on the same node as
long as the support/constrained directions do not interfere with each other.

Multi-DOF constraint forces and moments are listed separately from the regular
support reactions in the analysis results.
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Figure 4.40

Figure 4.41

Geometry > Supports > Inclined Rollers prompts you with the following dialog box
(Figure 4.41).  It allows you to define a reference point.  When applied to selected
nodes, the inclined roller can only move along a line between the reference point and
the support location.



114

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Menus

2.4.20 Springs

Geometry > Springs prompts you with the following dialog (Figure 4.42).  

Figure 4.42

It allows you to assign nodal, line, and surface springs (flexible boundary conditions)
to selected nodes, members, or shells in the model (Figure 4.43).  A nodal spring may
be restrained in one or more of the six global DOFs (Dx, Dy, Dz, Dox, Doy and Doz).

 A line or surface spring may be restrained in one or more of the three global
translational DOFs (Dx, Dy and Dz).  To qualify to be a valid flexible restraint, the

corresponding spring constant must be specified.
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Figure 4.43

A restraint may be designated as linear, compression-only or tension only.  A
compression-only restraint is active only when the nodal displacement in the
restrained direction is negative.  A tension-only restraint is active only when the nodal
displacement in the restrained direction is positive.  The presence of tension only or
compression only springs makes the model nonlinear and requires iterative solution for
each load combination.

After clicking “Assign”, you can start to continuously assign nodal, line or surface
springs by window-selecting nodes, members or shells until you right click the mouse
or press the ESC key.

2.4.21 Diaphragms

Geometry > Diaphragms prompts you with the following dialog box (Figure 4.44).  It
allows you to define regular or generic rigid diaphragms (in-plane) in a 3D model.  For
example, to model horizontal concrete floors, you may select one node on each floor
and apply regular diaphragms to the selected nodes in XZ plane (with normal in the
global Y direction).  Instead of using plate elements, rigid diaphragms allow you to
model stiff in-plane actions quickly.  The program further provides the option to ignore
the rigid diaphragm actions as an analysis option (Analyze > Analysis Options).

Figure 4.44
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2.4.22 Master-Slave

2.4.22.1 Master-Slave

Geometry > Master-Slave > Master-Slave (Figure 4.45) prompts you with the
following dialog box (Figure 4.45).  It allows you to define a generic constraint at one
or two nodes.   An equal displacement constraint is one type of multi-DOF
constraint.  

A regular support and multi-DOF constraints may be applied on the same node as
long as the support/constrained directions do not interfere with each other.

Multi-DOF constraint forces and moments are listed separately from the regular
support reactions in the analysis results.

Figure 4.45

2.4.22.2 Generic Displacement Constraint

Geometry > Master-Slave > Generic Constraints (Figure 4.46) prompts you with the
following dialog box (Figure 4.46).  It allows you to define a generic constraint at one
or two nodes. If the constraint is applied to the same node, the constraint DOFs must
be different.  Constrained DOFs must be compatible: Q1 and Q2 must be both
translational or rotational.  Constraint factors must be non-zero.

A regular support and multi-DOF constraints may be applied on the same node as
long as the support/constrained directions do not interfere with each other.

Multi-DOF constraint forces and moments are listed separately from the regular
support reactions in the analysis results.



117

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Menus

Figure 4.46

2.4.23 Story Drift Nodes

Geometry > Story Drift Nodes prompts you with the following dialog box (Figure
4.47).  It allows you to enter nodes that will be used for floor drift calculation. 

An empty row is allowed if all rows below it do not contain any non-empty fields. 
Selected rows (whole row must be selected) may be cut by clicking the button “Cut
Selected Rows”.
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Figure 4.47

2.5 Loads

The Loads menu provides commands to define load cases and combinations, and
assign loads of various types to selected nodes and elements.

2.5.1 Load Cases

Loads > Load Cases prompts you with the following dialog box (Figure 5.1).  It allows
you to define load cases to be used for loads and load combinations.  A number is
assigned to each load case automatically by the program.  You may assign a label
with 127 maximum characters to each load case for easy identification.  Duplicate
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labels in load cases are not allowed.  A load type specifies the characteristics of the
load case.  Examples are DEAD, LIVE, WIND, EARTHQUAKE.  They are used to
generate standard load combinations in Loads > Load Combinations.

Figure 5.1

You may add one or more load cases by clicking the “New Rows” button.  You may
also print all load cases in the list by clicking the “Print” button.  

The program always has a default load case labeled “Default”.  You may not delete
this load case or change its label.  You may however change its type.

2.5.2 Load Combinations

Loads > Load Combinations prompts you with the following dialog box (Figure 5.2).  It
allows you to define combinations of existing load cases in the model.  The program
solves for load combinations but not for load cases.  You may assign a label with 127
maximum characters to each load combination for easy identification.  Duplicate labels
in load combinations are not allowed.  
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You may add one load combination by clicking the “Add” button.   You may then
define the new load combination in the following dialog box (Figure 5.3).  The definition
includes a label with 127 maximum characters, a load factor for each load case, and a
P-Delta flag.  A load factor of zero excludes the respective load case from
participating in the load combination.  You may print all load cases and their
corresponding load factors in the list by clicking the “Print” button.  

If you need to design concrete beams, columns and/or plates, check or uncheck
“Perform Concrete Design using this Load Combination”.  In addition, a sustained load
factor must also be entered.  This is the load factor that applies to the sustained load
cases included in this load combination.  It is used to compute the infamousduring
concrete column design.  Therefore, if there are concrete columns to be designed,
you should define a separate load combination that contains only sustained load cases
(each case with a unit factor).  You can then designate this load combination as the
sustained load combination by RC Design > Design Options before performing
concrete design.

If you need to design steel members, check or uncheck “Perform Steel Design using
this Load Combination”.  If you need to use the load combination to check total or live
load deflection, check or uncheck appropriate boxes.

You may modify, copy, or delete a load combination by clicking the “Modify”, “Copy”,
or “Delete” button.  You may also create a load combination for every load case with
a unit load factor for the load case but zeros for the rest of the load cases.  To do
that, click the “Unit Cases” button.

You may also generate standard load combinations based on design codes such as
ACI 318-02/05/08/11 by clicking the button “Generate Std”.

There must be at least one load combination in a model.
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Figure 5.2

Figure 5.3
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2.5.3 Nodal Loads

Loads > Nodal Loads prompts you with the following dialog box (Figure 5.4).  It allows
you to assign nodal loads to selected nodes in the model.  You must select a load
case to which the nodal loads belong.  Nodal loads are specified in the global
coordinate system.  The loads are nodal forces in the X, Y, or Z direction if radio
button “X”, “Y”, or “Z” is selected.  The loads are nodal moments in the X, Y, or Z
direction if radio button “OX”, “OY”, or “OZ” is selected.  The load magnitude may be
any non-zero value.

Figure 5.4

2.5.4 Point Loads

Loads > Point Loads prompts you with the above dialog box (Figure 5.5).  It allows
you to assign point loads to selected members in the model.  You must select a load
case to which the point loads belong.  Point loads may be specified in either the local
or global coordinate system.  The loads are point forces in the X, Y, or Z direction if
radio button “X”, “Y”, or “Z” is selected.  The loads are point moments in the X, Y, or
Z direction if radio button “OX”, “OY”, or “OZ” is selected.  The load magnitude may
be any non-zero value.  The load distance is the ratio of the load location (measured
from the member start) to the member length.  A distance of 0.5 places the load at
the middle of each selected member.
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Figure 5.5

2.5.5 Line Loads

Loads > Line Loads prompts you with the following dialog box (Figure 5.6).  It allows
you to assign line loads to selected members in the model.  You must select a load
case to which the line loads belong.  Line loads may be specified in either the local or
global coordinate system.  The loads are line forces in the X, Y, or Z direction.  The
start and end magnitudes of the load may be zero for either end but not for both.  The
load distances are the ratios of the load start and end locations (measured from the
member start) to the member length.  A start distance of 0.0 and an end distance of
1.0 place the line load on the entire span of each selected member.
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Figure 5.6

2.5.6 Area Loads

Loads > Area Loads prompts you with the following dialog box (Figure 5.7).  It allows
you to assign area loads to enclosed areas of members in the model.  You must
select a load case to which the area loads belong.  Area loads may be specified in
either the local or global coordinate system.  Global area loads may be in the global
X, Y, or Z direction.  Local area loads may only be in the local z direction, which is
perpendicular to the load area.

A load area is defined by specifying three or four coplanar nodes.  The area load is
then distributed as line loads to perimeter members of enclosed areas within the load
area prior to static or dynamic solution.  Various area load distribution methods are
available.  It is recommended that area loads be defined in their own load cases.  In
this way, you will find it easier to identify, edit, and delete area loads later on.

The program also allows you to convert area loads to line loads automatically.  This
feature lets you see how the program would convert the area loads prior to the
solution.  For more information on the load conversion, see Input Data > Area Loads.
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Figure 5.7

2.5.7 Surface Loads

Loads > Surface Loads prompts you with the following dialog box (Figure 5.8).  It
allows you to assign surface loads to selected shells in the model.  You must select a
load case to which the surface loads belong. Surface loads may be specified in either
the local or global coordinate system.  The loads are surface forces in the X, Y, or Z
direction.  Surface load applies to the entire surface of a shell element. 
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Figure 5.8

2.5.8 Thermal Loads

Loads > Thermal Loads prompts you with the following dialog box (Figure 5.9).  It
allows you to assign thermal loads to selected elements in the model.  You must
select a load case to which the surface loads belong. Currently, ENERCALC 3D
considers thermal effect in longitudinal direction of members, membrane directions of
shells, and bricks.  It does not consider thermal gradients in members or shells.

Figure 5.9
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2.5.9 Self Weights

Loads > Self Weights prompts you with the following dialog box (Figure 5.10).  It
allows you to define how the program computes self weights for all elements in the
model.  You must select a load case to which self weights belong.  The self weights
may act in the global X, Y, or Z direction.  By default, self weights act in the global Y
direction.  You may specify a self weight multiplier (applied to material densities).  A
zero multiplier ignore self weights altogether.

Figure 5.10

2.5.10 Self Weight Exclusion

Loads > Self Weight Exclusion allows self weight to be considered or ignored for
selected members, shells, and bricks. 

2.5.11 Generate Loads

2.5.11.1 Generate Loads > Fluid Loads

Loads > Generate Loads > Fluid Loads prompts you with the dialog box above
(Figure 5.11).  It allows you to generate fluid loads applied to selected shells in the
model.  You must select a load case to which the fluid loads belong.  Fluid loads are
applied in the local coordinate system.  The load variation must be in global X, Y or Z
direction. 
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Figure 5.11

2.5.11.2 Generate Loads > Pattern Loads

Loads > Generate Loads > Pattern Loads prompts you with the following dialog box
(Figure 5.12).  It allows you to generate pattern loads applied to specified members in
the model.  You must select a load case (generally live case) that contains loads to
be patterned.  A pattern ratio (e.g., ACI 318-05 specifies 0.75) is also available. Load
patterning allows us to generate maximum positive and negative moment at each
span, maximum positive and negative moment at each support as well as maximum
shear at each support.  The existing point and line loads in the load case will be
patterned based on odd, even and adjacent/alternate spans.  These patterned loads
are assigned to their own load cases.  The program automatically generates
additional load cases and load combinations based on the load patterning.
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Figure 5.12

It should be pointed out that the program does not consider support conditions for
pattern load generation.  One pattern load case cannot be used in more than one load
combination prior to load pattern generation.

2.5.11.3 Generate Loads > Moving Loads

Loads > Generate Loads > Moving Loads prompts you with the dialog box above
(Figure 5.13).  It allows you to generate moving loads applied to specified members in
the model.  You must select a load case that contains moving loads.  Only point loads
on the specified members in the load case will be moved.  These moving loads are
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assigned to their own load cases.  The program automatically generates additional
load cases and load combinations based on the moving step size.

It should be pointed out that one moving load case cannot be used in more than one
load combination prior to moving load generation.

Figure 5.13

2.5.12 Case-Copy Loads

Loads > Case-Copy Loads prompts you with the following dialog box (Figure 5.14).  It
allows you to copy all loads from one load case to another.  You have the option to
delete existing loads in the target load case.  The loads copied may also be multiplied
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by a factor.  At least two load cases must exist in the model in order to use this
command.

Figure 5.14

2.5.13 Convert Area Loads to Line Loads

Loads > Convert Area Loads to Line Loads will convert all area loads to line loads in
every load case.  This is useful in checking how area loads would be converted during
the solution process.  You can always undo the area loads to line loads conversion.

2.5.14 Convert Local Loads to Global Loads

Loads > Convert Local Loads to Global Loads will convert all member point loads, line
loads and shell surface loads from local coordinate systems to global coordinate
system in every load case.  This is useful for data transfer from ENERCALC 3D to
Revit Structure using FastFrame Revit Link.  You can always undo the local loads to
global loads conversion.

2.5.15 Additional Masses

Loads > Additional Masses prompts you with the dialog box above (Figure 5.15).  It
allows you to assign additional masses and mass moment of inertia to selected
nodes.  The mass can be applied to X, Y and/or Z directions while the mass moment
of inertia can be applied to OX, OY and/or OZ directions.  Additional Masses are
added to the mass calculated from the load combination for frequency analysis (see
the command: Run > Frequency Analysis).  Mass moment of inertia values can only
be input using the Additional Masses command.
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The mass unit is a force unit divided by the acceleration of gravity, while the mass
moment of inertia has units of mass times length squared.  The acceleration of gravity
is taken as 386.09 in/sec^2 or 9.8 m/sec^2.

Figure 5.15

A more flexible way to assign additional masses is to use Assign > Additional
Masses command, which allows you to continuously assign additional masses to
nodes.

2.5.16 Response Spectra Library

Loads > Response Spectra Library prompts you with the dialog box below (Figure
5.16).  It allows you to define spectrums for current and future projects.  You can then
use one or more spectrums in  Run > Response Spectrum Analysis.

You may view/modify a user-defined spectrum by double clicking the spectrum (Figure
5.17).  The first spectrum can not be edited or deleted.  Spectra generated based on
building codes cannot be edited but can be deleted.
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Figure 5.16
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Figure 5.17

2.6 Assign

The Assign menu provides commands to continuously assign supports, springs, and
element properties to relevant objects (nodes and elements).  Unlike commands in
other menus, you do NOT need to select objects before running these commands.

2.6.1 Supports

Assign > Supports prompts you with the following dialog (Figure 6.1).   It allows you
to assign supports (rigid boundary conditions) to selected nodes in the model.  One or
more of the six global degrees of freedom (DOFs) may be restrained.  In addition,
you may specify enforced displacements in the restrained DOFs.  The enforced
displacements may be used to model support settlements.  You may regard them as
special loads.  For normal supports, enforced displacements in the restrained DOFs
are zero.  The program provides three commonly used supports, namely, pinned,
fixed and roller.  In order for support assignments to take place, nodes must be
selected beforehand.  
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After clicking “Assign”, you can start to continuously assign supports by window-
selecting nodes until you right click the mouse or press the ESC key.

Figure 6.1

2.6.2 Springs

Assign > Springs prompts you with the following dialog (Figure 6.2).  
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Figure 6.2

It allows you to assign nodal, line, and surface springs (flexible boundary conditions)
to selected nodes, members, or shells in the model (Figure 6.3).  A nodal spring may
be restrained in one or more of the six global DOFs (Dx, Dy, Dz, Dox, Doy and Doz).

 A line or surface spring may be restrained in one or more of the three global
translational DOFs (Dx, Dy and Dz).  To qualify to be a valid flexible restraint, the

corresponding spring constant must be specified.

Figure 6.3
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A restraint may be designated as linear, compression-only or tension only.  A
compression-only restraint is active only when the nodal displacement in the
restrained direction is negative.  A tension-only restraint is active only when the nodal
displacement in the restrained direction is positive.  The presence of tension only or
compression only springs makes the model nonlinear and requires iterative solution for
each load combination.

After clicking “Assign”, you can start to continuously assign nodal, line or surface
springs by window-selecting nodes, members or shells until you right click the mouse
or press the ESC key.

2.6.3 Member Properties

Assign > Member Properties prompts you with the following dialog (Figure 6.4).  It
allows you to assign one or more properties such as material, section etc to
members.  Make sure the “Use” checkbox by each property is set correctly.  After
clicking “Assign”, you can start to continuously assign all checked properties by
window-selecting members until you right click the mouse or press the ESC key.
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Figure 6.4

2.6.4 Shell Properties

Assign > Shell Properties prompts you with the following dialog (Figure 6.5).  It allows
you to assign one or more properties such as material, thickness etc to shells.  Make
sure the “Use” checkbox by each property is set correctly.  After clicking “Assign”, you
can start to continuously assign all checked properties by window-selecting shells
until you right click the mouse or press the ESC key.
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Figure 6.5

2.6.5 Nodal Loads

Assign > Nodal Loads prompts you with the following dialog box (Figure 6.6).  It
allows you to assign nodal loads to selected nodes in the model.  You must select a
load case to which the nodal loads belong.  Nodal loads are specified in the global
coordinate system.  The loads are nodal forces in the X, Y, or Z direction if radio
button “X”, “Y”, or “Z” is selected.  The loads are nodal moments in the X, Y, or Z
direction if radio button “OX”, “OY”, or “OZ” is selected.  The load magnitude may be
any non-zero value.
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Figure 6.6

2.6.6 Point Loads

Assign > Point Loads prompts you with the above dialog box (Figure 6.7).  It allows
you to assign point loads to selected members in the model.  You must select a load
case to which the point loads belong.  Point loads may be specified in either the local
or global coordinate system.  The loads are point forces in the X, Y, or Z direction if
radio button “X”, “Y”, or “Z” is selected.  The loads are point moments in the X, Y, or
Z direction if radio button “OX”, “OY”, or “OZ” is selected.  The load magnitude may
be any non-zero value.  The load distance is the ratio of the load location (measured
from the member start) to the member length.  A distance of 0.5 places the load at
the middle of each selected member.

Figure 6.7
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2.6.7 Line Loads

Assign > Line Loads prompts you with the following dialog box (Figure 6.8).  It allows
you to assign line loads to selected members in the model.  You must select a load
case to which the line loads belong.  Line loads may be specified in either the local or
global coordinate system.  The loads are line forces in the X, Y, or Z direction.  The
start and end magnitudes of the load may be zero for either end but not for both.  The
load distances are the ratios of the load start and end locations (measured from the
member start) to the member length.  A start distance of 0.0 and an end distance of
1.0 place the line load on the entire span of each selected member.

Figure 6.8

2.6.8 Surface Loads

Assign > Surface Loads prompts you with the following dialog box (Figure 6.9).  It
allows you to assign surface loads to selected shells in the model.  You must select a
load case to which the surface loads belong. Surface loads may be specified in either
the local or global coordinate system.  The loads are surface forces in the X, Y, or Z
direction.  Surface load applies to the entire surface of a shell element. 
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Figure 6.9

2.6.9 Additional Masses

Assign > Additional Masses prompts you with the dialog box above (Figure 6.10).  It
allows you to assign additional masses and mass moment of inertia to selected
nodes.  The mass can be applied to X, Y and/or Z directions while the mass moment
of inertia can be applied to OX, OY and/or OZ directions.  Additional Masses are
added to the mass calculated from the load combination for frequency analysis (see
the command: Run > Frequency Analysis).  Mass moment of inertia values can only
be input using the Additional Masses command.

The mass unit is a force unit divided by the acceleration of gravity, while the mass
moment of inertia has units of mass times length squared.  The acceleration of gravity
is taken as 386.09 in/sec^2 or 9.8 m/sec^2.
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Figure 6.10

2.6.10 Deletion

Assign > Deletion prompts you with the following dialog (Figure 6.11).  The input is
essentially the same as Edit > Delete.  After clicking “Assign”, you can start to
continuously delete objects by window-selecting nodes and elements until you right
click the mouse or press the ESC key.
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Figure 6.11

2.7 Input Data

The Tables menu provides commands to create or modify all input data of a model
using spreadsheets.  Spreadsheets provide an alternative method to the graphic input
described in earlier chapters.  You may combine both methods to create a model
quickly.

The spreadsheets support the common clipboard actions such as “CTRL+X” to cut,
“CTRL+C” to copy and “CTRL+V” to paste data.  You may even share data between
the spreadsheets in the ENERCALC 3D and other spreadsheet programs such as
Microsoft Excel.  For example, you may generate node data in an Excel spreadsheet,
copy the nodal coordinate data and paste to the Nodes spreadsheet in the program. 
In this way, you can take advantage of the more powerful data manipulation functions
in the Excel. 

In each spreadsheet, you may add one or more rows by clicking the “New Row”
button.  You may also print data in the spreadsheet by clicking the “Print” button.  You
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have the option to view only the selected data.  To do that, click Settings > Data
Options and check the “Show only selected entities in spreadsheet”.  You may not
modify the data in the spreadsheet when this option is chosen. 

2.7.1 Materials

The Input Data > Materials command opens the Material Data table to display the
materials that have been defined in the current model.  It also offers assignment
options.

2.7.2 Sections

The Input Data > Sections command opens the Section Data table to display the
sections that have been defined in the current model.  It also offers assignment
options.

2.7.3 Shell Thicknesses

The Input Data > Shell Thicknesses command opens the Shell Thickness Data table to
display the thicknesses that have been defined in the current model.  It also offers
assignment options.

2.7.4 Nodes

Input Data > Nodes prompts you with the following dialog box (Figure 7.1).  It allows
you to enter nodes in a spreadsheet.  Each node includes the nodal coordinates and
the selection status.  You may not modify the node Ids. 

An empty row is allowed if all rows below it are empty (except the node Id and status
fields).  You may not delete the existing nodes in the dialog box.  To delete the
existing nodes, you must dismiss this dialog box and click Edit > Delete.

Due to machine inaccuracy of floating point values, some commands (such as Edit >
Rotate) may cause the presence of very small numerical coordinate values.  You may
round off these tiny values to be zeros by clicking the Round-off Coordinates button. 
The epsilon used for the round-off may be set from Settings > Data Options.  The
default epsilon value is 1e-10 and must be less than or equal to  1e-6.
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Figure 7.1

2.7.5 Members

Input Data > Members prompts you with the following dialog box (Figure 7.2). 
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Figure 7.2

It allows you to enter members in a spreadsheet.  Each member includes the Ids of
start and end nodes, the material and section Ids, the element local angle, and the
selection status.  You may not modify the member Id.  All other Ids must be valid
(defined).  Material and section combo boxes are provided for you to correctly pick
and apply proper material and section Ids to selected members.

An empty row is allowed if all rows below it are empty (except the member Id and
status fields).  You may not delete the existing members in this dialog box.  To delete
the existing members, you must dismiss this dialog box and click Edit > Delete.

2.7.6 Shells

Input Data > Shells prompts you with the following dialog box (Figure 7.3).  
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Figure 7.3

It allows you to enter shells in a spreadsheet.  Each shell includes the Ids of four
element nodes, the material and thickness Ids, the element local angle, and selection
status. You may not modify the shell Ids.  All other Ids must be valid (defined). 
Material and thickness combo boxes are provided for you to correctly pick and apply
proper material and thickness Ids to selected shells.

An empty row is allowed if all rows below it are empty (except the shell Id and status
fields).  You may not delete the existing shells in this dialog box.  To delete the
existing shells, you must dismiss this dialog box and click Edit > Delete.

2.7.7 Bricks

Input Data > Bricks prompts you with the following dialog box (Figure 7.4).  It allows
you to enter bricks in a spreadsheet.  Each brick includes the Ids of eight element
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nodes, the material Id and selection status.  You may not modify the brick Ids.  All
other Ids must be valid (defined).  The material combo box is provided for you to
correctly pick and apply proper material Ids to selected bricks.

Figure 7.4

2.7.8 Supports

Input Data > Supports prompts you with the following dialog box (Figure 7.5).  It
allows you to enter supports in a spreadsheet.  Each support includes the node Id, the
fixity flag, and enforced displacements for all restrained DOFs.  The node Ids must be
valid (defined).

The fixity flag is a string of 6 characters representing restrained DOFs in Dx, Dy …

Doz.  For each character in the flag, enter ‘1’ if the DOF is restrained and ‘0’ if

unrestrained.  For example, “111111” represents a fixed support while “111000”
represents a pinned support.  Enforced displacements may be applied to the
restrained DOFs.  They may be regarded as special loads and can be used to model
known support settlements.  For normal support, they are 0s.  Enforced
displacements applied to unrestrained DOFs will be discarded.    
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An empty row is allowed if all rows below it are empty.  Selected rows (whole row
must be selected) may be cut by clicking the button “Cut Selected Rows”.

Figure 7.5

2.7.9 Springs

Input Data > Springs offers options to access the tables for Nodal Springs, Line
Springs and Surface Springs.

2.7.9.1 Springs > Nodal Springs

Input Data > Springs > Nodal Springs prompts you with the following dialog box
(Figure 7.6). 
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Figure 7.6

It allows you to enter nodal springs in a spreadsheet.  Each nodal spring includes the
node Id, the spring non-linearity flag and six spring coefficients Kx, Ky …, Koz.  The

node Id must be valid (defined).

The spring flag is a string of 6 characters representing the spring non-linearity in three
translational DOFs (Dx, Dy, Dz) and three rotational DOFs (Dox, Doy, Doz).  For

each character in the flag, enter ‘0’ if the restrained DOF is linear, ‘1’ if compression-
only and ‘2’ if tension only.  For the unrestrained DOFs, just enter 0s for the
corresponding spring coefficients.

An empty row is allowed if all rows below it are empty.  Selected rows (whole row
must be selected) may be cut by clicking the button “Cut Selected Rows”.

2.7.9.2 Springs > Line Springs

Input Data > Springs > Line Springs offers options to access the table for Line
Springs.
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2.7.9.3 Springs > Surface Springs

Input Data > Springs > Surface Springs prompts you with dialog boxes similar to that
in Input Data > Springs > Nodal Springs.  However, only three translational DOFs Dx,

Dy, Dz are available for line or surface spring coefficients.

2.7.10 Member Releases

Input Data > Member Moment Releases prompts you with the following dialog box
(Figure 7.7).  It allows you to enter member moment releases in a spreadsheet.  Each
moment release includes the member Id, four 1-character release codes for major
moment release (the local oz), and minor moment release (the local oy) for both ends
of members.  Enter ‘1’ for the released local DOF and ‘0’ for the un-released local
DOF.  The member Id must be valid.

An empty row is allowed if all rows below it are empty.  Selected rows (whole row
must be selected) may be cut by clicking the button “Cut Selected Rows”.

Figure 7.7
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2.7.11 Diaphragms

Input Data > Diaphragms prompts you with the following dialog box (Figure 7.8).  It
allows you to enter generic or regular rigid diaphragms in a spreadsheet.  For a
generic diaphragm, four distinct nodes are required to define the diaphragm plane. 
For a regular diaphragm in global XZ, YZ and XY plane, only the first node is required
to define the diaphragm plane. 

An empty row is allowed if all rows below it are empty.  Selected rows (whole row
must be selected) may be cut by clicking the button “Cut Selected Rows”.

Rigid diaphragms may be used instead of plate finite elements to model stiff in-plane
actions such as concrete floors.  Internally, the program creates multiple in-plane rigid
links for each diaphragm prior to static or frequency analysis.  A rigid link is simply a
member with very large sectional properties that can be adjusted with the diaphragm
stiffness factor (see Settings > Data Options).  The larger the diaphragm stiffness
factor, the stronger the in-plane rigid diaphragm action is.  The presence of rigid links
with large diaphragm stiffness factor (say 1E10) could create numerical difficulties
during the solution if 64-bit floating point solver is used.  However, the unique 128-bit
floating point solver in ENERCALC 3D makes this problem nonexistent in that much
larger diaphragm stiffness factor (say 1E20) may be used without creating numerical
difficulties during solution.

The program further provides the option to ignore the rigid diaphragm actions as an
analysis option (Analyze > Analysis Options).
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Figure 7.8

2.7.12 Load Cases

Input Data > Load Cases command is identical to the one found in the Loads menu.  It
is provided here for convenience only.

2.7.13 Load Combinations

Input Data > Load Combinations command is identical to the one found in the Loads
menu.  It is provided here for convenience only.

2.7.14 Nodal Loads

Input Data > Nodal Loads prompts you with the following dialog box (Figure 7.9).  It
allows you to enter nodal loads in a spreadsheet.  Each nodal load includes the node
Id, the load direction, and magnitude.  The load direction is specified in the global
coordinate system.  The load is a force if the load direction is in the X, Y or Z
direction and moment if in the OX, OY or OZ.  The node Id must be valid (defined).
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An empty row is allowed if all rows below it do not contain any non-empty fields. 
Selected rows (whole row must be selected) may be cut by clicking the button “Cut
Selected Rows”.

Figure 7.9

2.7.15 Point Loads

Input Data > Point Loads prompts you with the following dialog box (Figure 7.10).  It
allows you to enter member point loads in a spreadsheet.  Each point load includes
the member Id, the load coordinate system, direction, magnitude, and distance.  The
load is a force if the load direction is in the X, Y or Z direction and moment if in the
OX, OY or OZ.  The load distance is the ratio of load location (measured from the
start of the member) to member length.  The member Id must be valid (defined).

An empty row is allowed if all rows below it are empty.  Selected rows (whole row
must be selected) may be cut by clicking the button “Cut Selected Rows”.
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Figure 7.10

2.7.16 Line Loads

Input Data > Line Loads prompts you with the following dialog box (Figure 7.11).  It
allows you to enter member line loads in a spreadsheet.  Each line load includes the
member Id, the load coordinate system, direction, start and end magnitudes, and the
start and end distances.  The load is a force in the local or global X, Y, Z directions. 
The load distances are the ratio of load start and end locations (measured from the
start of the member) to the member length.  The member Id must be valid (defined).

An empty row is allowed if all rows below it are empty.  Selected rows (whole row
must be selected) may be cut by clicking the button “Cut Selected Rows”.
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Figure 7.11

2.7.17 Area Loads

Input Data > Area Loads prompts you with the following dialog box (Figure 7.12).  It
allows you to enter member area loads in a spreadsheet.  Each area load includes
four node Ids, the load coordinate system, direction, load distribution, and load
magnitude.  The area load may be in global X, Y or Z direction, or in local Z direction.
 The four nodes form a quadrilateral load area and must be in the same plane.  Node-
4 may also be the same as Node-1, in which case the load area is a triangle.  Area
loads in one or all load cases may be converted to lines loads in their respective load
cases.

An empty row is allowed if all rows below it are empty.  Selected rows (whole row
must be selected) may be cut by clicking the button “Cut Selected Rows”.
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Figure 7.12

2.7.18 Surface Loads

Input Data > Surface Loads prompts you with the following dialog box (Figure 7.13). 
It allows you to enter shell surface loads in a spreadsheet.  Each surface load
includes the shell Id, the load coordinate system, direction, and magnitude.  The load
is always a force in the local or global X, Y or Z directions.  The shell Id must be valid
(defined).

An empty row is allowed if all rows below it are empty.  Selected rows (whole row
must be selected) may be cut by clicking the button “Cut Selected Rows”.
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Figure 7.13

2.7.19 Self Weights

The Input Data > Self Weights command is identical to the one found in the Loads
menu.  It is provided here for convenience only.
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2.7.20 Thermal Loads

2.7.20.1 Member Thermal Loads

Input Data > Thermal Loads > Member Thermal Loads displays a table of members
and their temperature increase (Figure 7.14). 

Figure 7.14

2.7.20.2 Shell Thermal Loads

Input Data > Thermal Loads > Shell Thermal Loads displays a table of shells and their
temperature increase (Figure 7.15). 
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Figure 7.15

2.7.20.3 Brick Thermal Loads

Input Data > Thermal Loads > Brick Thermal Loads displays a table of bricks and
their temperature increase (Figure 7.16). 
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Figure 7.16

2.7.21 Calculated Masses

Input Data > Calculated Masses prompts you with the following dialog box (Figure
7.17).  It allows you to view the masses calculated from the load combination for
frequency analysis set in Analyze > Frequency Analysis.  The program will
automatically convert all forces (not moments) in the positive or negative gravity
direction to masses and apply them in all available mass degrees of freedom.  
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Figure 7.17

Obviously, the calculated mass values cannot be modified.  However, you may
convert all the calculated masses to additional masses.  In this case, the “Convert
loads to masses” option in Analyze > Frequency Analysis will be turned off.  This
technique may be useful when you want to account for the influence of axial loads on
frequencies.

2.7.22 Additional Masses

Input Data > Additional Masses prompts you with the following dialog box (Figure
7.18).  It allows you to enter additional nodal mass and nodal mass moment of inertia
values.  Each nodal mass or mass moment of inertia includes the node Id, the mass
direction, and magnitude.  The mass direction is specified in the global coordinate
system.  The unit of measurement for mass is force divided by the acceleration of
gravity.  For mass moment of inertia, the unit of measurement is mass times length
units squared.  The acceleration of gravity is generally takes as a constant value of
386.09 in/sec^2 or 9.8 m/sec^2.  
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An empty row is allowed if all rows below it do not contain any non-empty fields. 
Selected rows (whole row must be selected) may be cut by clicking the button “Cut
Selected Rows”.

Figure 7.18

2.7.23 Response Spectra Library

Input Data > Response Spectra Library prompts you with the dialog box below
(Figure 7.19).  It allows you to define spectrums for current and future projects.  You
can then use one or more spectrums in  Run > Response Spectrum Analysis.

You may view/modify a user-defined spectrum by double clicking the spectrum (Figure
7.20).  The first spectrum can not be edited or deleted.  Spectra generated based on
building codes cannot be edited but can be deleted.
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Figure 7.19
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Figure 7.20

2.7.24 Story Drift Nodes

Input Data > Story Drift Nodes prompts you with the following dialog box (Figure
7.21).  It allows you to enter nodes that will be used for floor drift calculation. 

An empty row is allowed if all rows below it do not contain any non-empty fields. 
Selected rows (whole row must be selected) may be cut by clicking the button “Cut
Selected Rows”.
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Figure 7.21

2.7.25 Comments

Input Data > Comments prompts you with the following dialog box (Figure 7.22).  It
allows you to add or delete comments at different locations in the model.  You may
also add an individual comment using View > Options > Comment.  A comment must
be less than 256 characters in length.

An empty row is allowed if all rows below it do not contain any non-empty fields. 
Selected rows (whole row must be selected) may be cut by clicking the button “Cut
Selected Rows”.
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Figure 7.22

2.8 Analysis

The Analysis menu provides commands to set the analysis options and to perform
analyses.  For more information on analysis, please refer to "Technical Topics".

2.8.1 Analysis Options

Analysis > Analysis Options prompts you with the following dialog box (Figure 8.1).  It
allows you to set important options before performing analysis on the model.  

The “Model type” determines the type of the model to analyze.  Model type “3D
Frame & Shell” is the most general.  It has all six degrees of freedom (DOFs)
available to every node in the model.  Any model may be analyzed with this model
type.  However, computer memory or time may be wasted if a simpler model can be
used.
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Figure 8.1

Model type “2D Frame” may be used to model a 2D frame (beams and trusses)
structure in the XY plane.  Only three DOFs (Dx, Dy and Doz) are available to every

node in the model.  The rest of the DOFs are suppressed.  
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Model type “3D Truss” may be used to model 3D truss structures.  Only three DOFs
(Dx, Dy, and Dz) are available to every node in the model.  The rest of the DOFs are

suppressed.  If the model contains both 3D trusses and beams, “3D Frame & Shell”
model type must be used and appropriate moment releases assigned.

Model type “2D Truss” may be used to model 2D truss structures in the XY plane. 
Only two DOFs (Dx and Dy) are available to every node in the model.  The rest of the

DOFs are suppressed.  If the model contains both 2D trusses and beams, “2D
Frame” model type must be used and appropriate moment releases assigned.

Model type “2D Plate Bending” may be used to model 2D plate bending structures
such as flat slabs or mat foundations in the XY plane.  It uses only the plate bending
action of the shell formulation.  Only three DOFs (Dz, Dox and Doy) are available to

every node in the model.  The rest of the DOFs are suppressed.  The self weight
should be in either –Z or +Z direction depending on your sign convention for loads.

Model type “2D Plane Stress” may be used to model 2D plane stress structures such
as shear walls in the XY plane.  It uses only the membrane action of the shell
formulation.  Only two DOFs (Dx and Dy) are available to every node in the model. 

The rest of the DOFs are suppressed.

Model type “3D Brick” may be used to model 3D solid structures.  Only three DOFs
(Dx, Dy, Dz) are available to every node in the model.  The rest of the DOFs are

suppressed.

Non-linear convergence control includes the maximum iterations and axial force
tolerance between adjacent P-Delta iterations.  The maximum iterations apply to both
P-Delta analysis and analysis involving non-linear springs.  It is provided to avoid
excessive number of nonlinear iterations during the solution.  A default value of 10 is
usually sufficient.  Axial force tolerance between adjacent P-Delta iterations reflects
the actual convergence of the P-Delta analysis.  The default value of 0.5% should be
good for most cases.  It is a good idea to perform a linear analysis before the P-Delta
analysis.  In this way, you may identify any problems in the model before the more
rigorous analysis option is undertaken.

By default, the program considers shear deformations on members in the model.  You
must also set shear areas of member sections for this option to take effect.  To do
that, click Assign Properties > Sections.  You may ignore member shear deformations
by unchecking “Consider shear deformation on members”.  Generally, shear
deformations on members are insignificant.  However, you should check this option
when members are of relatively great depths.  Shear deformation, when considered,
applies to both the element stiffness matrix and local (segmental) deflections.
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The number of segments for member segmental output may be set from 1 to 127.  A
value of 20 segments is recommended in most cases.  More segments produce more
accurate results, but require more usage of computer memory.  The accuracy may be
reflected in the smoothness of moment, shear and deflection diagrams.  Since
member local deflection is computed based on the moment and shear diagrams, a
value of more than 20 segments may be needed if very accurate local deflection is
desired.

You may specify whether to use cracked section properties for the analysis.  The
cracking factors are specified by Input Data > Members, Input Data > Shells or RC
Design > Cracking Factors.  Cracking factors will not be applied until “Use cracked
section properties (Icr) for members and finite elements” is checked here.  This option
is given so that you do not need to reenter cracking factors if you decide to use gross
section properties in a different analysis run.

Usually, stresses in finite elements are not continuous across element boundary.  You
may average them for adjacent shells/bricks at nodes.  This usually makes the results
more accurate and the contours smoother.  However, it may also disguise insufficient
convergence for an unsatisfactory (coarse) finite element mesh.  Obviously, stress
averaging can only apply to adjacent elements that have compatible local coordinate
systems.  For planar elements, stress averaging should only apply to adjacent
elements that share the same local coordinate systems.  Special attention should be
given to shear stress averaging at supports since shears of adjacent elements may
have opposite signs.
 
By default, the program uses the MITC4 for shell bending formulation.  The MITC4 is
a thick plate formulation and accounts for the out-of-plane shear deformation. 
However, if the shell elements are all rectangular, you may use the classical Kirchhoff
plate bending formulation.  The Kirchhoff plate element is a thin plate formulation and
ignores the out-of-plane shear deformation.

For the membrane formulation of the shell element or of the brick element,
incompatible modes may be added to the standard isoparametric (compatible)
formulation.  The incompatible shell element models the in-plane bending more
accurately than the standard compatible element.  The incompatible brick element,
which produces much more accurate results than the compatible one, should almost
always be preferred.
 
There are three kinds of solvers available in ENERCALC 3D: 

Double precision 64-bit floating point Skyline solver:  
· standard solver similar to many analysis programs in the market
· enough for most structures

Double precision 64-bit floating point Sparse solver:



172

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Menus

· fastest, but lacks informative messages when something goes wrong during a
solution

· can only be used for static analysis
· useful to solve extremely large structural models
· offers an out-of-core approach to minimize the requirement of computer memory

Quad precision 128-bit floating point Skyline solver:
· provides an invaluable alternative for some large or numerically sensitive models

where the 64-bit floating point (double precision) solver may fail 
· extremely stable and accurate, but relatively slow
· the recommended solver if the model contains rigid diaphragms to avoid numerical

difficulties.

You have the option to consider rigid diaphragm actions during the solution.  This is
useful to ignore rigid diaphragms without deleting the existing diaphragms.

2.8.2 Static Analysis

Analysis > Static Analysis performs the static analysis of the model.  You should set
the appropriate analysis options before running this command.  To do that, just click
Analyze > Analysis Options.

A solver dialog box (Figure 8.2) is displayed showing the progress of the solver.  The
solver first solves all linear load combinations, then all nonlinear load combinations.  If
the model contains compression-only or tension-only springs, every load combination
is a nonlinear load combination.  Otherwise, only P-Delta load combinations are
nonlinear.  The nonlinear load combinations are solved iteratively and therefore may
require considerable solution time.

You may abort the solving process by pressing ESC if a non-sparse solver is used.
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Figure 8.2
 

2.8.3 Frequency Analysis

Analysis > Frequency Analysis prompts you with the following dialog box (Figure 8.3).
 It allows you to set important options before performing frequency analysis on the
model.  

The load combination for mass and stiffness must be specified.  If you want to input
nodal mass and/or mass moment of inertia directly, you may do so from Loads >
Additional Masses or Input Data > Additional Masses.  The load combination is also
used to form the correct stiffness matrix if the model response is not linear.

The number of modes is used to determine how many frequencies and mode shapes
are to be computed.  This value must be less than the total number of mass degrees
of freedom.  Practically speaking, only the lowest eigen modes are used for design
purposes.

The number of iteration vectors q is normally set as the minimum of (2 * p, p + 8),
where p is the number of modes requested [Ref. 1].  A higher convergence rate can
be achieved by using more iteration vectors.  This may be necessary if some eigen
modes are missing after the solution or if the solution becomes unstable.
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The tolerance of eigenvalues is used to measure the convergence of eigenvalues
during each successive solver iteration.  It is expressed as the following:
 (i = 1, 2, … number of requested modes)
where k is the subspace iteration counter.

A maximum number of subspace iterations is used to prevent excessive solution time.
 If the solver reaches this limit without convergence, the eigen results should not be
trusted.

Figure 8.3

2.8.4 Response Spectrum Analysis

Analysis > Response Spectrum Analysis prompts you with the dialog box below
(Figure 7.4).  It allows you to perform response spectrum analysis in global X, Y
and/or Z directions.  There are three mode combination methods available in the
program: CQC (complete quadratic combination), SRSS (Square root of sum of
squares) and ABSSUM (absolute sum). CQC method for modal combination is
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applicable to a wider class of structures and is therefore recommended method. 
Critical damping ratio (0 <= damp < 1.0) affects CQC results.  When critical damping
ratio is 0, CQC method is the same as SRSS method.

You must first run from Analysis > Frequency Analysis prior to running this command.
 Response spectra can be defined from Loads > Response Spectra Library or Input
Data | Response Spectra Library. Inertia forces in global direction X, Y or/and Z from
response spectrum analysis will be calculated and then converted to nodal loads.  

These nodal forces will be placed in respective load cases such as
INERTIA_LOADCASE_X_MODE_1, INERTIA_LOADCASE_X_MODE_2 etc.
Existing loads in these load cases will be deleted prior to the load conversion.  

In addition, response spectrum load combinations
INERTIA_LOADCOMB_X_MODE_1, INERTIA_LOADCOMB_X_MODE_2 etc. will
be created or recreated.  

Static analysis will be performed on spectrum load combinations (as well as normal
user-defined load combinations) automatically.  Modal combinations will be
subsequently calculated for results such as displacements, forces and stresses etc.
using CQC, SRSS or ABSSUM on the response spectrum load combinations.
Normally, modal combination results are all positive due to the sign lost during SRSS,
CQC and ABSSUM procedures.  However, you can choose to use signage for modal
combination results based on the dominant mode (with maximum participation factor)
in each global direction.  

Modal combination results is done in each global direction first.  Using directional
factors, these directional modal results will be combined into final modal combination
results, which can be added to any user-defined load combination results if non-zero
response spectrum load factor is specified in the load combination definition (see
Loads | Load Combinations).
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Figure 7.4

2.9 Analysis Result

The Analysis Results menu provides commands to view and print analysis results for
each load combination in spreadsheets.

2.9.1 Nodal Displacements

Analysis Result > Nodal Displacements displays the following dialog box (Figure 9.1).
 It allows you to view nodal displacements for each load combination.  The
displacements for each node include three translational components Dx, Dy and Dz
and three rotational components Dox, Doy and Doz.  You have the option to view the

displacements for the selected nodes only. 
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Figure 9.1

2.9.2 Story Drifts

Analysis Result > Story Drifts displays the following dialog box (Figure 9.2).  It allows
you to view story drifts for each load combination.  You have the option to view the
story drifts for the selected nodes only. 

Figure 9.2

2.9.3 Support Reactions

Analysis Result > Support Reactions displays the following dialog box (Figure 9.3).  It
allows you to view support reactions for each load combination.  The reactions for
each support include three force components Rx, Ry and Rz and three moment

components Rox, Roy and Roz.  You have the option to view the reactions for the

selected supports only.  



178

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Menus

Figure 9.3

2.9.4 Spring Reactions

2.9.4.1 Spring Reactions > Nodal

Analysis Result > Spring Reactions > Nodal displays the following dialog box (Figure
9.4).  It allows you to view nodal spring reactions for each load combination.  The
reactions for each nodal spring include three force components SRx, SRy and SRz
and three moment components SRox, SRoy and SRoz.  You have the option to view

the reactions for the selected nodal springs only.

Figure 9.4

2.9.4.2 Spring Reactions > Line

Analysis Result > Spring Reactions > Line displays the following dialog box (Figure
9.5).  It allows you to view line spring reactions for each load combination.  The
reactions for each line spring include three force components SRx, SRy and SRz. 
You have the option to view the reactions for the selected line springs only.
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Figure 9.5

2.9.4.3 Spring Reactions > Surface

Analysis Result > Spring Reactions > Surface displays the following dialog box (Figure
9.6).  It allows you to view surface spring reactions for each load combination.  The
reactions for each surface spring include three force components SRx, SRy and SRz.

 You have the option to view the reactions for the selected surface springs only.

Figure 9.6

2.9.5 Multi-DOF Constraint Forces & Moments

Analysis Result > Multi-DOF Constraint Forces & Moments displays the following
dialog box (Figure 9.7).  It allows you to view constraint forces and moments for each
load combination.  The value columns can be either constraint forces (for DOF X, Y
and Z) or moments (for DOF OX, OY and OZ).  
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Figure 9.7

2.9.6 Member End Forces & Moments

Analysis Result > Member End Forces & Moments displays the following dialog box
(Figure 9.8).  It allows you to view forces and moments at the ends of each member
for each load combination.  The end forces and moments include axial force Fx, major

shear Fy, minor shear Fz, torsion Mx, minor moment My, and major moment Mz.  You

have the option to view the end forces and moments for the selected members only.

Figure 9.8

2.9.7 Member Segmental Results

Analysis Result > Member Segmental Results displays the following dialog box
(Figure 9.9).  It allows you to view member segmental results for each load
combination.  The segmental results are shown at each segmental point designated
by a distance along the member. They include axial force Fx, major shear Fy, minor

shear Fz, torsion Mx, minor moment My, major moment Mz, major local deflection Dy,

and minor local deflection Dz. You have the option to view the segmental forces and

moments for the selected members only.
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Figure 9.9

2.9.8 Shell Forces & Moments

Analysis Result > Shell Forces & Moments displays the following dialog box (Figure
9.10).  It allows you to view shell forces and moments for each load combination.  The
shell forces and moments include in-plane normal forces Fxx, Fyy and shear force

Fxy; out-of-plane bending moments Mxx, Myy, Mxy; and out-of-plane shear forces

Vxx, Vyy.  You may specify the force and moment locations to be at the nodes and/or

the center of each shell by running Settings > Data Options.  You have the option to
view the forces and moments for the selected shells only.

Figure 9.10

2.9.9 Shell Principal Forces & Moments

Analysis Result > Shell Principal Forces & Moments displays the following dialog box
(Figure 9.11).  It allows you to view shell principal forces and moments for each load
combination.  The shell principal forces and moments include in-plane principal forces



182

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Menus

Fmax, Fmin and the principal angle F-angle; out-of-plane principal moments Mmax,

Mmin and the principal angle M-angle; out-of-plane principal shear force Vmax and the

principal angle V-angle.  You may specify the principal force and moment locations to
be at the nodes and/or the center of each shell by running Settings > Data Options. 
You have the option to view the principal forces and moments for the selected shells
only.

Figure 9.11

2.9.10 Shell Stresses [Top & Bottom]

Analysis Result > Shell Stresses displays the following dialog box (Figure 9.12).  It
allows you to view shell top or bottom stresses for each load combination.  The shell
stresses include three normal components Sxx, Syy, Szz and three shear components

Sxy, Sxz and Syz.  You may specify the stress locations to be at the nodes and/or the

center of each shell by running Settings > Data Options. You have the option to view
the stresses for the selected shells only.
 

Figure 9.12
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2.9.11 Shell Principal Stresses

Analysis Result > Shell Principal Stresses displays the following dialog box (Figure
9.13).  It allows you to view shell top or bottom principal stresses and Von Mises
stresses for each load combination.  You may specify the stress locations to be at the
nodes and/or the center of each shell by running Settings > Data Options. You have
the option to view the stresses for the selected shells only.

Figure 9.13

2.9.12 Shell Nodal Resultants

Analysis Result > Shell Nodal Resultants displays the following dialog box (Figure
9.14).  It allows you to view shell nodal resultants for each load combination.  The
nodal resultants are concentrated forces and moments at element nodes that keep
individual elements in equilibrium.  They are expressed in the local coordinate system.
 You have the option to view the nodal resultants for the selected shells only.

Figure 9.14
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2.9.13 Brick Stresses

Analysis Result > Brick Stresses displays the following dialog box (Figure 9.15).  It
allows you to view brick stresses for each load combination.  The brick stresses
include three normal components Sxx, Syy, Szz and three shear components Sxy, Syz
and Sxz.  You may specify the stress locations to be at the nodes and/or the center of

each brick by running Settings > Data Options.  You have the option to view the
stresses for the selected bricks only.

Figure 9.15

2.9.14 Brick Principal Stresses

Analysis Result > Brick Principal Stresses displays the following dialog box (Figure
9.16).  It allows you to view brick principal stresses and Von Mises stresses for each
load combination.  Brick principal stresses are shown at locations of nodes and/or
center of each shell.  You may control the locations by running Settings > Data
Options.  Brick principal stresses include three principal components S1, S2, S3 and

direction vectors (V1x, V1y and V1z) and (V3x, V3y and V3z).  You have the option to

view the principal stresses for selected bricks only. 
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Figure 9.16

2.9.15 Eigenvalues

Analysis Result > Eigenvalues displays the following dialog box (Figure 9.17).  It
allows you to view eigenvalues (λ) and their derivatives such as periods (T),
frequencies (f), and circular frequencies (ω ).  In addition, an error measure is
calculated for each eigenvalue according to the following (see Ref. 1):

Error Measure = 

Where is the vector in the matrix corresponding to .

Figure 9.17

2.9.16 Eigenvectors

Analysis Result > Eigenvectors displays the following dialog box (Figure 9.18).  It
allows you to view eigenvectors (mode shapes) for each mode of vibration.  It is
worthwhile to point out that eigenvectors are meaningful only in their relative values.
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Figure 9.18

2.9.17 Mode Participation Factors

Analysis Result > Mode Participation Factors displays the following dialog box (Figure
9.19).  It allows you to view mode participation factors for each mode in global X, Y
and Z directions.  You must perform response spectrum analysis beforehand.

Figure 9.19

2.9.18 Modal Displacements SX, SY and SZ

Analysis Result > Modal Displacements > Modal Displacements SX, SY and SZ
displays the following dialog box (Figure 9.20).  It allows you to view modal
displacements for each mode as well as their SRSS combination in global X, Y and Z
directions. You must perform response spectrum analysis beforehand.
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Figure 9.20

2.9.19 Inertial Forces SX, SY and SZ

Analysis Result > Inertial Forces > Inertia Forces SX, SY and SZ displays the
following dialog box (Figure 9.21).  It allows you to view inertia forces for each mode
in global X, Y and Z directions. You must perform response spectrum analysis
beforehand.  Inertia forces are converted to nodal loads in different inertia load cases
automatically during response spectrum analysis. 

Figure 9.21

2.9.20 Modal Combinations

The sub-items in the Modal Combinations menu provide results from a modal analysis.

2.9.20.1 Nodal Displacements

Analysis Result > Modal Combinations > Nodal Displacements displays the following
dialog box (Figure 9.22).  It allows you to view nodal displacements in modal
combinations (including directional combinations). You must perform response
spectrum analysis beforehand.  
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Figure 9.22

2.9.20.2 Support Reactions

Analysis Result > Modal Combinations > Support Reactions displays the following
dialog box (Figure 9.23).  It allows you to view support reactions in modal
combinations (including directional combinations). You must perform response
spectrum analysis beforehand.  

Note: The support reactions do not include multi-DOF constraint forces and
moments.

Figure 9.23

2.9.20.3 Nodal, Line and Surface Spring Reactions

Analysis Result > Modal Combinations > Nodal, Line, Surface Spring Reactions a
dialog box similar to Modal Combinations > Support Reactions above (Figure 9.23).
You must perform response spectrum analysis beforehand.  

2.9.20.4 Multi-DOF Constraint Forces & Moments

Analysis Result > Modal Combinations > Multi-DOF Constraint Forces & Moments
displays the following dialog box (Figure 9.24).  It allows you to view multi-DOF
constraint forces & moments in modal combinations (including directional
combinations). You must perform response spectrum analysis beforehand.  
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Figure 9.24

2.9.20.5 Member End Forces & Moments

Analysis Result > Modal Combinations > Member End Forces & Moments displays
the following dialog box (Figure 9.25).  It allows you to view member end forces and
moments in modal combinations (including directional combinations). You must
perform response spectrum analysis beforehand.  

Figure 9.25

2.9.20.6 Member Segmental Results

Analysis Result > Modal Combinations > Member Segmental Results displays the
following dialog box (Figure 9.26).  It allows you to view member segmental results in
modal combinations (including directional combinations). You must perform response
spectrum analysis beforehand.  
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Figure 9.26

2.9.20.7 Shell Forces & Moments

Analysis Result > Modal Combinations > Shell4 Forces & Moments displays the
following dialog box (Figure 9.27).  It allows you to view shell4 forces and moments in
modal combinations (including directional combinations). You must perform response
spectrum analysis beforehand.  

Figure 9.27

2.9.20.8 Brick Stresses

Analysis Result > Modal Combinations > Brick Stresses displays the following dialog
box (Figure 9.28).  It allows you to view brick stresses in modal combinations
(including directional combinations). You must perform response spectrum analysis
beforehand.  

Figure 9.28

2.9.20.9 Base Shears

Analysis Result > Modal Combinations > Base Shears displays the following dialog
box (Figure 9.29).  It allows you to view modal base shears in X and Z directions. You
can compare them with the base shears computed by equivalent lateral force
procedure using relevant code such as ASCE 7-10. You must perform response
spectrum analysis beforehand.  
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Base Shears are not computed by the program if the model contains multi-DOF
constraints.

Figure 9.29

2.10 Concrete Design

The Concrete menu provides commands related to input, run, and output of concrete
design for beams, columns, and slabs.  With the exception of the cracking factors
command, the commands here do not affect the analysis results.  A static analysis
must be done successfully before concrete design can be performed.

2.10.1 RC Materials

Concrete Design > RC Materials prompts you with the following dialog box (Figure
10.1).  It allows you to define concrete and reinforcement strength properties for the
existing materials.  The strength properties include: 

· Concrete compressive strength fc
· Concrete reinforcement strength fy
· Concrete stirrup or tie strength fys

If standard materials are used in Geometry > Materials, these strength properties will
be set automatically.  You may override these properties prior to performing concrete
design.  No concrete design will be performed on a member or shell if its fc is zero. 
You should not modify materials that are not concrete on this dialog.
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Figure 10.1

2.10.2 Design Criteria

2.10.2.1 Design Criteria > Model Design Criteria

Concrete Design > Design Criteria > Model Design Criteria prompts you with the
following dialog box (Figure 10.2).  It allows you to enter global options for concrete
design.  You are encouraged to read the method of solution in the technical part of
this document in order to understand these options.  You should use this command
before performing concrete design.
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Figure 10.2

Design Code
Specifies design codes.  Currently the program supports ACI
318-02/05/08/11 only.

Column min and max
reinforcement ratios

Column minimum and maximum reinforcement ratios are used
to generate column sections.  They should be set between 1%
and 8%.  For all practical purposes, the maximum
reinforcement ratio should be less than 4% to avoid rebar
congestion.

Neutral axis steps for
accuracy

Neutral axis steps affect the solution accuracy and speed.  A
value of 250 ~ 500 for neutral axis steps is sufficiently
accurate for most sections.  The adequacy of neutral axis
steps can be determined by smoothness of the P-Mx and/or

P-My interaction diagrams.

Biaxial angle steps

Biaxial angle steps affects the solution accuracy and speed. 
For biaxial problems, steps must be multiple of 4.  A value of
16 or 32 is sufficiently accurate for most sections.  The
adequacy of biaxial angle steps can be determined by
smoothness of the Mx-My interaction diagram.  For uniaxial

problems, biaxial angle steps should always be set to 4.  This
will give P-Mx (+) at 0 degree angle, P-Mx (-) at 180 degrees

angle, P-My (+) at 90 degree angle, P-My (-) at 270 degrees

angle.  

Axial capacity steps
for display

Specifies the number of axial steps for the display of
interaction diagrams / surfaces and result data in the
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Design Code
Specifies design codes.  Currently the program supports ACI
318-02/05/08/11 only.

spreadsheet.  This value should be smaller than neutral axis
steps.  A value of 20 to 50 is usually adequate.

Exclude concrete
displaced by steel

Should almost always be checked.  This option is provided for
verifications with textbooks only!

Always use 1.0 for
Cm

If this option is checked, Cm = 1.0 will be used for all concrete
columns.  Otherwise, the program will compute Cm
automatically based on moment curvature and the existence of
transverse loading on the column.

Sustained load
combination for

computing Beta-d in
columns

Specify the load combination that contains the all sustained
load cases with each case load factor equal to 1.0.

Ignore compressive
force in concrete
shear capacity

Specify whether or not to ignore the increase in column
concrete shear capacity due to the influence of compressive
force.  Axial forces are ignored on concrete beams.

Check capacity at
column ends only

If this option is checked, column capacity is checked at its
ends only.  Otherwise, column capacity is checked at every
station along the column that analysis outputs. 

Compute minimum
moment

If this option is checked, a minimum moment Pu * (0.6 +
0.03h) is used for design

Automatically
compute support

widths

Select this option so that flexural design starts at the support
faces and shear design starts at a distance of ‘d’ from the
face of support.

Slab/plate min. reinf.
ratios

Specify slab/plate minimum top and bottom reinforcement
ratios for design.  According to ACI 318-02/05/08/11 7.12.2.1,
area of shrinkage and temperature reinforcement shall provide
at least 0.18% of gross concrete area.

2.10.2.2 Design Criteria > Beam Design Criteria

Concrete Design > Design Criteria > Beam Design Criteria prompts you with the
following dialog box (Figure 10.3).  It allows you to define and/or assign different
design criteria to selected concrete beams.  An Id is assigned automatically to each
design criterion by the program and may not be changed.  You may assign a label
with 127 maximum characters to each design criterion for easy identification.  The
beam design criteria include: 

· Number of stirrup legs.
· Stirrup bar size.
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· Bottom and top concrete covers measured from section edge to the centroid of
longitudinal bars.

You may add one or more criteria by clicking the “New Rows” button.  You may also
print all design criteria in the list by clicking the “Print” button.  The “Assign active
criteria to selected memebers” checkbox may be used to assign the active beam
design criterion to selected beams.  The active criterion refers to the one that
currently has focus in the list in the dialog box.  In order for beam design criteria
assignments to take place, beams must be selected beforehand.

The program always has a default beam design criterion labeled “Default”.  You may
not delete this criterion or change its label.  You may however change its properties.

Figure 10.3

2.10.2.3 Design Criteria > Column Design Criteria

Concrete Design > Design Criteria > Column Design Criteria prompts you with the
following dialog box (Figure 10.4).  It allows you to define and/or assign different
design criteria to selected concrete columns.  An Id is assigned automatically to each
design criterion by the program and may not be changed.  You may assign a label
with 127 maximum characters to each design criterion.  The column design criteria
include:

· Sway flags in x and y directions.
· Unbraced lengths in x and y directions.  You may enter zero if you want the

program to use the member lengths as the unbraced lengths.
· Effective length factors in x and y directions.



196

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Menus

· Number of tie legs.
· Tie bar size. 
· Concrete cover to the outside surface of ties.  Since different longitudinal bar

sizes may be used during automatic section generation, the program computes
concrete cover to bar center based on the following formula: “cover to tie” +
“tie diameter” + one half of “longitudinal bar diameter”  Note:  This is different
from concrete cover for beams.

· Start and end bar trial sizes for section generation.
· Bar layout.  0=bars will be placed on all sides of the section;  1=bars will be

placed only on the sides parallel to the section major axis; 2=bars will be
placed only on the sides parallel to the section minor axis; 3=bars will be
distributed equally on all sides.

· Confinement: Confining reinforcement can be either tied or spiral.  Spiral
applies to circular sections only.

Figure 10.4

You may add one or more criteria by clicking the “New Rows” button.  You may also
print all design criteria in the list by clicking the “Print” button.  The “Assign active
criteria to selected members” checkbox may be used to assign the active column
design criterion to selected columns.  The active criterion refers to the one that
currently has focus in the list in the dialog box.  In order for column design criteria
assignments to take place, columns must be selected beforehand.

The program always has a default column design criterion labeled “Default”.  You may
not delete this criterion or change its label.  You may however change its properties.
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2.10.2.4 Design Criteria > Plate Design Criteria

Concrete Design > Design Criteria > Plate Design Criteria prompts you with the
following dialog box (Figure 10.5).  It allows you to define and/or assign different
design criteria to selected concrete plates.  An Id is assigned automatically to each
design criterion by the program and may not be changed.  You may assign a label
with 127 maximum characters to each design criterion.  The plate design criteria
include: 

· Bottom-x, bottom-y, top-x and top-y concrete covers measured from plate
edge to the centroid of bars 

You may add one or more criteria by clicking the “New Rows” button.  You may also
print all design criteria in the list by clicking the “Print” button.  The “Assign active
criteria to selected shells” checkbox may be used to assign the active plate design
criterion to selected plates.  The active criterion refers to the one that currently has
focus in the list in the dialog box.  In order for plate design criteria assignments to
take place, plates must be selected beforehand.

The program always has a default plate design criterion labeled “Default”.  You may
not delete this criterion or change its label.  You may however change its properties.

Figure 10.5
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2.10.2.5 Design Criteria > Exclude Elements

Concrete Design > Design Criteria > Exclude Elements prompts you with the following
dialog box (Figure 10.6).  It allows you to include or exclude concrete design for
selected beams, columns, and plates.  For example, you might want to exclude some
plate elements (such as those near supports) from concrete design where large
stress spikes are present.  Plate envelope contours do not include the excluded shell
elements.  This makes the contour bands appear more distinct from each other.

Figure 10.6

2.10.2.6 Design Criteria > Cracking Factors

Concrete Design > Design Criteria > Cracking Factors prompts you with the following
dialog box (Figure 10.7).  It allows you to assign cracking factors to selected beams,
columns, and plates.  Cracking factors apply only to bending stiffness of members
and shell elements.  

Note:  Cracking factors are not considered by the program unless you check the
option “Use cracked section properties (Icr) for members and finite elements” in
Analyze > Analysis Options. Analysis results are cleared after assignment of
cracking factors.



199

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Menus

Figure 10.7

2.10.3 Assign

2.10.3.1 Assign > Beam Design Properties

Concrete Design > Assign > Beam Member Properties prompts you with the following
dialog box (Figure 10.8).  It allows you to continuously assign concrete beam design
properties to members.  After clicking “Assign”, you can start to continuously assign
concrete beam design properties by window-selecting members until you right click
the mouse or press the ESC key.

Figure 10.8
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2.10.3.2 Assign > Column Design Properties

Concrete Design > Assign > Column Member Properties prompts you with the
following dialog box (Figure 10.9).  It allows you to continuously assign concrete
column design properties to members.  After clicking “Assign”, you can start to
continuously assign concrete column design properties by window-selecting members
until you right click the mouse or press the ESC key.

Figure 10.9

2.10.3.3 Assign > Plate Design Properties

Concrete Design > Assign > Plate Member Properties prompts you with the following
dialog box (Figure 10.10).  It allows you to continuously assign concrete plate design
properties to shells.  After clicking “Assign”, you can start to continuously assign
concrete plate design properties by window-selecting shells until you right click the
mouse or press the ESC key.
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Figure 10.10

2.10.4 Design Input

2.10.4.1 Design Input > RC Member Input

Concrete Design > Design Input > RC Member Input prompts you with the following
dialog box (Figure 10.11).  It allows you to enter beams and columns for concrete
design in a spreadsheet.  Each element includes the class (“B” for beam, “C” for
column), design criteria Id, cracking factor, and exclusion design flag (0 for included, 1
for excluded). The element cracking factor with a value between 0 (fully cracked) and
1 (uncracked) applies to the moments of inertia of member elements.  You may not
modify the member Id.  Design criteria Ids must be valid (defined).  Beam and column
design criteria combo boxes are provided for you to correctly pick and apply proper
element class and design criteria to selected members.
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Figure 10.11

2.10.4.2 Design Input > RC Plate Input

Concrete Design > Design Input > RC Plate Input prompts you with the following
dialog box (Figure 10.12).  It allows you to enter plates for concrete design in a
spreadsheet.  Each element includes design criteria Id, cracking factor, and exclusion
design flag (0 for included, 1 for excluded). The element cracking factor with a value
between 0 (fully cracked) and 1 (uncracked) applies to the moments of inertia of
member elements. You may not modify the plate (shell) Id.  Design criteria Ids must
be valid (defined).  Plate design criteria combo box is provided for you to correctly
pick and apply proper element design criteria to selected shells.
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Figure 10.12

2.10.5 Perform Design

Concrete Design > Perform Design performs the concrete design based on the design
criteria and design input.  You must run the analysis successfully prior to running this
command.

2.10.6 Design Output

2.10.6.1 Design Output > RC Analysis Envelope

Concrete Design > Design Output > RC Analysis Envelope displays the following
dialog box (Figure 10.13).  It allows you to view the negative and positive moment
envelope as well as the shear envelope for concrete design.  You have the option to
view the envelope for the selected beams/columns only.  
Note: The envelope only considers the load combinations that are designated for
concrete design.
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Figure 10.13

2.10.6.2 Design Output > RC Beam Results

Concrete Design > Design Output > RC Beam Results displays the following dialog
box (Figure 10.14).  It allows you to view top and bottom required steel for flexure
and their corresponding design moments at every analysis output station along the
member.  You have the option to view the RC beam results for the selected beams
only.  

Figure 10.14

2.10.6.3 Design Output > RC Column Results

Concrete Design > Design Output > RC Column Results displays the following dialog
box (Figure 10.15).  It allows you to view the final column design sections and their
capacity ratios.  Some intermediate results such as moment magnification factors,
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Beta-d and Cm’s are output as well.  You have the option to view the RC column
results for the selected columns only.  

Figure 10.15

2.10.6.4 Design Output > Flexural/Axial Interaction > Sections

Concrete Design > Design Output > Flexural/Axial Interaction > Sections displays all
column sections generated by the program based on the input of material, section and
column design criteria (Figure 10.16). 

Figure 10.16
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2.10.6.5 Design Output > Flexural/Axial Interaction > P-Mx (+)

Concrete Design > Design Output > Flexural/Axial Interaction > P-Mx (+) displays the
P-Mx result data in a spreadsheet, with positive moment about the section major axis

(at biaxial angle of 0 degree) (Figure 10.17). 

Figure 10.17

2.10.6.6 Design Output > Flexural/Axial Interaction > P-Mx (-)

Concrete Design > Design Output > Flexural/Axial Interaction > P-Mx (-) displays the
P-Mx result data in a spreadsheet, with negative moment about the section major axis

(at biaxial angle of 180 degrees). 

2.10.6.7 Design Output > Flexural/Axial Interaction > P-My (+)

Concrete Design > Design Output > Flexural/Axial Interaction > P-My (+) displays the
P-My result data in a spreadsheet, with positive moment about the section minor axis

(at biaxial angle of 90 degrees). 
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2.10.6.8 Design Output > Flexural/Axial Interaction > P-My (-)

Concrete Design > Design Output > Flexural/Axial Interaction > P-My (-) displays the
P-My result data in a spreadsheet, with negative moment about the section minor axis

(at biaxial angle of 270 degrees). 

2.10.6.9 Design Output > Flexural/Axial Interaction > P-Mx-My

Concrete Design > Design Output > Flexural/Axial Interaction > P-Mx-My displays the
P-Mx-My result data in a spreadsheet at each biaxial angle step and axial capacity

step.

2.10.6.10 Design Output > Flexural/Axial Interaction > Print Diagrams

Concrete Design > Design Output > Flexural/Axial Interaction > Print Diagrams allows
you to view and print the interaction diagrams for each column section (Figure 10.18).
 The red and blue lines are the interaction diagrams about section major and minor
axes respectively.  A sketch of the section and the key control points are listed above
the diagrams as well.
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Figure 10.18
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2.10.6.11 Design Output > Member Shear Design Results

Concrete Design > Design Output > Member Shear Design displays the following
dialog box (Figure 10.19).  It allows you to view the required stirrup (tie) spacing for
concrete beam and column shear design.  You have the option to view the shear
design results for the selected beams and columns only.

Figure 10.19

2.10.6.12 Design Output > Wood-Armer Moments

Concrete Design > Design Output > Wood-Armer Moments displays the following
dialog box (Figure 10.20).  It allows you to view the critical Wood-Armer moments
(top and bottom, local-x and local y directions) and the corresponding load
combinations for concrete plates (shells).  These moments are used directly in
computing the required plate reinforcement areas.  You have the option to view the
Wood-Armer moments for the selected plates only.

Figure 10.20
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2.10.6.13 Design Output > RC Plate Results

Concrete Design > Design Output > RC Plate Results displays the following dialog
box (Figure 10.21).  It allows you to view the required plate reinforcement areas (top
and bottom, local-x and local y directions) and the corresponding Wood-Armer
moments for concrete plates (shells).  You have the option to view the plate design
results for the selected plates only.

Figure 10.21

2.10.7 Diagrams

2.10.7.1 Diagrams > RC Member Envelope Diagram

Concrete Design > Diagrams > RC Member Envelope Diagram displays the following
dialog box (Figure 10.22).  It allows you to view the required flexural reinforcement as
well as the moment and shear envelope used for designing concrete beams.  It also
allows you to view required stirrup or tie spacing for concrete beams and columns.
You have the option to view the member envelope diagrams for the selected
members only.
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Figure 10.22

2.10.7.2 Diagrams > RC Plate Envelope Contour

Concrete Design > Diagrams > RC Plate Envelope Contour displays the following
dialog box (Figure 10.23).  It allows you to view the required flexural reinforcement as
well as the Wood-Armer moments (top and bottom, local x and y directions) for
concrete plates (shells).  You have the option to view the plate envelope contours for
the selected plates only.

Figure 10.23
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2.10.8 RC Report

Concrete Design > RC Report displays the following dialog box (Figure 10.24).  It
allows you to print concrete design report on beams and columns.   You have the
options to include flexural design for concrete beams, axial-flexural design for
concrete columns as well as shear design for concrete beams and columns.  You also
have the option to print the report on selected members only.  

Figure 10.24

Figure 10.25 shows the print preview for a column axial-flexural design report.
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Figure 10.25
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2.10.9 RC Tools

2.10.9.1 RC Tools > Rebar Database

Concrete Design > RC Tools > Rebar Database displays the following dialog box
(Figure 10.26).  It allows you to select different rebar databases for use in concrete
design.

Figure 10.26

2.10.9.2 RC Tools > K Calculator

Concrete Design > RC Tools > K Calculator (Figure 10.27) allows you to accurately
calculate effective length factors (braced and unbraced Ks) based on the beam and
column relative stiffness input.
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Figure 10.27

2.10.9.3 RC Tools > Quick Rectangular Beam Flexural Design

Concrete Design > RC Tools > Quick R-Beam Flexural Design (Figure 10.28) allows
you to quickly design a rectangular concrete beam according to ACI 318-
02/05/08/11/14.  Minimum reinforcement may be optionally computed.  You have the
option to design the rectangular beam as singly or doubly reinforced.  A negative
reinforcement area means the design fails.
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Figure 10.28

2.10.9.4 RC Tools > Quick Tee Beam Flexural Design

Concrete Design > RC Tools > Quick T-Beam Flexural Design (Figure 10.29) allows
you to quickly design a concrete tee beam according to ACI 318-02/05/08/11/14. 
Minimum reinforcement may be optionally computed.  The tee beam is always
designed as singly reinforced.  A negative reinforcement area means the design fails.



217

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Menus

Figure 10.29

2.11 Steel Design

2.11.1 Steel Materials

Steel Design > Design Criteria > Steel Materials prompts you with the following dialog
box (Figure 11.1).  It allows you to define steel strength properties for the existing
materials.  The strength properties include: 
· Steel yield stress Fy
· Steel rupture stress Fu

If standard materials are used in Tables > Material Data, these strength properties
will be set automatically.  You may override these properties prior to performing steel
design.  No steel design will be performed on a member if its modulus is not close
(within 10%) to 29E3 ksi.  You should not modify materials that are not steel on this
dialog.



218

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Menus

Figure 11.1

2.11.2 Design Criteria

2.11.2.1 Model Design Criteria

Steel Design > Design Criteria > Model Design Criteria prompts you with the following
dialog box (Figure 11.2).

Use Direct Design Method currently only affects how the moment magnification factor
B1 is calculated. You also have the option not to consider moment magnification
factor B1 altogether.  Please be advised that P-Delta analyses should be performed
on load combinations that are used for steel design.

To be conservative, you can always use 1.0 for Cm that accounts for nonuniform
moment.  Uncheck the Always use 1.0 for Cm” if you would like the program to
calculate Cm for automatically.
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Figure 11.2

You have the option to only use sections defined in Steel Design > Design Criteria >
Section Pool during the design process.  This is useful if you do not want the program
to use too many steel section sizes for the entire model.

Connector distance for double angles is used for sections that are double angles.

The default number of section candidates designed for each member is 10.

You can also specify limits for total load deflection and live load deflection.

2.11.2.2 Member Design Criteria

Steel Design > Design Criteria > Member Design Criteria prompts you with the
following dialog box (Figure 11.3).  It allows you to define and assign design criteria
for members.
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An Id is assigned automatically to each design criterion by the program and may not
be changed.  You may assign a label with 127 maximum characters to each design
criterion.  The column design criteria include:
· Section Prefix, which is a comma delimited list.  For example, if you want the

member section to be with W10 or W12 size, enter the prefix as “w10,w12”.  You
also specify the prefix as the exact AISC shapes.  Use the prefix “Default” if you do
not want the member section changed from the original shape.

· Sway flags in x and y directions.
· The length between points that are braced against lateral displacement of

compression flange Lb.  Currently, the program only supports equal Lb along the
member length.  For non-continuously braced, the program will use the member
length for Lb if the value is entered 0.  For continuously braced, 0 must be entered
for Lb.

Figure 11.3

· Lateral-torsional buckling modification factor for nonuniform moment diagrams Cb. 
The program will automatically calculate Cb if the value is entered 0.  You can
always use Cb = 1.0 for conservative reasons.

· Unbraced lengths in x, y and z directions.  You may enter zero if you want the
program to use the member lengths as the unbraced lengths.

· Effective length factors in x, y and z directions.
· You have the option to set the maximum capacity ratio.  By default, this ratio is 1.0.

 You can set a value less than 1.0 (but greater than 0.0) for conservative reasons.
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2.11.2.3 Section Pool

Steel Design > Design Criteria > Section Pool prompts you with the following dialog
box (Figure 11.4).  It allows you to define a list of sections that may be used
exclusively for design.

You can copy a list of section labels from the AISC table.  You can also enter
sections manually.  Each line in the section pool box can only contain one section. 
Furthermore, you can automatically add all the section candidates to the section pool
(from Steel > Design Results).

Figure 11.4

2.11.2.4 Exclude Elements

Steel Design > Design Criteria > Exclude Elements prompts you with the following
dialog box (Figure 11.5).  It allows you to include or exclude steel design for selected
members.  
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Figure 11.5

2.11.3 Assign Member Design Properties

Steel Design > Assign Member Design Properties prompts you with the following
dialog box (Figure 11.6).  It allows you to continuously assign steel design properties
to members.  After clicking “Assign”, you can start to continuously assign steel design
properties by window-selecting members until you right click the mouse or press the
ESC key.

Figure 11.6

2.11.4 Steel Member Input

Steel Design > Design Input > Steel Member Input prompts you with the following
dialog box (Figure 11.7).  It allows you to enter members for steel design in a
spreadsheet.  Each element includes the design criteria Id, and exclusion design flag
(0 for included, 1 for excluded).  You may not modify the member Id.  Design criteria
Ids must be valid (defined).  Steel design criteria combo box is provided for you to
correctly pick and apply proper steel design criteria to selected members.
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Figure 11.7

2.11.5 Perform Design

The Steel Design > Perform Design menu allows you to run the steel design.

2.11.6 Design Results

The Steel Design > Design Results allows you to view the steel design results (Figure
11.8).  It also allows you to update member sections.  
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Figure 11.8

The section column on Figure 11.8 includes a combobox that contains the member
original section (first entry in the combobox) and designed section candidates (second
or more entries in the combobox).  You can change the member sections by picking
the proper section candidates. Please be advised you need to re-analyze and design
after one or more member sections are updated.

In addition, you can add all the section candidates to Section Pool, which can be used
in the next round of design.

Finally, you can view the detailed calculation procedure for each member for the most
critical load condition.

2.11.7 Steel Tools

2.11.7.1 K Calculator

Steel Design > Steel Tools > K Calculator offers a tool to calculate the K value of
columns by entering the ratios of the sum of the EI/L values at the top and bottom of
the column segment.

2.11.7.2 Section Check

Steel  Design > Steel Tools > Section Check (Figure 11.9) allows you to perform steel
section capacity check.
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Lux, Luy and Luz are unbraced lengths in local x, y and z directions.  
Kx, Ky and Kz are unbraced length factors in local x, y and z directions.

Lb is the unbraced lateral length. 
Cb is the lateral-torsional buckling modification factor for non-uniform moment
diagrams.  It should be greater or equal to 1.0.  You can use 1.0 for Cb
conservatively.

Connector Distance is used for double angles only.

Figure 11.9

Pu, Mux, Muy, Vux, Vuy are required axial, major moment, minor moment, major
shear and minor shear.  For Pu, the compressive force is positive while tensile force is
negative.  Moment Mux is positive when section top most fiber is under compression.
Moment Muy is positive when section rightmost fiber is under compression.  Moment
magnification may be optionally considered to account for the P-delta (P-δ) effect.

If direct design method is chosen, the program will calculate stiffness reduction
parameter based on Eq. C2-2a and C2-2b of the code.
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Cmx, Cmy are coefficients accounting for non-uniform moments when computing
moment magnification.  You can use 1.0 for Cmx and Cmy conservatively.  If Cmx or
Cmy is 0, 1.0 is used in the computation instead.

Results include axial capacity (phi-Pn), moment capacity (phi-Mnx, phi-Mny), shear
capacity (phi-Vnx, phi-Vny), moment magnification factors (B1x, B1y) and critical ratio.
 The section is deemed safe to resist a load if the critical ratio is less than 1.0,
otherwise, the section is deemed unsafe.  Please note that for single angle, the
moment capacity is given about the principal axes (w-w and z-z).
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2.11.7.3 Section Design

Steel Design > Steel Tools > Section Design (Figure 11.10) allows you to quickly
design steel sections against a set of load effects.  The Section Design input and
output are shown below:

Figure 11.10

For Section Filter Criteria, you can use either Section Prefixes or section dimension
limits (but not both).  The section prefixes is a comma delimited list such as W12,
W14.  If section prefixes is used, the section dimension limits will be ignored.  If a
section dimension limit is zero, then that limit criteria is ignored.

By default, a maximum of ten section candidates will be provided after a successful
design.  You can then view the detailed check for each of the section candidate.
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2.12 Settings

The Settings menu provides commands related to settings for model data and
graphical entities in model views.  Some of these settings may be applied beyond the
current model, that is, they may be saved for use in future models.

2.12.1 Units & Precisions

Settings > Units & Precisions prompts you with the following dialog box (Figure 12.1).
 You may select different units and precisions for various physical measurements
used in the model.  You may use this command as many times as you like.  You may
convert existing data associated with a unit in the model by checking or unchecking
the check box to the right of that unit.  For example, if you mistakenly enter all nodal
coordinates in a wrong length unit, you may select the correct length unit and uncheck
the conversion checkbox to correct nodal coordinate input.

Figure 12.1

Default English and Default Metric let you quickly set predefined units commonly used
for the imperial or metric system.  Consistent English and Consistent Metric buttons
let you set predefined consistent units for the imperial or metric system.  In a
consistent unit system, units for the same type of physical measurements are the
same.  For example, units for both length and dimension are the same, which is inches
for imperial system and meters for metric system.  
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You may set the precision for each unit in either decimal or scientific format. 
Precision settings are used in displaying data in spreadsheets, diagrams, and
reports. 
 
By checking “Save as defaults for future use”, units will be remembered for use in
future models.  It is a good idea to also save graphic scales at the same time.  To do
that, just click Settings > Graphic Scales. 

2.12.2 Data Options

Settings > Data Options prompts you with the following dialog box (Figure 12.2).  

Distance tolerance is used for distance comparisons in certain commands such as
Edit > Merge Nodes and Edit > Explode Members.  Distances less than distance
tolerance are considered zero by the program.  

The “Undo/redo levels” sets the maximum undo/redo levels which the program will
perform.  The program requires extra computer memory for each undo/redo level. 
The default undo levels setting is 100.  Depending on your computer memory and
model sizes, you may want to set undo levels to be smaller.
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Figure 12.2

Round-off epsilon is used to truncate floating point numbers such as those found in
results.  For example, a fixed support may have a displacement of 1.077e-10 when in
fact it should zero.  A round-off epsilon of 1e-9 will do just that.  

Stresses are computed at the center and at the nodes of finite elements such as
shells or solids.  However, you may request the program to show stresses at the finite
element center only, nodes only, or both. The checkbox “Show only selected entities
in spreadsheet” determines if all or selected nodes, elements and their dependents
will be shown in the spreadsheet.  By checking this checkbox, you may easily query
selected entities in a large model.  It is important to point out that data in some input
spreadsheets may not be modified when this option is checked.  The checkbox “Save
results when the document is saved” gives you the option to save results (when
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available) to a file when the model input data is saved.  The result file is a binary file
and has the same file name as model input file, but with an extension of “rst” (static
results) or “dyn” (dynamic results).  The result file could be much larger than the
model input file.

The fictitious oz stiffness factor is used to multiply the minimum of diagonal terms
(excluding oz) in the shell stiffness matrix to construct the fictitious oz stiffness terms. 
The smaller this factor, the more accurate the solution, especially for very thin and
doubly curved shells.  The valid range for this factor is [1e-12, 1e-3].  You normally do
not need to change its default value (1e-7).  Numerical difficulties may arise during
solution if this value is set too small.

The diaphragm stiffness factor is used to control the diaphragm rigidity.  The larger
this factor, the more rigid the diaphragm action is. The valid range for this factor is [0,
1e20].  The default value is 1e4.  Numerical difficulties may be present during static or
frequency analysis if the diaphragm stiffness factor is set too large (say 1e13 for 64-
bit floating point solver).  It is generally recommended to use 128-bit floating point
solver to avoid the aforementioned problem.

2.12.3 New Origin

Settings > New Origin prompts you with the following dialog box (Figure 12.3).  It
allows you to reset the model origin.  In particular, the origin may be set at the current
model center.  This allows you to center the model so its view may be rotated more
smoothly.

Figure 12.3
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2.12.4 Graphic Scales

Settings > Graphic Scales prompts you with the following dialog box (Figure 12.4). 
You may set scales for graphical entities such as loads, nodes, supports etc.  By
“Save as defaults for future use”, these scales will be saved for future use.  It is a
good idea to save units at the same time.  To do that, click Settings > Units &
Precisions. 

Figure 12.4

2.12.5 Colors

Settings > Colors prompts you with the following dialog box (Figure 12.5).  It allows
you to set colors of different graphical entities in the model.  You may modify the
color(s) of one or more items at a time.  By checking “Use color cues for different
materials”, concrete, steel and wood materials will show different colors in rendering
mode.

By checking “Use white background for image captures”, a white background will be
used for the captured image even if a different background color is used in the model
views.  This option will reduce the amount of ink required to print the images. Color
settings can be optionally saved for future use.
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Figure 12.5

2.12.6 Preferences

Settings > Preferences prompts you with the following dialog box (Figure 12.6).  

The “Automatic file backup period” determines how frequently the model files are
saved automatically.  Enter 0 for no auto-backups.  Backup files have the extension
“.r3a”.  

Settings for “Response Animation” can be set here.  You may activate the Response
Animation command from the View menu after an analysis has been performed
successfully.

You have the options to lock the model after analysis is performed successfully.  By
default, an internal HTML viewer is used to view text and graphical reports.  

By default, rubber-banding is enabled while drawing beams, shells or bricks.  You
may want to disable this feature if your computer graphic card is not fully OpenGL
compatible.

Additional settings related to the font for graphics and the spreadsheet appearance
are available.
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When the sparse solver is used for static analysis, you may choose an out-of-core
approach so computer memory usage is minimized.  You may specify the maximum
amount of memory to be used in the out-of-core sparse solver.  This value should be
smaller than the physical memory available in your system.  
 
Preferences are always saved for future use.

Figure 12.6

2.12.7 Tools

2.12.7.1 Tools > Unit Conversion

Settings > Tools > Unit Conversion displays a tool for conversion between various
units (Figure 12.7).
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Figure 12.7

2.12.7.2 Tools > Calculator

Settings > Tools > Calculator displays the Windows Calculator.

2.12.7.3 Tools > Text Editor

Settings > Tools > Text Editor displays the Windows Notepad.

2.12.7.4 Tools > Copy Command History

Settings > Tools > Copy Command History copies the history in the command window
to the clipboard.  You may then paste the command history content to a text editor
using Ctrl + V.  A command history is associated with each open document.

2.12.7.5 Tools > Clear Command History

Settings > Tools > Clear Command History clears the history in the command window.
 You may want to copy the command history before running this command.

2.12.8 Toolbars

Settings > Toolbars offers options to show or hide the available toolbars.
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2.13 Window

The Window menu provides commands to create new windows and arrange existing
windows.  In this program, a window may be used interchangeably with a view.  The
program has two types of views: model view and report view.  The model view
contains the graphical display of the input in a model.  The report view contains text or
graphical report in html format for the input or output of a model.

2.13.1 New Window

Window > New Window creates a new window or view based on the current view. 
You may create different model views with different display settings with respect to
zooming, panning, loading diagram, shear or moment diagrams, contours, etc.  For
example, you may have one model view to display moment diagram, another view to
display shear diagram.  You may create as many views as you want.  However, too
many views may clutter the view area and make graphic display sluggish.

2.13.2 Close

Window > Close closes the current window.

2.13.3 Close All

Window > Close All closes all windows that are currently open.  You will be prompted
to save file(s) if necessary.

2.13.4 Tile Horizontal

Window > Tile Horizontal arranges all opened windows horizontally.

2.13.5 Tile Vertical

Window > Tile Vertical arranges all opened windows vertically.

2.13.6 Tile Cascade

Window > Cascade arranges all opened windows in an overlapped manner
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3 Toolbars

3.1 Main Toolbar

Settings > Toolbars > Main Toolbar shows or hides the main toolbar.

The Main toolbar is fairly long.  So for clarity, it is broken into three portions below
with each toolbar button annotated:

1: Save & Close
2: Save Only
3: Close without
Saving
4: Print Text Report
5: Print Preview
6: Undo

7: Redo
8: Drawing Grid
9: Generate Rectangular Frames
10: Generate Rectangular Shells
11: Generate Arc Members
12: Generate 2D Truss/Frame

13: Draw Members
14: Draw Nodes
15: Draw Shells
16: Materials
17: Sections
18: Thickness
19: Moment Releases
20: Supports
21: Springs
22: Local Angle

23: Load Cases
24: Load Combinations
25: Nodal Loads
26: Point Loads
27: Line Loads
28: Area Loads
29: Surface Loads
30: Nodal Masses
31: Load Combination

3.2 View Toolbar

Settings > Toolbars > View Toolbar shows or hides the toolbar that contains
commands for controlling the view.
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The View toolbar is fairly long.  So for clarity, it is broken into two portions below with
each toolbar button annotated:

1: Window Select
2: Invert Selection
3: Freeze
4: Freeze All Except
Plane
5: Thaw
6: Zoom Window
7: Zoom Extent
8: Zoom Previous

9:  Zoom In
10: Zoom Out
11: Real-time Zoom
12: Pan Left
13: Pan Right
14: Pan Up
15: Pan Down
16: Real-time Pan

17: Rotate +X
18: Rotate -X
19: Rotate +Y
20: Rotate -Y
21: Rotate +Z
22: Rotate -Z
23: Real-time Rotate
24: Query

25: Quick Render
26: Loading Diagram
27: Front View
28: Right View
29: Top View
30: Isometric View
31: Restore Model

32: Annotate Node
Related Items
33: Annotate Member
Related Items
34: Annotate Shell
Related Items
35: Annotation Dialog
36: Toggle Grid
Display
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3.3 Edit/Run Toolbar

Settings > Toolbars > Edit/Run Toolbar shows or hides the toolbar related to edit,
analysis, and result visualization commands.

1: Duplicate

2: Array

3: Mirror

4: Move

5: Rotate

6: Scale

7: Delete

8: Lock or Unlock

9: Toggle Show-Selected-Only

10: Static Analysis

11: Frequency Analysis

12: Fast Shear & Moment Diagrams

13: Shear & Moment Diagrams

14: Fast Contours

15: Contours

16: Deflections

17: Mode Shape

18: Response Animation
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3.4 Input Toolbar

Settings > Toolbars > Input Toolbar shows or hides the toolbar that contains input
buttons.  They are an alternate way to open the named tables.

3.5 Output Toolbar

Settings > Toolbars > Output Toolbar shows or hides the toolbar that contains output
buttons.  They are an alternate way to open the named tables.
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3.6 Status Bar

Settings > Toolbars > Status Bar shows or hides the status bar at the bottom of the
screen.

1: Currently selected command
2: Type of model
3: Cursor coordinates (when cursor is on a grid point)
4: Current Load Combination
5: Solution status 



Coordinate Systems
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4 Coordinate Systems

Two kinds of coordinate systems are used in the program, namely, the global
coordinate system and the local coordinate system.  The global coordinate system is
the one and only fixed Cartesian system in a structural model.  The local coordinate
system applies to each individual member or finite element.

4.1 Global Coordinate System

The global coordinate system is a fixed Cartesian system that is used for entire
model.  The three axes are denoted by capital letters X, Y and Z.  They follow the
right-hand rule.  By default, that is, when a model is not rotated for viewing purpose,
the X axis points from left to right (horizontal), the Y axis points from bottom to top
(vertical), and the Z axis points from screen to out of screen (perpendicular to
screen).

The global coordinate system is used in the following input:
- nodal coordinates, nodal loads
- degrees of freedom related to nodes, supports and springs 
- self weights
- point, line, and surface loads on members and finite elements [may also be

specified in the element local coordinate system]

The global coordinate system is used in the following output:
- nodal displacements
- support and spring reactions
- brick stresses

4.2 Local Coordinate Systems - General

Each member or finite element has a local coordinate system.  It is a Cartesian
system that has a default orientation (when local angle equals 0) and may be changed
at any time. The three axes are denoted by small letters x, y, z.  They follow the right-
hand rule.

The local coordinate system exists to facilitate input and output for member and finite
elements.  For example, point or line loads on a member may be most conveniently
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specified in the local coordinate system of the member.  The element results such as
shears and moments are output in the local coordinate system for design purposes.  

Since the local coordinate systems directly affect input and results, it is always
prudent to check them for correctness using the commands such as View > Annotate
or Render.  You may change the local coordinate systems using the commands such
as Edit > Element Local Angle or Reverse Node Order for Selected Elements.  It is
the directional vectors that matter...the origin of the local coordinate system is
insignificant in this program.

The local coordinate system is used in the following input:
- point, line, and surface loads on members and finite elements [may also be

specified in the global coordinate system]
- member moment releases

The local coordinate system is used in the following output:
- member forces, moments, and local deflections
- shell forces, moments, and stresses

In the following sections, Vx, Vy and Vz (with lowercase subscripts) represent the

local x, y, and z vectors respectively.  VX, VY and VZ (with uppercase subscripts)

represent the global X, Y, and Z vectors respectively.  For vector algebra, please
refer to relevant math textbooks. 

4.3 Member Local Coordinate System

The local coordinate system of a member is determined by the start and end nodes,
and an element local angle.  The default (local angle equals 0 degrees) local
coordinate system of a member is defined using the following procedures:

Steps Description Mathematical Notations

A Vx points from node 1 (N1) to node 2 (N2) Vx = N2 – N1

B1 For vertical members:
Vz is always parallel to VZ

For vertical members
Vz = VZ
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Steps Description Mathematical Notations

B2 For non-vertical members:
Vz is perpendicular to a plane formed by Vx

and VY

For non-vertical
members 

Vz = Vx x VY

C Vy is determined based on Vx and Vz and the

right-hand rule
Vy = Vz x Vx

For a member with a non-zero local angle (γ), first follow the procedures above that
determine the default local coordinate system.  Then rotate the default system a γ
angle about its local x vector Vx.  The rotated Vx, Vy and Vz define the local

coordinate system. Figure 13.1 shows the local coordinate systems of some
members with different local angles (γ).

Local coordinate systems for members with different local angles

Figure 13.1



261

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Coordinate Systems

4.4 Four-Node Shell Local Coordinate System

The local coordinate system of a shell is determined by its four nodes, and an element
local angle.  The default (local angle equals 0 degrees) local coordinate system of a
four-node shell is defined based on the shape of the shell element.

Rectangular Shell Non-Rectangular Shell

For rectangular shells, the default local coordinate system is easily defined by the
following: local x points from N1 to N2, local y points from N1 to N4 and local z is
perpendicular to the shell surface.

For non-rectangular shells, the default local coordinate system is defined using the
following procedures:
 

Steps Description Mathematical Notations

A Local z is perpendicular to the shell surface

Let V1 = N2 – N1, 

Let V2 = N4 – N1

Vz = V1 x V2

B1

For horizontal shells that are parallel to
global XZ plane, local x is parallel to global

X

For horizontal shells 
Vx  =  VX

B2

For non-horizontal shells, Vx is

perpendicular to a plane formed by VY and

Vz 

For non-horizontal
shells 

Vx = VY x Vz

C
Vy is determined based on Vx and Vz and

the right-hand rule
Vy = Vz x Vx

For a shell with a non-zero local angle (γ), first follow the procedures above that
determine the default local coordinate system.  Then rotate the default system a γ
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angle about is its local z vector Vz.  The rotated Vx, Vy and Vz define the local

coordinate system.  Figure 13.2 shows the local coordinate systems of some shell
elements with different local angles (γ)

Local coordinate systems for shells with different local angles

Figure 13.2

4.5 Eight-Node Brick Local Coordinate System

The local coordinate system for a brick element is always identical to the global
coordinate system.  It is fixed and cannot be changed. 
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5 Nodes

Nodes are numbered points in space.  They are used to define the geometry and
connectivity of all members and finite elements in a model.  For members, a node is
sometimes referred to as a joint, which has a physical meaning of the intersection of
two members such as a beam and a column.  However, in this program, the term
“node” is generally preferred because it carries a more general meaning.

5.1 Nodal Coordinates

The location of a node is defined by the global X, Y, and Z coordinates.  Since each
member or finite element connects to two or more nodes, nodal coordinates define
the geometry of a model.  For example, when you move an element, you actually
move the locations of the nodes connected to that element.

5.2 Degrees of Freedom (DOFs)

Each node may have a maximum of six global degrees of freedom (DOFs) associated
with it.  They are three translational DOFs along the global X, Y, Z directions (Dx, Dy
and Dz) and three rotational DOFs about the global X, Y, Z directions (Dox, Doy and

Doz).  

Some of these DOFs may not be available depending upon the type of a model.  

For example, the model type “2D Truss” has Dx and Dy available and Dz, Dox, Doy,

Doz unavailable or suppressed; while the model type “2D Plate Bending” only has Dz,

Dox, Doy available and Dx, Dy, Doz suppressed.  

You may always use the model type “3D Frame and Shell” to analyze any structure,
however, time and computer memory may be wasted if a simpler model type can be
used instead.  You may choose the appropriate model type by command Analyze >
Analysis Options.

Six nodal displacements associated with 6 DOFs are output for each node.  For
restrained or unavailable DOFs, the program outputs the corresponding
displacements as zero.  Nodal displacements should be the first thing to check for
when determining result correctness since the solution is displacement-based.  If the
displacements are wrong, nothing else will be correct.
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5.3 Node Numbers

A distinct integral number is assigned to each node.  Node numbers are used to
define the connectivity of member and finite elements.  Duplicate numbers in nodes
are not permitted.  There can be gaps in node numbering sequence.  The program will
automatically renumber the nodes internally before performing the solution.  The order
of node numbering in a model is insignificant to the final results, but it may affect the
time and computer memory required to solve the model.  For a very large model,
node renumbering may be important in order to reduce the half band width in the
global stiffness matrix and therefore the solution time.  You may renumber the nodes
sequentially based on nodal coordinates using the command Edit > Renumber Nodes.

Half Band Width (HBW) is defined as [Ref.7] as follows:

where m is the total number of structural elements, and the max dofel and min dofel

are the maximum and minimum global degrees of freedom numbers associated with
element el.

For example, in Figure 14.1 and 14.2, models A and B are identical 3D frames (6
DOFs per node) but with different node numbering schemes.  Model A has a HBW of
6 * (9 + 1) = 60 while model B has a HBW of 6 * (5 + 1) = 36.  Therefore, model B is
more economical than model A because of the reduction of half band width.  
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Model A: HBW=60

Figure 14.1

Model B: HBW=36

Figure 14.2

5.4 Loads

Forces or moments may be applied to a node.  These forces and moments are
specified in the global coordinate system.  You may regard enforced displacements
as special kinds of loads.  They are specified in supports.

5.5 Supports

By default, a node is unrestrained, that is, it is free to move in any of the six available
DOFs.  However, for a model to be stable, restraints on one or more DOFs must be
imposed on some nodes.  Restraints may be rigid or flexible.  Rigid restraints are
referred to as supports while flexible restraints are referred to as springs.  You may
regard supports as springs with infinite spring constants.

You may assign a support with one or more DOFs (Dx, Dy, Dz, Dox, Doy and Doz)

restrained to a node.  The program uses a six-character code to represent restraint
conditions of a support in six DOFs.  For example, “111111” represents a fixed a
support while “111000” represents a pinned support.  By default, restrained DOFs
have zero enforced displacements.  You may specify non-zero enforced
displacements to any or all of restrained DOFs.  The enforced displacements are
discarded if they are assigned to unrestrained DOFs.  You may regard these
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enforced displacements as special kinds of loads.  They participate in all load
combinations but always with a load factor of 1.0.

The forces or moments required to enforce rigid restraints are called support
reactions.  They are computed by the program.

5.6 Springs

Springs are flexible restraints.  Springs applied to nodes are referred to as nodal
springs. You may assign a nodal spring to a node with one or more global DOFs (Dx,

Dy, Dz, Dox, Doy and Doz) restrained.  To qualify to be a valid flexible restraint, the

corresponding spring constant must be specified. A restraint may be designated as
linear, compression-only or tension only.  A compression-only restraint is active only
when the nodal displacement in the restrained direction is negative.  A tension-only
restraint is active only when the nodal displacement in the restrained direction is
positive.  If a model contains one or more compression-only or tension-only springs,
the whole problem becomes nonlinear and the solution becomes iterative for each
load combination.

The forces or moments required to enforce the flexible restraints are called spring
reactions.  They are computed by the program. 
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6 Members

A member is a two-node straight frame element with a constant cross section.  The
term “frame element”, “beam element”, and “member” are used interchangeably in this
program.  The truss element is a special frame element with moments fully released
at both ends.  The frame element formulation accounts for axial, torsional, and
bending about strong and weak axes, with options to include shear deformations and
axial stress stiffening (P-Delta) effects.  Moment releases may be applied to either or
both ends of the element. 

The frame element may be used to model continuous beams, 2D or 3D frames, 2D or
3D trusses or a mixture of two.  The program provides powerful commands to
generate commonly used framed structures such as continuous beams, 2D or 3D
frames, arc beams, and non-prismatic beams.  A non-prismatic member is
approximated by subdividing the original member into several prismatic members. 
You may access these commands from the Generate menu. 

6.1 Member Sections

Each member must have a section assigned to it.  The section properties include: 
- A: axial section area
- Ay: shear area along the member local y direction

- Az: shear area along member the local z direction

- Izz:  moment of inertia about strong the local axis z

- Iyy:  moment of inertia about weak the local axis y

- J:  torsional moment of inertia

Ay and Az may be zero, in which case, the program ignores shear deformations of the

element.  Mathematically speaking, the program interprets them as being infinite.  For
rectangular sections, Ay = Az = 5/6A.  For solid circular sections, Ay = Az = 0.9A. 

For thin-walled hollow circular sections, Ay = Az = 0.5A.  For wide flange sections, Ay
= web area, Az = area of two flanges [Ref. 6].  To consider member shear

deformation, you must choose the proper option from the command Run > Analysis
Options.  Shear deformation, when considered, applies to both element stiffness and
local deflections.

6.2 Local Coordinate System

Each member has its own local coordinate system.  The element local coordinate
systems are used in element stiffness formulations.  They are also used for inputs



271

ENERCALC 3D 
 
                                                                                                                                                                                                                                    © 2020  ENERCALC, Inc.

Members

such as loads and releases and outputs such as internal shears and moments.  For
the definition of the member local coordinate system, refer to Coordinate Systems.  

6.3 Member Numbers

A distinct integral number is assigned to each member.  Duplicate numbers in
members are not permitted. There can be gaps in the member numbering sequence. 
 The order of member numbering in a model is insignificant to the results or solution
time.  You may renumber the members sequentially using the command Edit >
Renumber Members.

6.4 Beams Vs. Trusses

By default, a member or frame element is a beam.  However, if you choose the model
type to be either “2D Truss” or “3D Truss”, then the frame element becomes a truss
element.  The program assigns full moment releases automatically to the ends of all
members and suppresses all three rotational DOFs Dox, Doy, Doz for each and every

node.  For the model type “2D Truss”, the program also suppresses translational DOF
Dz.  Generally speaking, if a model contains only 2D or 3D truss elements, you should

choose the model type as “2D Truss” or “3D Truss”.  If a model contains both trusses
and beams, you should choose the model type“2D Frame” or “3D Frame & Shell”, and
assign appropriate moment releases to individual beams.  It may also be necessary to
assign appropriate restraints to nodes to ensure stability of the model. You may
choose the appropriate model type by running the command Analyze > Analysis
Options.

6.5 Elastic Stiffness Matrix

Total number of DOFs of a member is the summation of DOFs of the two nodes. 
Therefore, for a 3D beam, the stiffness matrix is of size 12 x 12.  The elastic stiffness
matrix in the local coordinate system with shear deformation is given [Ref. 8] as
follows:
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where: ;  ;    ;  ;    

6.6 Geometric Stiffness Matrix

When a tensile axial force is present in a member, the bending stiffness of that
member is increased.  Conversely, when a compressive axial force is present in a
member, the bending stiffness of that member is reduced.  The stiffness matrix that
reflects this kind of stress stiffening effect is called the geometric stiffness matrix
[Ref. 3, 7].  It is determined by the element geometry and stress conditions, and is
independent of the elastic properties.  The geometric stiffness matrix is very effective
in accounting for the P-Delta effect and is implemented in the program.  It may also
be used to perform buckling analysis of the structure but is not implemented in the
program directly. 

Like the elastic stiffness matrix, the geometric stiffness matrix is of size 12 x 12 and is
given [Ref. 3, 7] as follows: 
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where P is the average of the axial forces (positive in tension, negative in
compression) at the member ends.

When the linear static (first order) analysis is chosen, the member stiffness matrix is
the elastic stiffness matrix.  When the P-Delta (second order) analysis option is
chosen, the member stiffness matrix is the summation of the elastic stiffness matrix
and the geometric stiffness matrix.  You may set the appropriate analysis option with
the command Analyze > Analysis Options .

6.7 Moment Releases

By default, a member is rigidly connected to two end nodes.  You may however
assign moment releases to either end of the member.  It is important to note that the
releases are applied with respect to the member local coordinate system.  The
moment releases may be in major bending direction (Doz) or minor bending direction

(Doy) or both.  The element stiffness matrix is modified to enforce moment releases.

6.8 Tension/Compression-Only

By default, a member is linear.  You may assign nonlinearity (tension-only or
compression-only) to the selected members.  The member stiffness will be ignored if
a tension-only member is subjected to compressive forces or if a compression-only
member is subjected to tensile forces. The presence of tension- or compression-only
members makes the model nonlinear, so an iterative solution is required for each load
combination.

168
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6.9 Rigid Links

A rigid link is a member that has very large sectional properties (A, Ay, Az, Iz, Iy and
J).  There can only be one rigid link section defined in the model and it must be named
as “RIGID_LINK”.  The properties for the RIGID_LINK section must be set to 0’s on
the member section dialog box.  The program will appropriately calculate A, Ay, Az,
Iz, Iy and J during the solution process. Self weight for rigid links will be ignored
by the program.

6.10 Rigid Diaphragms

Rigid diaphragms may be used instead of plate finite elements to model stiff in-plane
actions such as concrete floors.  Internally, the program creates multiple in-plane rigid
links for each diaphragm prior to static or frequency analysis.  A rigid link is simply a
member with very large sectional properties that can be adjusted with the diaphragm
stiffness factor (see Settings > Data Options).  The larger the diaphragm stiffness
factor, the stronger the in-plane rigid diaphragm action is.  The presence of rigid links
with large diaphragm stiffness factor (say 1E10) could create numerical difficulties
during the solution if the 64-bit floating point solver is used.  However, the unique 128-
bit floating point solver in ENERCALC 3D makes this problem nonexistent in that much
larger diaphragm stiffness factor (say 1E20) may be used without creating numerical
difficulties during the solution.

The program further provides the option to ignore the rigid diaphragm actions as an
analysis option (Analyze > Analysis Options).

It is important to point out that rigid diaphragm action in the program does not
use master-slave nodes.  

6.11 Loads

Point loads or line loads may be applied to a member.  Point loads may be forces or
moments.  Line loads must be forces.  You may specify loads in either the global or
local coordinate system.  The locations of loads must be in ratios of the member
length, measured from the start of the member.  Figure 15.1 shows examples of point
and line loads.

The self weight of members may be calculated automatically if the material weight
densities and self weight multiplier are nonzero.  By default, self weight acts in the
negative global Y direction.  You may however change the direction to positive or
negative direction of the global X, Y, or Z.  This flexibility is useful in some
circumstances.  For example, if you model a grillage on the XY plane, the self weight
may be either in the positive or negative global Z direction, depending on your
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preference on load sign convention.  To activate automatic self weight calculation, use
the command Loads > Assign Self Weights.

Point Loads Line Loads

local y force, distance=0.6 local y force, start distance=0,end distance=1

local z moment, distance=0.4 global Y force, stat distance=0.2, end
distance=0.8

Figure 15.1

An area load may be applied to multiple members on a whole planar area.  The area
is defined by three or four coplanar nodes.  The area load is then distributed as line
loads to perimeter members of enclosed sub-areas within the load area prior to static
or dynamic solution.  Area loads are distributed to perimeter members that form each
of the enclosed sub-areas according to the following methods:

- Two-way (rectangular sub-areas)
- Short-Sides (rectangular sub-areas)
- Long-Sides (rectangular sub-areas)
- AB-CD Sides (rectangular sub-areas)
- BC-AD Sides (rectangular sub-areas)
- Centroid-based
- Circumference-based

The first five distribution methods apply to four-node rectangular sub-areas only.  The
centroid-based method may be applied to convex sub-areas only.  The circumference-
based method may be applied to both convex and concave sub-areas.  Loads may
also be distributed to sides parallel to AB-CD or BC-AD sides of the load area.  The
program is intelligent enough to determine the most appropriate load distribution if
inconsistencies arises.  For example, if you select two-way distribution method for a
sub-area that is not rectangular, the program will use the centroid-based method if the
sub-area is convex or the circumference-based method if the sub-area is concave. 
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The program allows you to convert area loads to line loads directly and automatically.
 This feature allows you to see how exactly the program would distribute area loads
to members prior to the solution.  Of course, you can always undo the conversion if
you want to keep the area loads.  For more information on the load conversion,
please see Loads > Assign Area Loads.

As an example, let’s say we have a 3.5 x 1.5 ft rectangular sub-area subjected to 100
lb/ft^2.  The following line loads (Figure 15.2) are converted from the same area load
based on different distribution methods.

Two-way Distribution

Short-side Distribution

Long-side Distribution

Centroid-based Distribution
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Two-way Distribution

Circumference-based Distribution

Figure 15.2

Area loads may be specified in either the local or global coordinate system.  Global
area loads may be in the global X, Y, or Z direction.  Local area loads may only be in
the local z direction, which is perpendicular to the load area.  It is recommended that
area loads be defined in their own load cases.  In this way, you will find it easier to
identify, edit, and delete area loads later on.

There are a few limitations to the area load concept in the program.  The first
limitation is that the sub-areas must be close-formed by perimeter members.  In the
following Figure 15.3, the sub-area formed by node 97, 98, 104 and 103 is not a
closed sub-area because there is no member connecting the node 97 and 98.  As a
result, no area loading will be distributed to the three perimeter members from the
sub-area.  The second limitation is that sub-areas must not overlap.  In Figure 16.3,
the sub-areas in node 101, 102, 120 and 119 are overlapping.  This will result more
load being distributed to the members in these sub-areas.  The program gives a
warning when the area load footprint is not equal to the total actual loaded area.  The
problem may be solved by splitting members 119-108, 107-120 and 113-114 at the
intersection point.
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Figure 15.3

The third limitation is that any sub-area may not contain more than one concave node
(with internal angle more than 180 degrees).  The fourth limitation is that any sub-area
may not contain the same node more than once in forming the perimeter polygon.

The program offers automatic generation of live load patterning (point and line loads
only).  The following example (Figure 15.4) shows how the program generates load
patterning on a five-span continuous beam.  Loads on each generated pattern reside
in a separate load case automatically generated.  Additional load combinations are
generated as needed as well.

All Spans

Odd Spans

Even Spans
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All Spans

Second Support + Alternate Spans

Third Support + Alternate Spans

Fourth Support + Alternate Spans

Fifth Support + Alternate Spans

Figure 15.4

The program also offers automatic generation of moving loads (point loads only).  The
mechanism employed by the program is similar to the live load patterning.

6.12 Line Springs

Springs are flexible restraints.  Springs applied to members are referred to as line
springs. You may assign a line spring to a member with one or more global DOFs
(Dx, Dy and Dz) restrained. To qualify as a valid flexible restraint, the corresponding
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spring constant must be specified.  A restraint may be designated as linear,
compression-only or tension-only.  A compression-only restraint is active only when
the nodal displacement in the restrained direction is negative.  A tension-only restraint
is active only when the nodal displacement in the restrained direction is positive.  If a
model contains one or more compression-only or tension-only springs, the whole
problem becomes nonlinear and the solution becomes iterative for each load
combination
 
The forces or moments required to enforce the flexible restraints are called spring
reactions.  They are computed by the program.

6.13 Internal Forces and Moments

The program outputs internal forces and moments at designated stations along the
member length.  You may specify the number of segments ranging from 1 to 127 for
member output by running the command Run > Analysis Options.  For smooth
moment and shear diagrams, the program may add extra segments.  

Figure 15.5 shows the positive direction of the internal forces and moments of
members.  

Forces Moments

Axial Force Vx
Torsion Mx

Major Shear Vy Major Moment Mz
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Forces Moments

Minor Shear Vz Minor Moment My

Figure 15.5

Figure 15.6 is an alternative way to show the positive direction of the internal shears
and moments on the local xy and xz planes.

Moment & shear on the local xy plane Moment & shear on the local xz plane

Figure 15.6
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7 Shells

A shell is a structure or part of a structure which has a relatively small thickness in
comparison with the other two dimensions.  A general shell forms a curved surface in
space.  When it forms a flat surface, it is also called a plate.  In this program, when
the term “plate” is used, it refers to flat shell in the out-of-plane bending action.  

The shell element in the program is a four-node (quadrilateral) element that combines
the in-plane membrane action and the out-of-plane bending action.  The in-plane
membrane action is a standard isoparametric compatible formulation with the option
to add incompatible modes.  The out-of-plane bending action is a thick-plate
formulation, with the option to use the thin-plate formulation when the element is
rectangular.  The element can be used to model both flat-surface plates and curved-
surface general shells.  Applications of shell elements in structures are wide and far-
reaching.  Examples are concrete floors, mat foundations, shear wall, folded plates,
barrel vaults, cooling towers, spherical domes, water tanks, etc.  The program
provides powerful commands to generate these and other commonly used plate and
shell structures.  These commands include Geometry > Generate Shells, Edit >
Extrude, Revolve, etc.

For many years, a great number of papers have been published on the subject of
plate and shell structures.  Although the membrane action of a shell element is
relatively simple, the (plate) bending action is much more complex.  Many plate
elements have been proposed, some of which have been implemented in commercial
programs.  However, most of these proposed plate elements are either ineffective or
unreliable.  One of the main hurdles is known as transverse “shear locking”, that is,
elements behave too stiff with respect to shear deformation especially when elements
are thin or geometrically distorted.

One of the few reliable plate elements is a rectangular thin plate element developed
by O.C. Zienkiewicz [Ref. 2].  It is based on the Kirchhoff thin plate bending theory in
which a line straight and normal to the mid-surface of the plate before loading is
assumed to remain straight and normal to the deformed mid-surface after loading. 
The transverse shear strain is therefore assumed to be zero.  This plate element is
important in that it is the first plate element that can be applied reliably in engineering
practice.  Prior to this, plate analysis depended mainly on very few “closed-form”
solutions of simple geometry and boundary conditions, and other very approximate
methods such as equivalent frame method of ACI [Ref. 12].  The Kirchhoff rectangular
thin plate is implemented in the program.  It produces results that converge to
“closed-form” solutions as finite element meshes are refined.  The element, however,
has to be rectangular in shape and does not account for shear deformation.

A much more reliable and effective plate bending element is the MITC4 developed by
K.J. Bathe and others [Ref. 1].  It is a thick plate that is based on Mindlin plate theory
in which a line straight and normal to the mid-surface of the plate before loading is
assumed to remain straight but not necessarily normal to the deformed mid-surface
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after loading.  The element considers shear as well as bending deformations and may
be used for both thick and thin plates.  This plate element differs from earlier Mindlin
theory based plate elements in that different (mixed) interpolations are used to
account for the bending and transverse shear strains.  The MITC4 plate bending
element is implemented in the program.  It is free from “shear locking” and performs
well even when element meshes are distorted.  The shape of the element may be any
general quadrilateral as long as the aspect ratio is within a reasonable range (say 0.2
to 5.0).

7.1 Shell Thicknesses

Each shell must have a thickness assigned to it.  Based on the ratio of thickness to
span length, you may choose to use the thin or thick plate bending formulation.

The thick plate formulation is generally recommended over the thin plate formulation
because it applies equally well to both thick and thin plates.  The program therefore
uses the thick plate formulation by default.  If thickness to span ratio is less than 1/20
and elements are rectangular, you may use the thin plate formulation.  The thickness
should be compared to the support distances, not to the sizes of individual plate
elements.

It is important to point out that out-of-plane shear forces exist in thin plates even
though shear deformations are not considered.  You may draw an analogy between
a plate and a beam.  A thin plate is analogous to a Euler-Bernoulli beam while a thick
plate is analogous to a Timoshenko beam.  We consider shear deformation for the
Timoshenko beam but not for the Euler-Bernoulli beam, while shear forces exist in
both the Euler-Bernoulli and Timoshenko beams.

7.2 Local Coordinate System

Each shell element has its own local coordinate system.  The element local coordinate
systems are used in element stiffness formulations.  They are also used for inputs
such as loads and outputs such as internal shears, moments, and stresses.  Local
angles for rectangular shells must be 0s if thin plate bending formulation is used in the
analysis options.  For definition of the shell local coordinate system, refer to
Coordinate Systems.  

7.3 Shell Numbers

A distinct integral number is assigned to each shell.  Duplicate numbers in shells are
not permitted. There can be gaps in shell numbering sequence.  The order of shell
numbering in a model is insignificant to the results or solution time.  You may
renumber the shells sequentially using the command Edit > Renumber Shells.
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7.4 Element In-Plane Stiffness Matrix

The in-plane element formulation accounts for Dx and Dy of the local coordinate

system.  The in-plane stiffness matrix of the element is based on the standard
isoparametric formulation [Ref 1, 2, 3].  However, when the element is rectangular in
shape, incompatible modes may be optionally added to the formulation [Ref. 3].  An
incompatible element, when applied, yields results of high quality especially when
used to model in-plane bending.  Full two by two numerical integration is used to
calculate the in-plane stiffness matrix of the element.

7.5 Element Out-of-Plane Stiffness Matrix

Out-of-plane bending accounts for Dz, Dox and Doy of the local coordinate system. 

By default, the MITC4 thick plate formulation is used [Ref. 1].  If the thin plate option
is chosen, elements with rectangular shapes will be calculated based on the Kirchhoff
thin plate formulation [Ref. 1].  Full two by two numerical integration is used in either
case to calculate the out-of-plane stiffness matrix of the element.

7.6 Combining Element In-Plane and Out-of-Plane Stiffness
Matrices

The shell element stiffness matrix is the combination of the in-plane and out-of-plane
stiffness matrices.  In order to avoid singularity of the stiffness matrix, a very small
“fictitious” stiffness is added to the diagonal term associated with the local DOF Doz.

7.7 Loads

Surface loads may be applied to a shell. You may specify loads in either the global or
local coordinate system.  Surface loads are lumped to element nodes before solution.
 The self weight of shells may be calculated automatically if the material weight
densities and self weight multiplier are nonzero.  By default, the self weight acts in the
negative global Y direction.  You may, however, change the direction to positive or
negative direction of the global X, Y or Z.  This flexibility is useful under certain
circumstances.  For example, if you select the model type “2D Plate Bending”, the self
weight may be either in positive or negative global Z direction, depending on your
preference on the sign convention.  To activate automatic self weight calculation, use
the command Load > Assign Self Weights.
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7.8 Surface Springs

Springs are flexible restraints.  Springs applied to shells are referred to as surface
springs. You may assign a surface spring to a shell with one or more global DOFs
(Dx, Dy and Dz) restrained. To qualify as a valid flexible restraint, the corresponding

spring constant must be specified.  A restraint may be designated as linear,
compression-only or tension-only.  A compression-only restraint is active only when
the nodal displacement in the restrained direction is negative.  A tension-only restraint
is active only when the nodal displacement in the restrained direction is positive.  If a
model contains one or more compression-only or tension-only springs, the whole
problem becomes nonlinear and the solution becomes iterative for each load
combination.
 
The forces or moments required to enforce flexible restraints are called spring
reactions.  They are computed by the program.  Surface springs may be used to
model Winkler mat foundations.  It may be worthwhile to note that in modeling a mat
foundation, surface spring constants are the soil subgrade moduli while surface spring
reactions are the soil pressures.

7.9 Internal Forces or Moments

The internal forces and moments exist at every point on the middle surface of the shell
element.  They represent the resultants of different normal and shear stresses over
the element thickness.  The internal forces have the units of force per unit length and
the internal moments have the units of moment per unit length.

The in-plane or membrane results include the normal forces Fxx, Fyy and shear force

Fxy.  The out-of-plane results include the shear forces Vx, Vy and bending moments

Mxx, Myy, Mxy.  Mxy is also called twisting moments.  It is important to differentiate

these forces and moments

Figure 16.1 shows the positive direction of the internal forces and moments of a shell.
 They represent forces and moments at one point on the middle surface of the
element.  The program outputs these forces and moments at the four corner nodes
and /or at the center of the element.  You may use Analysis Results > Results 
Diagrams > Contour Diagram to see the distribution of these and other resultants. 
Generally speaking, internal forces or moments (or result in general) are different
across element boundaries.  You have the option to average forces and moments for
adjacent elements at nodes.  To do that, click Analyze > Analysis Options.
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the in-plane axial and shear forces

the out-of-plane bending shears the out-of-plane bending moments

Figure 16.1

Based on the internal forces and moments, the program computes the internal
stresses at the shell bottom (the –z side) and top (the +z side) as follows.  The
stresses are expressed in the local coordinate systems.  The stress directions
correspond to the in-plane normal axial forces and shear, and the out-of-plane shears.

(@ bottom) or (@ top)

(@bottom) or (@ top)

(@bottom) or (@ top)
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The program also outputs in-plane principal forces and angles, and out-of-plane
principal forces, moments, and angles.  In addition, principal stresses S1, S2, and S3

are computed based on the stresses  as follows:  

The Von Mises stress, which is often used to estimate the yield of ductile materials, is
then computed as follows:

7.10 Membrane Nodal Resultants

The membrane nodal resultants of a shell are concentrated forces Fx and Fy (Unit:

Force) at the four nodes of each shell element.  They in effect keep each individual

element in equilibrium (in-plane).  They are expressed in the local coordinate system. 

You may view nodal forces of selected shell elements by View > Annotate.  The
membrane nodal forces may be used to compute shears, axial forces, or moments in
a shear wall. For example, the following three shells represent a pier in a shear wall. 
Each shell is 1.5 x 1.5 ft in size.  Membrane nodal resultants Fx and Fy are shown in

the first and second rows respectively at each corner of the element.  The shear, axial
force and moment resultants on the top of the pier may be computed as follows:
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Fxi (kips) Fyi (kips) Xi (ft) Fyi * Xi (ft-kips)

1.758 -2.284 -2.25 5.139

3.226 1.663 -0.75 -1.24725

7.226 -8.458 -0.75 6.3435

5.786 4.611 0.75 3.45825

3.144 -3.718 0.75 -2.7885

2.722 3.082 2.25 6.9345

Shear 
ΣFx = 23.862

Axial Force
ΣFy = -5.104

Moment

ΣM = 17.8395
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8 Bricks

The Brick element in the program is an eight-node solid element based on
isoparametric compatible or incompatible formulation [Ref 1, 2, 3].  It may be used to
model structures where actions in all three dimensions are significant.  

8.1 Local Coordinate System

The local coordinate systems for all Bricks are the same.  They are identical to the
global coordinate system.  The element nodal connectivity must be numbered in such
a way so that the normal vector of the surface 1-2-3-4 points to the surface 5-6-7-8
(Figure 17.1).  This is to avoid negative diagonals in the element stiffness matrix.  You
may use the command Edit > Reverse Node Order for Selected Elements if the
normal vector is not in accordance with the requirement.  For more information about
the brick local coordinate system, refer to Coordinate Systems.  

solid element

Figure 17.1

8.2 Brick Numbers

A distinct integral number is assigned to each Brick.  Duplicate numbers in Bricks are
not permitted. There can be gaps in Brick numbering sequence.  The order of Brick
numbering in a model is insignificant to the results or solution time.  You may
renumber the Bricks sequentially using the command Edit > Renumber Bricks.

8.3 Element Stiffness Matrix

The element formulation accounts for Dx, Dy and Dz of the local coordinate system. 

The element stiffness matrix is based on isoparametric compatible or incompatible
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formulation [Ref 1, 2, 3].  Therefore, the stiffness matrix is of size 24 by 24.  Full two
by two numerical integration is used to calculate the stiffness matrix.

8.4 Loads

Loads on Brick elements must be input as nodal loads.

The self weight of Bricks may be calculated automatically if material weight densities
and self weight multiplier are nonzero.  By default, the self weight acts in the negative
global Y direction.  You may however change the direction to positive or negative
direction of the global X, Y or Z.  To activate automatic self weight calculation, use the
command Loads > Assign Self Weights.

8.5 Internal Stresses

Three normal stresses σxx, σyy , σzz and three shear stresses σxy, σxz,  σyz  are

computed by the program.  They are output at the eight nodes and/or at the center of
the element.

The program also outputs principal stresses S1, S2, S3 and the corresponding

directional vectors (V1x, V1y, V1z) and (V 3x, V 3y, V 3z).  The Von Mises stress,

which is often used to estimate the yield of ductile materials, is then computed as
follows:
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9 Static Analysis

The stiffness (or displacement-based) method is used in the solution of the structural
model.
The following outlines the major analysis steps:

· The individual element stiffness matrix [k] is computed in the element local
coordinate system.

· Based on the element nodal connectivity, [k] is transformed to the global
coordinate system and assembled into the global stiffness matrix [K].

· The load vector [R] for each load combination is formed.
· The equation [K] [U] = [R] is solved for the nodal displacements [U].  
· Other structural responses such as internal forces and moments are computed

based on the nodal displacements.
 

9.1 Load Cases and Load Combinations

Each of the nodal loads, point loads, line loads, surface loads, and self weights must
be assigned to a load case.  The enforced displacements of supports are special
loads and are considered in each load combination.  The load cases are used as
bases for the load combinations and are not solved directly.  If you desire to solve for
a particular load case, you may form a load combination with a unit load factor for that
load case and 0s for all other load cases.   

P-Delta analyses may be performed on one or more load combinations.

9.2 Linear, Non-linear Static Analyses

The program is capable of performing linear and nonlinear static analyses.  The linear
analysis may be applied to models where structural responses such as the
displacements are expected to be linearly related to the applied loads.  Otherwise the
nonlinear analysis must be applied.  The program currently handles two types of
nonlinearity: the element nonlinearity when compression-only springs or tension-only
springs are present, and the geometric nonlinearity which is commonly known as the
P-Delta effect.  The P-Delta effect refers to the axial stress influence on the element
bending stiffness.  Generally, a tensile axial force increases the element bending
stiffness while a compressive axial force reduces the element bending stiffness.  The
P-Delta effect exists in both members and shell elements.  However, the program only
accounts for the P-Delta effect on members.

The program assigns each load combination to be linear or nonlinear just before
analysis is performed.  If a model includes one or more nonlinear elements
(compression-only springs or tension-only springs), the entire problem becomes
nonlinear, that is, all load combinations are assigned to be nonlinear.  If there are no
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nonlinear elements present in the model, only the P-Delta load combinations are set to
be nonlinear while the rest of load combinations are linear.  The non-linear load
combinations must be solved iteratively and therefore are potentially time consuming. 
Analyses are performed on all linear load combinations first and then on all nonlinear
load combinations.  

In order to avoid excessive iterations on nonlinear load combinations, you can use the
command Analyze > Analysis Options to set “Maximum nonlinear iterations”.  For the
P-Delta load combinations, you can use the same command to set “Axial force
tolerance between P-Delta iterations”.  A tolerance of 0.5% is normally acceptable.  It
is strongly recommended that you perform linear analyses for all load combinations
before you attempt P-Delta analyses.  In this way, you can identify any modeling
problems prior to performing more rigorous and generally more time consuming P-
Delta analyses.

It may be interesting to note that the P-Delta analysis may be used to estimate the
buckling load of a structure for a P-Delta load combination.  To do that, try to apply
different scales (λ) uniformly to the load factors of all load cases in the P-Delta load
combination, until a zero or negative diagonal term is detected in the global stiffness
matrix during the solution process.  The lowest scale λ is the buckling load factor. 

9.3 P-Delta (P-∆) vs. P-delta (P-δ)

The P-Delta (P-∆) refers to the second order effect associated with the lateral
translation of the members [Ref. 10, 11, 12].  Consider the moment M at the bottom
of the column in Figure 18.1.  If the effect of the axial force on bending is ignored, M =
H * L.  However, if the effect of the axial force on bending is considered, M = H * L +
P * ∆.  The increase in moment in turn increases the deflection ∆, which further
increases M, and so on.  An equilibrium will eventually be reached unless the axial
load P exceeds the column critical buckling load. 
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Figure 18.1

P-delta (P-δ) refers to the second order effect associated with the member curvature
[Ref. 10, 11, 12].  Consider the moment M at the middle of the column in Figure 18.2.
 A secondary moment P * δ is induced by the axial load acted upon the lateral
defection of the column.  This additional moment will cause more lateral deflection,
which in turn will induce more secondary moment, and so on.  An equilibrium will
eventually be reached unless the axial load P exceeds the column critical buckling
load.

Figure 18.2

The presence of the axial force in effect reduces the column bending stiffness.  The
member geometric stiffness accounts for this reduction.  The P-Delta analysis in the
program is capable of handling both P-∆ and P-δ effects.  In order to account for the
P-δ component, however, you must split compression members (columns) into several
segments.  Normally four segments for each column are enough.  The program
provides the command Edit > Split Members to automatically split members.

As an example [Ref. 13], assume in Figure 19.2, the beam-column is of L = 12 ft in
length, and is subjected to an axial compressive load of P = 100 kips and a transverse

load of Q = 6 kips at midspan.  The member section: 4 x 4 inches, I = 21.33 in4, A =

16 in2.  The material: E = 30000 ksi, υ = 0.30.  Theoretical results are calculated as
follows:
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Linear (bending only):  ft-kips;  in

P-δ (bending and axial load):  radian (or 51.57o)

ft-kips;  in

To solve this problem in the program, we can create one linear load combination and
one P-Delta load combination.  Since the problem involves the P-δ effects, the beam-
column must be modeled with multiple elements (4 beam elements generally
sufficient).  The results from the program are compared with the theoretical results
below:

The moments and deflections at the midspan for linear and P-δ behaviors

Analysis Type Effects ENERCALC 3D Theoretical

Linear

δmid (in) 0.5832 0.583

Mmid (ft-kips) 18 18

P-δ

δmid (in) 0.8643 0.864

Mmid (ft-kips) 25.203 25.2

9.4 Solution Algorithm

Mathematically, the static analysis involves solving the following simultaneous
equations: 

[K] [U] = [R]

where [K] is the global stiffness matrix, [U] is the displacement vector, and [R] is the
load vector for each load combination.
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There are two solution algorithms used in ENERCALC 3D: skyline and sparse.  The
skyline solution algorithm used to solve the equation above was developed by K.J.
Bathe [Ref. 1].  It is an active column (also called profile or skyline) solver that
involves the factorization of a stiffness matrix and the back-substitution of the load
vector.  The factorization generally takes most of solution time while the back-
substitution is relatively fast.  For all linear load combinations, the factorization only
needs to be performed once.  For nonlinear load combinations, the factorization has
to be performed multiple times on each load combination because the global stiffness
matrix has to be updated during the solving process.  This is the reason why linear
and nonlinear load combinations are analyzed separately. 

The sparse solver only stores non-zero elements in the global stiffness matrix, thus it
is both more memory efficient and much faster than the skyline solver.  It also has the
option to use an out-of-core approach to minimize the requirement of computer
memory.  This is useful to solve extremely large structural models.  The sparse solver
is available for static analysis only.  It lacks some of the informative error messages
when something goes wrong during the solution process.

9.5 Solution Accuracy and Stability

At the very basic level, the solution involves basic arithmetic operations such as
addition, subtraction, multiplication and division on floating point numbers.  Since all
numbers in computers are stored in finite number of bits or digits, round-off errors are
introduced by manipulations of these numbers.  Round-off errors depend on the
precisions of floating point arithmetic and may affect the solution accuracy and
stability under certain circumstances. Two types of precisions are generally available
on most computers today: single precision and double precision.  A single precision
(or 32-bit) floating point value has numerical accuracy of about 7 significant digits
while a double precision (or 64-bit) floating point value has numerical accuracy of
about 15 or 16 significant digits.
 
Take a look at the following example:

A = 1.00000001; B = -1.0; C = 1.0; D = C / (A + B);

Theoretically, D = 100000000.0.  With 64-bit floating point arithmetic, the statement
yields D = 100000000.60775 while with 32-bit floating point arithmetic, the statement

theoretical answer with double precision arithmetic.  The solution collapsed (division
by zero) with single precision arithmetic.  The reason for this to happen is during the
addition of A and B, the fractional part of A (0.00000001) is rounded off due to lack of
enough significant digits.  In general, 32-bit floating point arithmetic should never be
used in any structural or finite element analysis programs.  

The 64-bit floating point (double precision) has been the predominant solver over the
last several decades.  For most not-so-large and well-conditioned models, standard
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64-bit floating point solvers produce results that are sufficiently accurate for practical
uses.  However for very large and complex models and especially those under ill-
conditioned circumstances, standard 64-bit floating point solvers sometimes produce
inaccurate results.  

Ill-conditioning occurs when small errors in the coefficients of equations before or
during the solution process have large impact on solution results.  It may make the
solution unstable and results unreliable.  Very severe ill-conditioning may even make
the coefficient matrix singular and thus a solution non-existent.  Some examples where
ill-conditioning may occur are: finite elements with severe shape distortion or large
aspect ratio; shells with very strong in-plane stiffness and very weak out-of-plane
bending stiffness; very flexible elements connected to very stiff elements.  It may be
worthwhile to note that when ill-conditioning does happen, finer element meshes
tend to make the problem worse.  

During the solution process of a large model, round-off errors tend to accumulate. 
We can determine the number of significant digits lost based on the diagonal decay
ratio [Ref. 3]. 

ri = Kii / Pii

where Kii is the original diagonal coefficient of the global stiffness matrix and Pii is the

reduced value of Kii just before it is used for back-substitution.  The number of

significant digits lost is about log10(ri).  For example, if ri is 108, then 8 digits are lost.

 The solution results given by the 64-bit floating point (double precision) are unreliable
if 12 or more significant digits are lost during the solution process.  The program
reports the number of digits lost during the solution process.  

Consider the following cantilever beam under a tip load of 10,000 lbs:

L = 100 in; Izz = 200 in4;

E = 2.9e7 psi; ν  = 0.3; 
P = -10000 lb

The beam is modeled with 1, 1000, 10000, 20000, 50000 elements and an analysis is
performed on each model.  Theoretically all models should yield the same tip
deflection of -0.5747 inch (shear deformation ignored).   The following table shows tip
deflections for the all five models using the 64-bit floating point (double precision) in
the program.
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Effect of number of elements on accuracy (the 64-bit skyline solver) of a cantilever
beam

No of elements 1 1,000 10,000 20,000 50,000

Tip deflection (in) -0.5747 -0.5748 -0.6522 -0.1534 No solution

No of digits lost 0 8 12 12 -

As we can see from the table above, the tip deflections given by the 64-bit skyline
solver tend to deteriorate in accuracy as the number of elements increases.  For the
model with 50,000 elements, some diagonal terms in the global stiffness matrix even
become negative.  The solver has to abort and the solution is not obtainable anymore.
 

After identifying a severe ill-conditioning problem, the 64-bit floating point (double
precision) generally stops the solution process.  No results are better than wrong
results.  To address the problem, a more accurate solver is needed.  ENERCALC 3D
implements a unique 128-bit floating point (quad precision) solver which offers
unparalleled advantages in solution accuracy and most importantly solution stability
over the standard 64-bit floating point (double precision) solver.  The 128-bit floating
point (quad precision) provides numerical accuracy up to 30 significant digits.  Many of
ill-conditioned problems for the 64-bit floating point solver become well-conditioned
problems for the 128-bit floating point solver.  The superiority of the 128-bit floating
point solver can be demonstrated by running the same cantilever beam above with
50,000 elements, the tip deflection given by the 128-bit floating point (quad precision)
is -0.5747 inch, the correct answer.

A more practical application of the 128-bit floating point (quad precision) may be in the
modeling of a rigid diaphragm (e.g. floor with much larger in-plane stiffness than out-
of-plane stiffness).  Most of the other programs model this kind of rigid diaphragm
action through master-slave constraints in order to avoid numerical difficulties.  With
the 128-bit floating point solver available in ENERCALC 3D, you may model the floor
as a flexible diaphragm, yielding much more realistic results.  

It should be pointed out that the 128-bit floating point (quad precision) requires twice
as much memory as the 64-bit floating point (double precision).  It is also significantly
slower.  However, in situations where the standard 64-bit floating point solver
produces unreliable or even wrong results, the 128-bit floating point (quad precision)
provides an invaluable alternative.  Between faster but wrong results and slower but
correct results, the latter is obviously preferable.



Frequency Analysis
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10 Frequency Analysis

The frequency analysis solves for frequencies and corresponding mode shapes
(eigenvectors) of the structural system.  Many concepts discussed in the previous
chapter-“Static Analysis”, apply to the frequency analysis as well.

10.1 Solution Algorithm

Mathematically, the frequency analysis involves solving the following Eigen problem: 
[K] [Φi] = λi [M] [Φi]

where [K] is the global stiffness matrix, [M] is the global mass matrix, [Φi] is the ith

mode shape and λi is the ith eigenvalues which is equal to the free vibration circular

frequency squared (ω i)
2
.  Other related values are frequency fi which is 2π  ω i and

period Ti which is 1 / fi.  For practical reasons, we are generally interested only in the

lowest eigenvalues (and therefore lowest frequencies).

The solution of eigenvalue problems must be iterative in nature because it is equivalent
to finding the roots of the polynomial p(λ).  The solution algorithm to solve the equation
above is given by K.J. Bathe [Ref. 1].  It uses the subspace iteration method to
iteratively find the lowest p eigenvalues λ1, λ2, … λp and corresponding vectors [Φ1],

[Φ2], …[Φp].  Eigenvalues are extracted in ascending order.  Each eigenvector is then

normalized such that [Φi]
T[M] [Φi] = [I] where [I] is the identity matrix, a diagonal

matrix with unit values along the main diagonal.

A tolerance may be set before the solution to control the convergence of eigenvalues
during each successive solver iteration.  It is expressed as the following:
 (i = 1, 2, …number of requested modes)
where k is the subspace iteration counter.

To prevent excessive computing time, a maximum number of subspace iterations may
be set before the solution.  If the solver reaches this limit without convergence, the
eigen results should not be trusted.

At the completion of the solution, an error measure is computed for each eigenvalue
according to the following [Ref 1]:

Error Measure = 
Where is the vector in the matrix corresponding to and the eigenvalues are accurate

to about 2s digits if Error Measure is less than 10-2s.
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10.2 Mass and Stiffness

The global mass matrix [M] is diagonal and is computed based on the load
combination for frequency analysis and/or additional nodal masses/mass moments of
inertia.  The load combination for frequency analysis may be specified in Run >
Frequency Analysis.  The program will automatically convert all forces (not moments)
in the positive or negative gravity direction to nodal masses and apply them in all
available mass degrees of freedom.  Additional nodal masses and mass moments of
inertia may be input from Loads > Additional Masses or Input > Additional Masses. 
Zero terms in the global mass matrix [M] are allowed.  The number of eigenvalues
requested must be fewer than the mass DOFs which is the number of nonzero
diagonal terms in [M].  Due to the lumped mass modeling, the elements should be
properly divided or submeshed for a continuous vibration model.  For example, a
beam with uniformly distributed mass should be divided into at least eight elements in
order to find accurate vibration results.

The load combination for frequency analysis is also used to compute the global
stiffness matrix [K] if the model response is not linear.  This may be the case if 1).
The load combination for frequency analysis is of P-Delta type; or 2). The model
contains nonlinear elements such as compression-only springs.  In the first case
(geometric nonlinearity), the compressive forces decrease the model stiffness (and
therefore lengthen the vibration periods of the model) while tensile forces increase the
model stiffness.  The influence of the axial loads is greater on the lower frequencies
than on the higher ones.  The effect of nonlinearity on the stiffness matrix of the
structure is incorporated as follows:

· An iterative (nonlinear) static analysis is first performed with the loads in the
load combination for frequency analysis.

· The stiffness matrix at the end of the static analysis will be used in the
frequency analysis.  The stiffness therefore includes geometric and element
nonlinearities corresponding to the end of the nonlinear static analysis.

Forced displacements at supports are ignored in frequency analysis.

10.3 Solution Convergence

Due to the iterative nature in the eigen solution, much more computational effort is
required (in order to achieve satisfactory convergence) in frequency analysis than in
static analysis.  Another important difference is solution stability, which is more difficult
to achieve in frequency analysis.  To ensure that the smallest required eigenvalues
and the corresponding eigenvectors have been computed, the program performs a
Sturm sequence check after the subspace iterations [Ref 1].  A warning message is
given in the solver dialog box if some eigen values are missing after the Sturm
sequence check.  Under some rare circumstances, the solution may become unstable
and the solver has to abort the solution process
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Several remedies can be used to address the solution instability and solution
divergence.  
1). Solve for fewer number of modes.
2). Use larger number of iteration vectors.
3). Use 128-bit floating point arithmetics instead of 64-bit floating point arithmetics.
These remedies may be used in tandem.  Once again, the 128-bit floating point
arithematics is especially effective for solution stability.

The maximum number of subspace iterations is set to 18 by default.  If no
convergence is achieved at this limit, you should rerun the frequency analysis with a
larger maximum number of subspace iterations.



Concrete Design – ACI
318-02/05/08/11/14
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11 Concrete Design – ACI 318-02/05/08/11/14

The concrete design module performs concrete design for beams, columns and plates
(bending only) according ACI 318-02, 05, 08, 11 and 14 [Ref. 19].  Static analysis
must be performed successfully before concrete design can be performed.  Sound
engineering judgment is especially important to interpret and apply the design results
given by the program.

Note: The provisions that apply for ACI 318-02 and 05 shall apply to ACI 318-08,
11 and 14 unless explicitly stated otherwise.

11.1 Concrete Column Design

General
The concrete column module designs concrete rectangular or circular columns against
axial, uniaxial or biaxial bending as well as shear based on ACI 318-02/05/08/11/14
Code Provisions.  The program generates EXACT (not approximate or empirical) P-
Mx-My interaction surfaces for all sections according to user-specified design criteria.
 The capacity ratio is computed for each column based on capacity interaction
surfaces and axial force-biaxial bending in each load combination. Slenderness effects
are considered for both non-sway (braced) and sway (unbraced) frames.  Shear
design in columns is based on the shear force envelope with the option to include or
exclude axial force influence on concrete shear capacity.

Axial Load and Moment Convention
For concrete design, compressive and tensile axial loads have positive and negative
signs respectively.  The major moment is designated as Mx in design as opposed to
Mz used in analysis output.  The minor moment is designated as My in both analysis
and design.

Solution Assumptions
· The strain in reinforcement and concrete is directly proportional to the distance

from the neutral axis (ACI 318-02/05 10.2.2).
· The maximum usable strain at the extreme concrete compression fiber is equal

to 0.003 (ACI 318-02/05 10.2.3).
· The stress of steel is fs = Es * εs but fs  <= fy where Es = 29000 ksi, εs is

steel strain and fy is the yield strength of steel (ACI 318-02/05 10.2.4).

· The tensile strength of the concrete is neglected in flexural calculation (ACI
318-02/05 10.2.5).

· A uniformly distributed stress of 0.85fc is assumed over an equivalent
compression zone bounded by the edge of the cross section and a line parallel
to the neutral axis at a distance a = β1* c where c is the distance from extreme

compression fiber to neutral axis (ACI 318-02/05 10.2.7.1).
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· β1 = 0.85 – 0.05 * (f’c - 4) and 0.65 <= β1 <= 0.85 and f’c unit is ksi

· Reinforcement ratio ρ should be 1% <= ρ <= 8% for column sections (ACI 318-
02/05 10.2.7.3).

Solution Algorithms

1.  All sections are EXACTLY solved biaxially based on the solution
assumptions above.  Each section is solved based on the following steps.

2.  Nominal Strength Calculation (Pn, Mnx, Mny)

2a. The nominal capacity of a section is computed at successive choices of biaxial
angles.  The choices of angles are based on the user input for biaxial angle steps
found in the command Concrete > Design Options.  Biaxial angle steps affect the
solution accuracy and speed.  For biaxial problems, steps must be multiples of 4.  A
value of 16 ~ 32 is sufficiently accurate for most sections.  The adequacy of biaxial
angle steps can be determined by smoothness of the Mx-My interaction diagram.  For

uniaxial problems, biaxial angle steps should be set to 4.  This will give P-Mx (+) at 0

degree angle, P-Mx (-) at 180 degrees angle, P-My (+) at 90 degree angle, P-My (-)

at 270 degrees angle.  

The number of biaxial angle steps is analogous to the number of sides of a polygon
used to approximate a circle or ellipse.  A uniaxial solution in the program is therefore
analogous to using a square to approximate a circle or a rectangle to approximate an
ellipse.  A biaxial solution with 16 angle steps is analogous to using a 16-sided
polygon to approximate a circle or an ellipse.  Obviously, the 16-sided polygon is
closer or more accurate to approximate a circle than a square.  The moral of this
comparison is that a low value of biaxial angle steps tends to give more conservative
biaxial capacity for the section.
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2b). For each biaxial angle, Pn, Mnx, Mny and maximum tensile steel strain εt are

computed at successive choices of neutral axis distance c using strain compatibility
and stress-strain relations to establish bar forces and the concrete compressive
results.  The choices of c are based on the neutral axial steps found in the command
Concrete > Design Options.  Neutral axial steps affect the solution accuracy and
speed.  A value of 250 ~ 500 for neutral axis steps is sufficiently accurate for most
sections.  The adequacy of neutral axis steps can be determined by smoothness of
the P-Mx and/or P-My interaction diagrams.  In addition, the program always

computes several control points.  They are maximum Pn (compression), minimum Pn
(tension), fs = 0; 0.25fy; 0.5fy and 1.0fy (balanced condition).  Concrete displaced by

steel may be optionally included or excluded (by default).

2c). Mnx-Mny contour curves are computed for successive choices of axial forces. 

This is achieved through interpolation on the Pn, Mnx and Mny already calculated for

each biaxial angle in the procedure above.  The choices of axial forces are based on
the neutral axial steps found in the command Concrete > Design Options.   

3.  Design Strength Calculation (φPn, φMnx, φMny)

Design strength according to ACI 318-02,05/08/11/14 is obtained by multiplying Pn,

Mnx and Mny of each biaxial angle by applying strength reduction factor φ as

determined in the following (ACI 318-02/05 9.3.2):
Φc = 0.65, α  = 0.80 for tied confinement

Φc = 0.70, α  = 0.85 for spiral confinement for ACI 318-02/05

Φc = 0.75, α  = 0.85 for spiral confinement for ACI 318-08/11/14

For (εt <= εy, compression-controlled sections)

φ = Φc 

For (εt > 0.005, tension-controlled sections)

φ = 0.90
For  (εy  < εt < 0.005)

φ = Φc + (0.9 - Φc) * (εt  - εy ) / (0.005 – εy)

where εt is maximum tensile steel strain for the biaxial angle and εy is steel yield strain

(at balanced condition) 

In addition, φ Pn must be always less than the following (ACI 318-02/05 10.3.6.1)

Φc * α * [ 0.85 * fc
’ * (Ag – As) + fy * As] if concrete displaced by steel is excluded

or 

Φc * α * [ 0.85 * fc
’ * Ag + fy * As] if concrete displaced by steel is not excluded.
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4.  Capacity Ratio

Capacity ratio is computed for each section based on the loads and the capacity of
the section.  It is defined as the following:
For a given load set (Pu, Mux, Muy), find the section capacity Mx-My contour at φPn=

Pu.  The capacity ratio for the load set is the larger of: 

Where (φMnx,max, φMny, max) is the interaction point between the line from point

(Mux, Muy) to point (0, 0) and the Mx-My contour line. is the maximum compression

or tension capacity of the section, depending on the positive or negative sign of Pu.  If

Pu is outside the maximum compression or tension capacity, a capacity ratio of 99.9

is assigned.

A capacity ratio equal or less than 1.0 means the design strength is greater than the
required strength; and the section is adequate to resist all input loads. A capacity ratio
greater than 1.0 means the design strength is less than the required strength and the
section is inadequate to resist all input loads.  It is important to realize that capacity
ratio defined in the program is just a measure of section adequacy against loads.  It
should not be equated to a factor of safety. 

Capacity Ratio Calculation Example

To illustrate the calculation of capacity ratio in the program, see the following
example.
For a given load set (Pu, Mux, Muy) = (333 kip, 180 ft-kip, 125 ft-kip), a Mx-My
capacity contour at φPn = 333 kip is obtained as shown below.  In addition, the

maximum compression capacity = 1050.2 kip.
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The interaction point between the line from point (180 ft-kip, 125 ft-kip) to point (0, 0)
and the contour line is obtained as (214.1 ft-kip, 148.7 ft-kip)

Therefore, the capacity ratio corresponds to the load set is 0.841.  The section is
adequate to resist the load.

P-δ and P-∆ Effects
Two types of second-order moment effects may develop in a frame.  
1). P-δ effect is associated with individual member curvature.  Additional second-order
moment may develop by member (usually a column) axial force (P) acting upon the
lateral deflection (δ) of the column axis away from the chord connecting the column
ends.  It is possible to account for P-δ effects on columns independently.

119
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2). P-∆ effect is associated with the lateral drifts of the frame members.  Additional
second-order moment may develop by axial force (P) acting upon the lateral
translation (∆) of the frame nodes relative to their original position.  It is NOT possible
to account for P-∆ effects on columns independently.

Slenderness Effects
For a non-sway frame, P-∆ effect may be safely ignored and the first-order structural
analysis is therefore sufficient.  The program then accounts for P-δ effect by
magnifying the first-order moments using ACI moment magnification method.

For a sway frame, the second-order structural analysis must be performed to account
for P-∆ effect.  In addition, the program accounts for P-δ effect by magnifying the
second-order moments using ACI moment magnification method.  In fact, all columns
in sway frames must first be considered as braced columns under gravity loads acting
alone.

Braced or Unbraced Column
The column is considered braced if one of the following two criteria is met:
Criterion 1:  Increase in column end moment due to second-order effects is less than
5% of the first-order moment

Criterion 2:  Stability index Q for the column story under consideration from the first-
order analysis

(ACI 318-02/05 Eq10-6)

Section Properties for Structural Analysis and Computing K
It is important to point out that in both first- and second-order analyses; appropriate
member stiffness must be used to account for the effects of axial loads, cracking, and
creep.

for normal weight concrete

for wc between 90 and 155 lb/ft3

Moment of inertia (ACI 318-02/05 10.11.1)
= 0.35 Ig for beams and cracked walls

= 0.70 Ig for columns and uncracked walls

= 0.25 Ig for flat plates and flat slabs

Area
A = 1.0 Ag

Note: 
a). Ig and Ag are based on the gross concrete cross section, neglecting

reinforcement.

195

195

198
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a). Ig for Tee beams can be closely approximated as 2 times Ig for the web.

b). 0.70 Ig should be used for walls first.  If the factored moments and shears indicate

that a portion of the wall will crack due to stresses reaching the concrete modulus of
rupture, the analysis should be repeated with 0.35 Ig for the cracked portions of the

wall.
[Ref. 16 pp577]

The program allows a user to modify the moments of inertia through Element Cracking
Factor from Concrete > Cracking Factors.  In order to use stiffness reduction, you
also need to check “Use cracked section properties (Icr) for members and finite
elements” in Analysis Options.  This allows you to consider or ignore cracking in the
analysis without re-entering element cracking information.

Radius of Gyration

Effective Length Factor K

Find relative stiffness ratios ( ) of columns and beams at the top and bottom
joints of the column

                                                                                 
                                                                                                                             
                                                                                                                             
             
Section properties are the same as used in the first-order analysis (step 1)

For practical reasons,  for fixed end and  for hinged end.

The effective length factor K is solved from the from the following equations
For braced frames:

For unbraced frames:

195
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The program provides a tool to calculate the effective length factor K based on the

input .  The equations above provide a more accurate K calculation than
what is given by (ACI 318-02/05 10.12.1)

Unsupported Length Lu
The unsupported lengths Luy, Luz of a column are the clear distances between lateral

supports in column local y and z directions (ACI 318-02/05 10.11.3.1).  A zero value
of Lu means that it is equal to the member length between the end nodes.

For non-sway frames, an optional check is made kLu / r <= 34 – 12(M1/M2)  (ACI

318-02/05 Eq10-7).  Braced frame k is used here.  Lu is unbraced length in local x
and y directions.  M1 and M2 are the smaller and larger factored end moments on the

compression member respectively.  (M1/M2) is positive if the member is bent in single

curvature and negative otherwise.
 
For sway frames, an optional check is made kLu / r <= 22 (ACI 318-02/05 10.13.2). 
Sway frame k is used here. 

Minimum Moments
The program calculates minimum moments for both braced and unbraced frames,

 , where h is in inches (ACI 318-02/05 10.12.3.2).  The
program conservatively applies the minimum eccentricity about both axes
simultaneously.

Equivalent Moment Factor Cm (ACI 318-02/05 10.12.3.1)

 if M1 = 0 or M2 = 0

 if transverse load exists

 if end moments only.  (ACI 318-02/05 Eq10-13).  

Although not required, the program also conservatively applies  for ACI 318-
08 /11/14.

The sign of is: positive if the column is bent in single curvature, negative
otherwise.

Note, Cm is only applicable to non-sway frames.  You have the conservative option to
always use Cm = 1.0 from Model Design Criteria under Concrete > Design Criteria.

195
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Section Properties for Critical Loads Computation
The EI used in the frame analysis above is an average value.  In designing individual
columns, the following reduced EI should be used to reflect the greater chance of
cracking:

(ACI 318-02/05 Eq10-12)

The Infamous
The ratio of maximum factored axial sustained load to maximum factored axial total

load.  The factor  accounts for the effects of creep.

Generally:  

Critical Load Pc

  where (ACI 318-02/05 Eq10-10)

Moment Magnification Factor

 (ACI 318-02/05 Eq10-9)

Pu is the average of axial force at both ends.  If , the design fails and a

capacity ratio of 999.9 is assigned.

Other Requirements
Reinforcement ratio for columns: 

Bar requirements: minimum 4 bars for tied columns, 6 bars for spiral columns.

Tie requirements: >= #3 for No. 10 longitudinal bars and smaller; >= #4 for No. 11 14,
18 longitudinal bars.

Column Trial Size
The ACI code requires that the reinforcement ratio for columns be within

.  It is usually economical to have .
For tied columns
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For spiral columns

Based on rectangular or circular sections used for analysis, the program will generate
column sections with different reinforcement configurations. 

Column Shear Reinforcement

The column shear design is based on 

(ACI 318-02/05 Eq11-1)

where .

Given bw, d, fc, fy, number of stirrup legs n, and stirrup (tie) area Av, the required

stirrup spacing is computed at every analysis station.

Concrete shear strength
1.  For Pu < 0 (column subjected to tension)

(ACI 318-02/05 Eq11-8)

2.  For Pu >= 0 (column subjected to compression)

(ACI 318-02/05 Eq11-4)

Note: 

· For circular section,  and d = 0.8(2R) where R is the radius of the
circular section.  (ACI 318 11.3.3 and 11.5.7.3)

· Nu = 0 if the influence of compression on concrete shear strength is ignored.

·  (ACI 318 11.1.2)

· ksi in design of shear reinforcement. (ACI 318-02/05 11.5.2)
· Light-weight concrete is not considered.
· Torsional forces are not considered.
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The following is the algorithm used to compute the stirrup (tie) spacing(s) in the
program.

If , the design fails (ACI 318-02/05 11.5.7.9).

If , no stirrup required (ACI 318-02/05 11.5.6.1).  The program does not
check member depths when applying minimum shear reinforcement for ACI 318-
08/11/14.

If , smax <= min(d/2, 24 in) (ACI 318-02/05 11.5.5.1)

If , smax <= min(d/4, 12 in) (ACI 318-02/05 11.5.5.3)

If , s = min <= smax (ACI 318-02/05 11.5.6.3)

Otherwise, s = <= smax (ACI 318-02/05 Eq11-15)

According to ACI 318-02/05, column confinement spacing shall not exceed 16
longitudinal bar diameters, 48 tie bar or wire diameters, or the least dimension of the
compression members.

The following additional requirements are needed for column spirals:
· The maximum center-to-center spacing:

 s <   (Derived from ACI 318-02/05 Eq10-5)
· The clear spacing between successive turns shall not exceed 3 inches, nor be

less than 1 inch. (ACI 318-02/05 7.10.4.3)

11.2 Concrete Beam Design

General
The concrete beam module designs concrete rectangular or Tee beams against
enveloped bending about strong axis (local z) and enveloped shear along local y. 
Axial force, bending about weak axis (local y), and torsion are not considered. 
Furthermore, no deep beam action is considered.  If axial force or biaxial bending
actions cannot be neglected, the use of column design module is recommended.

Beam Flexural Reinforcement
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The beam top and bottom flexural reinforcement is computed at each analysis station
along the beam length. Minimum reinforcement is computed for the bottom steel.  The
program designs each beam against positive or negative moment with single layer of
tension steel with tension-controlled condition.  For flexural design, the critical section
at a support may be taken at the face of the support (but not greater than 0.175 *
span length from the support center). The program offers an option to account for
these conditions by automatically computing beam support widths from Model Design
Criteria under Concrete > Design Criteria.

The following algorithm assumes one layer of tension steel, that is, dt = d, the depth

of the tension steel centroid.  This assumption is made due to its simplicity and
conservative nature and is reasonable unless the tension steel strain is very close to
0.005 – the tension-controlled limit strain.

The design result is reflected in top and bottom reinforcement diagrams.

Rectangular Beam Flexural Design Algorithm

Given b, d = dt, d’, fc, fy and Mu find required As (and As’ if needed)

Step 1: Determine maximum moment without compression steel, using the tension-

controlled limit  and .

Step 2: If , design the section as singly-reinforced as follows:

(ACI 318-02/05 10.5.1)
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Step 3: If , design the section as doubly-reinforced as follows (still

assuming the tension-controlled limit and ):

Note, the tensile steel required to balance the compressive steel is

The design fails if fs’ < 0.  For practical reasons, the design also fails if . 

Tee Beam Flexural Design Algorithm

Given b, bw, hf , d = dt, fc, fy and Mu, find required As

Step a).  Assuming a <= hf and tension-controlled section with 
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If a > hf, go to Step b)

If , the design fails.

Step b). a > hf and tension-controlled section with 
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If , the design fails.

Beam Shear Reinforcement

The member shear reinforcement (stirrup spacing) is computed at each analysis
station along the member length. Stirrup size and number of legs are assumed uniform
along the length of a member as part of input.  For shear design, sections located
less than a distance d from the face of the support may be permitted to be designed
for Vu computed at a distance d from the support (ACI 318-02/05 11.1.3.1).  The
program offers an option to account for these conditions by automatically computing
beam support widths from Model Design Criteria under Concrete > Design Criteria.

The design result is reflected in a stirrup spacing diagram.

Beam Shear Design Algorithm

The shear design for concrete beam is the same as that of concrete column except
the axial force is always treated as zero.

11.3 Concrete Slab/Wall Design

General
The concrete slab/wall module designs concrete slabs or walls against enveloped
positive and negative Wood-Armer bending moments in slab local x and y directions. 
Axial force action is ignored.  The program produces contours of required areas of
steel which can be averaged with some commonsense to finish the design. 

Wood-Armer Moments

194
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Wood-Armer Formula [Ref 18, pp198] is the most popular approach to convert Mx,
My and Mxy to orthogonal plate design moments Mux and Muy

The procedure to obtain Mux and Muy for designing plate bottom reinforcement is as
follows:

· Mux = Mxx + |Mxy|
Muy = Myy + |Mxy|

· If Mux < 0 and Muy < 0
Mux = 0
Muy = 0

If Mux < 0 and Muy > 0
Mux = 0 
Muy = Myy + |Mxy * Mxy / Mxx|

If Mux > 0 and Muy < 0
Muy = 0
Mux = Mxx + |Mxy * Mxy / Myy|

· Mux >= 0
Muy >= 0

The procedure to obtain Mux and Muy for designing plate top reinforcement is as
follows:

· Mux = Mxx - |Mxy|
Muy = Myy - |Mxy|

· If Mux > 0 and Muy > 0
Mux = 0
Muy = 0

If Mux > 0 and Muy < 0
Mux = 0 
Muy = Myy - |Mxy * Mxy / Mxx|

If Mux < 0 and Muy > 0
Muy = 0
Mux = Mxx - |Mxy * Mxy / Myy|

· Mux <= 0
Muy <= 0

Wood-Armer Formula is a lower bound solution method which satisfies the following
conditions for a given external load: 

· The equilibrium conditions are satisfied at all points in the plate.
· The yield strength of the plate elements is not exceeded anywhere in the plate.
· The boundary conditions are complied with.

A lower bound solution is conservative in nature. 

Stress Singularity
The stresses and bending moments at the point of a concentrated load on the slab
are theoretically infinite.  This theoretically means that if we used all the steel in the
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world, we still did not have enough steel to resist the stress at that point.  This is of
course ridiculous.  The reason is of course because we prescribe an impossible
loading (“concentrated load”).  If we distribute the load over a small area (circle), the
stresses become finite.

In finite element analysis, the program will never give you a stress of infinite
magnitude.  Still, at a point of concentrated force such as a column acting on a flat
plate, stresses may have rather significant spikes.  According to Ugural [Ref 15,
pp116], the actual stress caused by a load on a very small area of radius rc can be

obtained by replacing the actual rc with an equivalent radius re.

 (rc > 0.5t)

 (rc <= 0.5t)

where t is the plate thickness.

By applying this method, we can use stresses at half of the slab thickness instead of
those at the concentrated loading point.  By excluding the finite elements (usually
finely meshed) near the concentrated loading points, we can provide practical and
reasonable design results.

Flexural Reinforcement

The plate top and bottom flexural reinforcement in local x and y direction is computed
at each nodal point as well as the center.  No minimum reinforcement is considered. 
The program only designs each plate with tension-controlled condition.  The procedure
is similar to that of concrete beams except no double reinforcement is considered.

197
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12 Steel Design

The steel design module performs steel design for beams and columns according
AISC 14th edition LRFD [Ref. 21].  Static analysis must be performed successfully
before steel design can be performed.  Sound engineering judgment is especially
important to interpret and apply the design results given by the program.

Due to the fact that the software provides step-by-step calculation procedures, the
technical treatment of the design process is kept minimal here.

12.1 Section Orientation

The orientations of section local X and Y axes of various AISC shapes are shown
below (Figure 20.1).

Figure 20.1

12.2 Member Internal Forces and Moments

1. Axial force P acts perpendicular to the section.  Moments Mx and My act about
section local X and Y axes respectively.  They have the following sign conventions.

Axial Force P: positive for compression; negative for tension
Moment Mx: Positive when section top most fiber is under compression.
Moment My: Positive when section rightmost fiber is under compression.
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Figure 20.2

2.  All moments are referenced about the geometric centroid of the gross section.

3.  Loads are the required strength computed by the code-specified factored load
combinations using either hands or analysis program such as FastFrame-3D.  It is

sway structure.  If desired, the program uses moment magnification procedure to
calculate the P-delta (P-δ) effect, which accounts for slenderness of columns in non-
sway structure or for slenderness along the lengths of columns in sway structure.

4.  Critical ratio (also called capacity ratio) is computed for each section based on the
magnified factored loads and the capacity of the section.  Critical ratio equal or less
than 1.0 means the design strength is greater than the required strength and the
section is adequate.  Critical ratio greater than 1.0 means the design strength is less
than the required strength and the section is inadequate.

12.3 Solution Algorithms

Because detailed step-by-step calculation procedure is available for each member on
Steel > Design Result, we will not list the algorithm here.
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14 Appendix

14.1 Unit Conversions

From English to Metric From Metric to English

1 ft => 0.3048 m 1 m => 3.28084 ft

1 in => 25.4 mm 1 mm => 0.03937 in

1 kip => 4.44822 kN 1 kN => 0.22481 kip

1 lb => 4.44822 N 1 N => 0.22481 lb

1 kip-ft => 1.35582 kN-m 1 kN-m => 0.73756 kip-ft

1 kip-in => 0.112985 kN-m 1 kN-m => 8.85073 kip-in

1 lb-ft => 1.35582 N-m 1 N-m => 0.73756  lb-ft

1 lb-in => 0.112985 N-m 1 N-m => 8.85073  lb-in

1 kip/in^2 => 0.00689476 kN/mm^2 1 kN/mm^2 => 145.04 kip/in^2

1 lb/in^2 => 0.00689476 N/mm^2 1 N/mm^2 => 145.04 lb/in^2

14.2 Designations, diameters and areas of standard bars

ASTM 615 (English) ASTM 615 96a (Metric)

Bar No Diameter (in) Area (in^2) Bar No Diameter (mm) Area (mm^2)

#3 0.375 0.11 #10 9.5 71

#4 0.500 0.20 #13 12.7 129

#5 0.625 0.31 #16 15.9 199

#6 0.750 0.44 #19 19.1 284

#7 0.875 0.60 #22 22.2 387

#8 1.000 0.79 #25 25.4 510
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ASTM 615 (English) ASTM 615 96a (Metric)

#9 1.128 1.00 #29 28.7 645

#10 1.270 1.27 #32 32.3 819

#11 1.410 1.56 #36 35.8 1006

#14 1.693 2.25 #43 43.0 1452

#18 2.257 4.00 #57 57.3 2581
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