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1 Introduction

ENERCALC 3D Verifications Manual

Last Revised:  9 February 2021

ENERCALC Inc.

Windows is a registered trademark of Microsoft Corporation.
ENERCALC 3D is a trademark of ENERCALC Inc.
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2 Static - Beam Element
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2.1 A-01 (Simple 3d-Truss - Model Type 3D Truss)

Objective

To verify the behavior of the 3d truss element.

Problem Description

A simple 3d truss is supported and loaded as shown below.  Nodal X, Y, and Z coordinates
are given in parenthesis.

Material properties: E = 200 KN/mm2, = 0.3

Section properties: A12 = 2e4 mm2, A13 = 3e4 mm2, A14 = 4e4 mm2, A15 = 3e4 mm2

All members Iz = 1e10 mm4, Iy = 1e10 mm4 , J = 1e10 mm4

Nodal forces applied at node 1: Px = 200 KN, Py = 600 KN, Pz = -800 KN

Finite Element Model

4 beam elements
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Model type: 3D Truss

Results

The displacements and support reactions are given in [Ref 1].

Units: displacement-mm; reaction-KN

ENERCALC 3D [Ref 1]

X Y Z X Y Z

Displacement @ N1 0.1779 2.722 -0.4865 0.1783 2.722 -0.4863

Reactions @ N2 -76.39 -152.78 -305.56 -76.4 -152.8 -305.6

Reactions @ N3 170.83 -113.88 -227.77 170.8 -113.8 -227.7

Reactions @ N4 -470.83 -156.94 627.77 -470.7 -156.9 627.8

Reactions @ N5 176.39 -176.39 705.56 176.3 -176.3 705.5

Comments

The results given by ENERCALC 3D are very close to the referenced values.

The deflection diagram is shown below for illustration purposes.
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Deflection Diagram

Reference

[1]. McGuire, Gallagher and Ziemian, “Matrix Structural Analysis” 2nd Edition, pp104, John
Wiley & Sons, Inc., 2000
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2.2 A-01 (Simple 3d-Truss - Model Type 3D Frame)

Objective

To verify the behavior of the 3d frame element with moment releases

Problem Description

A simple 3d truss is supported and loaded as shown below.  Nodal X, Y, and Z coordinates
are given in parenthesis.

Material properties: E = 200 KN/mm2, = 0.3

Section properties: A12 = 2e4 mm2, A13 = 3e4 mm2, A14 = 4e4 mm2, A15 = 3e4 mm2

All members Iz = 1e10 mm4, Iy = 1e10 mm4 , J = 1e10 mm4

Nodal forces applied at node 1: Px = 200 KN, Py = 600 KN, Pz = -800 KN

Finite Element Model

4 beam elements



Static - Beam Element 9

© 2026  ENERCALC, Inc.

Model type: 3D Frame & Shell

Moment Releases

The following table shows one way to apply moment releases.  Please note that we only apply
torsional moment release either (not both) end of a member.

Member Id Start oz End oz Start oy End oy Start ox End ox

1 Released Released Released Released Released
Not

Released

2 Released Released Released Released Released
Not

Released

3 Released Released Released Released Released
Not

Released

4 Released Released Released Released
Not

Released
Not

Released

Results

The displacements and support reactions are given in [Ref 1].

Units: displacement-mm; reaction-KN

ENERCALC 3D [Ref 1]

X Y Z X Y Z

Displacement @ N1 0.1779 2.722 -0.4865 0.1783 2.722 -0.4863

Reactions @ N2 -76.39 -152.78 -305.56 -76.4 -152.8 -305.6

Reactions @ N3 170.83 -113.88 -227.77 170.8 -113.8 -227.7

Reactions @ N4 -470.83 -156.94 627.77 -470.7 -156.9 627.8

Reactions @ N5 176.39 -176.39 705.56 176.3 -176.3 705.5

Comments

The results given by ENERCALC 3D are very close to the referenced values. The results in
this example using 3D Frame & Shell model with moment releases are identical to those in
the previous example using 3D Truss model.  It is generally easier and more efficient to use
3D Truss model type if your model contains only truss members as the program will
automatically suppress global OX, OY and OZ DOFs.  On the other hand, 3D Frame and
Shell model type (with proper moment releases) should be used if your model contains both
truss and frame members.  
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Reference

[1]. McGuire, Gallagher and Ziemian, “Matrix Structural Analysis” 2nd Edition, pp104, John
Wiley & Sons, Inc., 2000
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2.3 A-02 (Simple 3d-Beam)

Objective

To verify the behavior of the 3d beam element

Problem Description

A simple 3d beam of round section is fixed at one end and loaded at the tip of the other end as
shown below.  

Lengths: L1 = 120 in, L2 = 60 in

Material properties: E = 2.9e7 psi, G = 11.15e6, = 0.3

Section properties: Ix = Iy = 1017.88 in4, J = 2023.75 in4
, Az = 10 in2

Tip Force P = 1e4 lb

Finite Element Model

2 beam elements

Model type: 3D Frame & Shell (shear deformation ignored)

Results

The tip vertical displacement Dy at N3 may be calculated as [Ref 1]:
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Unit:  displacement - in

ENERCALC 3D Theoretical

Displacement Dy @ N3 -0.4098 -0.4098

Comments

The results given by ENERCALC 3D are identical to the theoretical values.

The moment, shear and deflection diagrams are shown below for illustration purposes.

Major Moment Diagram (Mz)

 
Torsion Diagram (Mx)
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Shear Diagram (Vy)

Deflection Diagram

Reference

[1]. Long & Bao, “Structural Mechanics”, pp146, People’s Educational Publishing House,
China, 1983.
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2.4 A-03 (Beam on Grade)

Objective

To verify the behavior of the line spring

Problem Description

A 300 in beam is supported on an elastic foundation and subjected to a point force of -40,000
lb at the middle as shown below [Ref 1]:

Material properties: E = 29,000 ksi, = 0.3

Section properties: Iz =125.8 in4, A = 1 in2

Elastic line spring constant: Ky = 1500 lb / in2

Finite Element Model

20 beam elements

Model type: 2D Frame

Results

The displacement and moment at the middle of the span are given in [Ref 1].

Units: displacement – in; moment – kip-in

@ middle of the span ENERCALC 3D [Ref 1]

Displacement Dy -0.239 -0.238

Moment Mz 544.44 547

Comments

1. The results given by ENERCALC 3D are very close to the referenced values.

2.  Line springs may be replaced by equivalent nodal springs or even truss elements with
appropriate section properties as indicated in [Ref 1].
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Reference

[1]. McGuire, Gallagher and Ziemian, “Matrix Structural Analysis” 2nd Edition, pp87, John
Wiley & Sons, Inc., 2000
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2.5 A-04 (P-delta Beam)

Objective

To verify the 2nd-order behavior of beam element

Problem Description
A 12 ft simply supported beam is subjected to a pair of compressive forces of P = -100 kips
at the ends and a transverse point force of Q = -6 kips at the middle as shown below [Ref 1].

Material properties: E = 30e6 psi, = 0.3

Section: 4 x 4 in (Iz = 21.3333 in4, A = 16 in2)

Finite Element Model

4 beam elements

Model type: 2D Frame (First order and P-Delta)

Results

The displacement and moment at the middle of the beam may be calculated as follows [Ref
1]:

First order:  kip-ft;  in

Second order:  rad (= 51.57o)  kip-ft;

 in
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Units: displacement – in; moment – kip-in

@ middle of the span ENERCALC 3D [Ref 1]

First-order Displacement Dy -0.5832 -0.583

First-order Moment Mz 18 18

Second-order Displacement Dy -0.8643 -0.864

Second-order Moment Mz 25.203 25.2

Comments

1. The results given by ENERCALC 3D are very close to the referenced values.

2. In order to capture P- behavior that is associated with member curvature, the beam must
be split into multiple segments.  In this example, we used 4 segments and produced
satisfactory results.  On the other hand, the splitting is not needed to capture behavior
that is associated with the lateral translation of the frame members.

Reference

[1]. Leet & Bernal, “Reinforced Concrete Design” 3rd Edition, pp294, McGraw-Hill, 1997
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2.6 A-05 (Rotational Spring)

Objective

To verify the behavior of the rotational spring

Problem Description

A 10-inch long cantilever beam is subjected to a triangular linear load of q = 2 lb/in.

Material properties: E = 2.9e7 psi, = 0.3

Section properties: Ix = 1000 in4, Az = 10 in2

Boundary condition: rotational spring constant Koz = 1e4 lb-in/rad, Dx and Dy fixed.

Finite Element Model

1 beam element
Assign large spring constants to Kx, Ky to represent fixed DOFs Dx, Dy 
Model type: 2D Frame

Results

The rotational displacement Doz at N1 and vertical displacement Dy at N2 may be calculated
as:

@N1:  rad

@N2,  in

Units: displacement – in; rotation - rad

ENERCALC 3D Theoretical

Rotation Doz @ N1 -3.333e-3 -3.333e-3

Displacement Dy @ N2 -3.333e-2 -3.333e-2
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Comments

The results given by ENERCALC 3D are identical to the theoretical values.

The displacements due to beam strains are negligible.
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2.7 A-06 (Non-Prismatic Continuous Beam)

Objective

To verify the behavior of a non-prismatic beam

Problem Description

A 3-span non-prismatic continuous beam is fixed at the right end as shown below [Ref 1].

Material properties: E = 1.99948e11 N/m2, = 0.3

Section properties: width b = 0.1 m, heights as shown (unit: meter)

Finite Element Model

3 beam elements, then use Create > Templates > Non-Prismatic Members

Model type: 2D Frame (do not consider shear deformation)

Results

The moments at supports given by ENERCALC 3D are compared with those given in [Ref 1].

Unit: moment – KN-m

ENERCALC 3D [Ref 1]

Mz @ B Mz @ C Mz @ D Mz @ B Mz @ C Mz @ D

-4.39 -4.24 -9.13 -4.28 -4.21 -9.15

Comments

The results given by ENERCALC 3D are close to the referenced values.
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In ENERCALC 3D, the non-prismatic beam is approximated by splitting an existing beam into
multiple beams (segments) to which different section properties are automatically assigned. 
The steps to create the model in this problem are as follows:

1.  Create 3 (prismatic) beams: AB - 4 m, BC – 6m, CD – 8 m

2.  Define and assign uniform and point loads on beams

3.  Assign supports to A, B, C and D

4.  Define and assign section to beam CD

5.  Define and assign material to beams AB, BC, and CD.

6. Select the beam AB.  Run the command Create > Templates > Non-Prismatic Members. 
Enter the input for “Generate Nonprismatic Members” as follows.  The distance list specifies
how many beam segments to be used to approximate the non-prismatic beam.  In our input,
we use one segment for the left 2 m and 10 segments for the right 2 m haunch.  More
segments could be used to achieve even more accurate result.  It should be pointed out that
appropriate section properties are assigned to the segmented beams.
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7. Select the beam BC.  Run the command Create > Templates > Non-Prismatic Members. 
Enter the input for “Generate Nonprismatic Members” as follows.  

Reference

[1]. Lin, Liu, Jiang “Structural Statics Calculation Manual”, pp 232, Building Industry Publishing
House of China, 1993
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2.8 A-07 (2D Steel Frame)

Objective

To verify the behavior of the beam element in a large 2D steel frame

Problem Description

A 5-span, 12-story 2D steel frame is subjected to static lateral and vertical loads as shown
below.  All beams are W24’s and all columns are W14’s.  The lateral loads are in kips and
vertical linear loads are in kip/ft (self weight included).

Material properties: E = 29000 ksi, = 0.3, density = 483.84 lb/ft3
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Interior columns:  
Floor 1 – 4: W14x120
Floor 5 – 8: W14x90
Floor 9 – 12: W14x68

Exterior columns:  
Floor 1 – 4: W14x90
Floor 5 – 8: W14x68
Floor 9 – 12: W14x48

Beams:  
Floor 1 – 4: W24x131
Floor 5 – 8: W24x104
Floor 9 – 12: W24x84

Units: Iz, Iy and J – in4, A, Ay and Az – in2

Section Iz Iy J A Ay Az

W14X120 1380 495 9.37 35.3 8.555 23.03

W14X90 999 362 4.06 26.5 6.16 17.1583

W14X68 722 121 3.01 20 5.81 12

W14X48 484 51.4 1.45 14.1 4.692 7.96308

W24X131 4020 340 9.5 38.5 14.8225 20.64

W24X104 3100 259 4.72 30.6 12.05 16

W24X84 2370 94.4 3.7 24.7 11.327 11.5757

Finite Element Model

132 beam elements

Model type: 2D Frame (shear deformation included)
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Results

The displacements and support reactions compared with another program, Frame Analysis &
Design (STRAAD) [Ref 1].

Units: displacement-in; reaction force-kips, reaction moment - kip-ft

ENERCALC 3D
Frame Analysis & Design

(STRAAD)

First order Second order First order Second order

Dx @ node 73 5.981 7.151 5.9762 7.1347

Rx @ node 3 -36.773 -34.825 -36.7694 -34.8356

Ry @ node 3 2456.514 2457.846 2456.4503 2457.9036

Roz @ node 3 303.299 377.605 303.2664 377.6628

Comments

The results given by ENERCALC 3D are very close to the referenced values.

Reference

[1]. “Frame Analysis & Design”, Digital Canal Corporation, Dubuque, Iowa, USA
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2.9 A-08 (A Simple Suspension Bridge)

Objective

To verify the behavior of the beam element with moment releases

Problem Description

A suspension bridge consists of a 60m long beam fixed on both ends and two 25m long truss
members which suspend the beam as shown below.

Lengths: shown in parentheses

Material properties: E = 200 kN/mm2, = 0.3

Beam Section: Ix = Iy = J= 0.1 m4, Az = 1.0955 m2

Truss Section: Ix = Iy = J= 2e-6 m4, Az = 0.005 m2

Uniform load on beam: -10 kN/m

Finite Element Model

5 beam elements (moment release at truss ends connecting the beam)

Model type: 2D Frame (shear deformation ignored)
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Results

The displacements and internal forces given by ENERCALC 3D are compared with the
reference [Ref 1].

ENERCALC 3D Ref 1

Displacement Dy @ N2 (m) -3.970e-003 79400/(EI) = -3.97e-3

Rotation Doz @ N2 (rad) -2.540e-004 5080/(EI) = -2.540e-004

Maximum (+) Moment in Beam
(kN-m)

674.755 675

Maximum (-) Moment in Beam
(kN-m)

-682.840 682

Shear at Beam Ends (kN) 42.88 42.8

Shear at Beam Third Point (kN) 100 100

Maximum Axial Force in Trusses
(kN)

95.2 95.2

Comments

The results given by ENERCALC 3D are very close to the referenced values.  Since the
model contains both truss and beam members, we used 2D Frame model type and applied
moment releases to beam elements for truss members.

The reference gives the relationship of section properties as (EA)truss = (EI)beam/(20m). 

The properties used in the problem were selected based on this assumption.  The beam
section area is much greater than the truss section area.  Therefore, the axial deformation in
the beam is practically ignored.

The moment, shear, and axial force diagrams are shown below for illustration purposes.
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Major Moment Diagram (Mz)

Shear Diagram (Vy)
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Axial Force Diagram (Vx)

Reference

[1]. Long & Bao, “Structural Mechanics”, pp279, People’s Educational Publishing House,
China, 1983.
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2.10 A-09 (2D Truss with Tension Only Member)

Objective

To verify the behavior of the tension only element

Problem Description

A member connecting node 2 and node 4 is tension only in the 2D truss shown below.

Lengths: shown in parentheses in meters

Material properties: E = 205 kN/mm2, = 0.3

All Sections: Az = 1500 mm2

Loads: as shown

Finite Element Model

8 beam elements, with one member connecting N2-N4 being tension only

Model type: 2D Truss
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Results

The displacements and internal forces given by ENERCALC 3D are compared with the
reference [Ref 1].

ENERCALC 3D Ref 1

Displacement Dx @ N3 (mm) 3.469 3.46

Displacement Dy @ N3 (mm) 19.12 19.13

Axial Force in Member connecting
N1-N5 (KN)

181.67 181.7

Comments

The results given by ENERCALC 3D are very close to the referenced values.  Since the
member connecting N2-N4 is tension only but subjected to compression force, its stiffness is

ignored in the 2nd iteration during the solution of this nonlinear model.  We can also set the
member to be inactive to achieve the same effect. The difference between using
tension/compression only members and inactive members is that the former requires non-
linear solution while the latter does not (unless other nonlinearities such as non-linear springs
or P-Delta analysis exist).

Reference

[1]. William M.C. McKenzie, “Examples in Structural Analysis”, pp 125, Taylor & Francis,
2006.
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2.11 A-10 (3D Frame with Rigid Diaphragms)

Objective

To verify the behavior of the rigid diaphragms in 3D Frame

Problem Description

A two-story building is subjected two nodal loads in global X direction at the two story level
nodes.  The X-bay and Z-bay distances are both 18 ft.  The story height is 12 ft.

Material properties: E = 3155.92 ksi, = 0.15

All Sections: rectangular 12x12 in.  

Iyy = Izz = 1728 in4; J = 2920.32 in4 ;  

Az = 144 in2; Ax = Ay = 120 in2

Loads: two 20 kips nodal loads in global X direction as shown.

Finite Element Model

Model type: 3D Frame, with rigid diaphragms defined at two story levels.

Diaphragm stiffness factor: default value (=10000)
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Results

The displacements and support reactions given by ENERCALC 3D with and without rigid
diaphragm actions are shown below.

Displacements:

Node Dx (in) Dy (in) Dz (in) Dox Doy Doz

Diaphragm actions considered

5 1.01E+00 4.95E-03 6.70E-01 1.01E-03 6.20E-03 -2.01E-03

6 1.01E+00 -4.95E-03 -6.70E-01 -1.01E-03 6.20E-03 -2.01E-03

11 2.35E+00 4.95E-03 6.70E-01 1.01E-03 6.20E-03 -4.03E-03

12 2.35E+00 -4.95E-03 -6.70E-01 -1.01E-03 6.20E-03 -4.03E-03

Diaphragm actions ignored

5 8.36E-01 4.17E-03 5.03E-01 8.31E-04 5.99E-03 -1.81E-03

6 8.36E-01 -4.17E-03 -5.03E-01 -8.31E-04 5.97E-03 -1.81E-03

11 2.53E+00 5.72E-03 5.03E-01 8.31E-04 5.99E-03 -4.23E-03

12 2.52E+00 -5.72E-03 -5.03E-01 -8.31E-04 5.97E-03 -4.24E-03

Reactions:

Node Rx (kip) Ry (kip) Rz (kip) Rox Roy Roz

Diaphragm actions considered

1 -5.42E+00 -1.15E+01 -4.58E+00 -3.37E+01 -7.63E+00 4.30E+01

2 -5.42E+00 1.15E+01 4.58E+00 3.37E+01 -7.63E+00 4.30E+01

7 -1.46E+01 -1.15E+01 -4.58E+00 -3.37E+01 -7.63E+00 1.10E+02

8 -1.46E+01 1.15E+01 4.58E+00 3.37E+01 -7.63E+00 1.10E+02

Diaphragm actions ignored

1 -3.96E+00 -9.55E+00 -3.12E+00 -2.34E+01 -7.55E+00 3.26E+01

2 -3.96E+00 9.55E+00 3.12E+00 2.34E+01 -7.52E+00 3.26E+01

7 -1.61E+01 -1.34E+01 -3.12E+00 -2.34E+01 -7.55E+00 1.21E+02

8 -1.60E+01 1.34E+01 3.12E+00 2.34E+01 -7.52E+00 1.21E+02
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Comments

The diaphragm actions are noticeable in this example. Although the model is subjected to
unsymmetrical loads, the nodal rotations about global Y axis are the same for nodes on the
diaphragms.  This means that the diaphragm stiffness factor, which happens to be the default
value 10000, is appropriate for this example.  The program is also capable of handle slanting
diaphragms.  For example, you may rotate the model about Z axis by (-30) degrees.  Adjust
the local angles for horizontal members as well as the nodal forces accordingly.  The Dx for
the Node 5, 6, 11 and 12 given by the program are 8.769e-001, 8.720e-001, 2.037e+000 and
2.032e+000 in.  The correctness can be verified as the following:

Dx @ node 5: 1.01cos30 + 0.00495sin30 = 0.877
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2.12 A-11 (2D Frame with Support Settlements)

Objective

To verify the behavior of the forced translational and rotational displacements

Problem Description
A frame [Ref 1] is clamped at point A and rolled at points B and C as shown below.  The
relative flexural stiffness of each element is shown in a circle. No external load is applied to
the frame, but the frame is subjected to settlement of fixed support A.  Assume that the
vertical, horizontal, and angular settlements are a = 2 cm, b = 1 cm, and   = 0.01 rad,
respectively.

Finite Element Model

Model type: 2D Frame, without considering frame shear deformation.  

The reference does not specify material and section specifically, so we will use steel and
rectangular sections  (100 mm x 100 mm for vertical members and 200 mm x 100 mm for
horizontal member, which satisfy the relative flexural stiffness of members).

E = 200 kN/mm2, I = 8.33333e+006 mm4
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Results

The support reactions given by ENERCALC 3D are shown below.

ENERCALC 3D Ref 1

Reaction Moz @ A 7.57 kN-m

C1 * EI = 4.5418 * 10-3 * (1/m) * 200

kN/mm2 * 8.333 * 106 mm4

= 7.5667 kN-m

Reaction Ry @ B -0.19 kN

C2 * EI = -1.119 * 10-4 * m2 * 200

kN/mm2 * 8.333 * 106 mm4

= -0.1865 kN

Reaction Rx @ C -1.18 kN

C3 * EI = -7.076 * 10-4 * m2 * 200

kN/mm2 * 8.333 * 106 mm4

= -1.179 kN

 Note: From [Ref 1]

C1 = 4.5418 * 10-3 (unit: 1/m)

C2 = -1.119 * 10-4 (unit: 1/m2)

C3 = -7.076 * 10-4 (unit: 1/m2)

Comments

The results given by ENERCALC 3D are very close to the referenced values.

Reference

[1]. Igor A. Karnovsky, Olga Lebed, “Advanced Methods of Structural Analysis”, pp 248,
Springer Science+Business Media, LLC, 2010.
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2.13 A-12 (2D Frame with Rigid Offsets)

Objective

To verify the behavior of the rigid offsets

Problem Description

A portal frame [Ref 1] is clamped at point A and D as shown below.  The columns are of
rectangular size 200mm x 800mm.  The beam is of rectangular size 200mm x 1000 mm. 
The beam is subjected to an uniform load 10 kN/m.

Finite Element Model

Model type: 2D Frame, without considering frame shear deformation. 

The reference does not specify material specifically, so we will use concrete with fc = 3ksi.
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Results

The following are the moment diagrams for modeling the structure with rigid offsets and
without rigid offsets.

ENERCALC 3D

With Rigid Offsets

Ref 1

Beam Max Negative Moment 11.09 kN-m 11.23 kN-m

Beam Max Positive Moment 16.91 kN-m 16.9 kN-m

Moment Reactions at Supports 5.39 kN-m 5.43 kN-m

 
Comments

The results given by ENERCALC 3D are very close to the referenced values.  The reference
computes moment diagram manually using displacement method.  There are noticeable
differences between results with rigid offsets and those without.

Reference

[1]. Long & Bao, “Structural Mechanics”, pp296, People’s Educational Publishing House,
China, 1983.
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2.14 A-13 (2D Truss with an Inclined Roller)

Objective

To verify the behavior of inclined roller using multi-DOF constraint

Problem Description

A truss [Ref 1] is supported by a pinned support at point c and a roller (inclined at 30 degrees
from horizontal line) at point b as shown below.  

Sections: ab = 20,000 mm 2̂, ac = 15,000 mm 2̂, bc = 18,000 mm 2̂

Material: E = 200 MPa

When creating the inclined roller, we can set any point along the roller angle line as the
reference point.  For example, if the coordinate at point b is (10.928, 0, 0), then we can set the
reference point as (10.928 + 10 * cos30, 10 * sin30, 0) = (19.588254, 5, 0).  
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This effectively creates a multi-DOF constraint as the following:
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Results

The following are the displacements and support reactions given by ENERCALC 3D and [Ref
1].  The reaction resultant @ b is calculated by hand as following:

kN (pointing to bottom-right). kN

kN

ENERCALC 3D Ref 1

Displacement Dx @ a 0.9282 mm 0.928 mm

Displacement Dy @ a 1.142 mm 1.143 mm

sqrt(Dx * Dx + Dy * Dy) @ b 0.09416 mm 0.094 mm

Reaction Rx @ c -419.70 kN -419.7 kN (by hand)

Reaction Ry @ c -257.83 kN -257.83 kN (by hand)

Reaction Rx @ b 36.70 kN (constrained force) 36.70 kN (by hand)

Reaction Ry @ b -63.57 kN (constrained force) -63.57 kN (by hand)

 
Comments

The displacement results given by ENERCALC 3D are very close to the referenced values. 
The support reactions are not given in Ref 1 but can be easily calculated by hand, which
match exactly with those given by ENERCALC 3D.

Reference

[1]. W. McGuire & R.H. Gallagher & R.D. Ziemian, “Matrix Structural Analysis” pp 390, 2nd

ed., John Wiley & Sons, Inc., 2000
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2.15 A-14 (2D Truss with Thermal Load)

Objective

To verify the behavior of thermal load

Problem Description

In the truss [Ref 1] below, all bars are cooled by 20 degrees Celsius.
  
Material: E = 200 MPa, thermal coefficient = 1.2e-5 mm/mm per degree Celsius
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Results

The following are the results given by ENERCALC 3D and [Ref 1].  

ENERCALC 3D Ref 1

Displacement Dx @ a -4.044e-01 mm -0.4045 mm

Displacement Dy @ a -6.995e-02 mm -0.0698 mm

Reaction Rx @ b 0 kN 0 kN

Reaction Ry @ b -274.01 kN -274 kN

Reaction Rx @ c -173.71 kN -173.8 kN

Reaction Ry @ c 100.29 kN 100.2 kN

Reaction Rx @ d 173.71 kN 173.8 kN

Reaction Ry @ d 173.71 kN 173.8 kN

 
Comments

The displacement results given by ENERCALC 3D are very close to the referenced values.  

Reference

[1]. W. McGuire & R.H. Gallagher & R.D. Ziemian, “Matrix Structural Analysis” pp 127, 2nd

ed., John Wiley & Sons, Inc., 2000
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2.16 A-15 (Multi-DOF Constraints - Cyclically Symmetric Frame)

Objective

To verify the multi-DOF constraints to enforce cyclic symmetry

Problem Description

In the frame [Ref 1] below, each of the 16 members is 10 inch long.
  
Material: E = 1.2e7 psi, = 0.15.

Sections: A = 1.0 in2, Iyy = Izz = 8.33e-2 in4 

Four cyclic loads: P = 10 lb 

Boundary condition: Fixed at the center node (N13)
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Finite Element Model

To take advantage of the cyclic symmetry, we are going to model only one quarter of the
structure (4-element model) with the following multi-DOF constraints at node 40 and node 30.

X40 = -Y30

Y40 = X30

Oz40 = Oz30

We can use Geometry->Multi-DOF Constraints->Generic Constraints menu to define these
three displacement constraints.  Alternatively, we can directly enter the constraints in a
spreadsheet from Input Data->Multi-DOF Constraints menu.
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Results

To illustrate, the following shows the identical Mz moment diagrams for both 16-element
model and 4-element model.

Reference

[1]. ADINA Verification Manual, ADINA R & D Inc., Example A.40, June 2001
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2.17 A-16 (Coupled Spring)

Objective

To verify the behavior of coupled spring which is useful in modeling bridge foundations.

Problem Description

In the 10 meter column [Ref 1] below, the top is subjected to the loads: Fx = 100.00 (kN), Fy =
200.00 (kN), Fz = -3000.00 (kN), Mx = 400.00 (kN-m), My = 500.00 (kN-m) and Mz = 600.00
(kN-m).  

Material: E = 3.25e+07 kN/ m2, = 0.20.

Sections: Izz = 0.0104 m4 , Iyy = 0.0417 m4 , J = 0.0286 m4 , A= 0.5 m2 , Ay = 0.4167 m2 ,

Az = 0.4167 m2
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The bottom of the column is supported by a coupled spring with the following stiffness matrix
terms (see “Calculation of Coupled Spring Stiffness Terms” below)
 

Calculation of Coupled Spring Stiffness Terms

The stiffness matrix terms of the coupled spring used in this example are calculated based on
the following simplified bridge piers below.  On the left is the full pier (column + foundation)
model A while on the right is the foundation-only model B.  In order to compute the stiffness
matrix of the coupled spring, 6 loads in separate load cases (1000 kN for Px, Py and Pz; 1000
kN-m for Mx, My and Mz) are applied at the bottom of the column in Model B. We first solve
the model B to obtain displacement matrix (displacements for each of these load cases).
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We then invert the displacement matrix to obtain the stiffness matrix.  Note the stiffness
matrix is multiplied by 1000 so the stiffness terms are in the right units as shown below. 
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Results

The nodal displacements in the coupled spring model are very close to those obtained from
the full model A.  This illustrates that a coupled spring can be used to simplify the modeling of
a bridge sub-structures effectively.

Model with a Coupled Spring Full Model A

X Y Z X Y Z

Displacement
@ Top (m)

3.961e-02 1.706e-01 -3.667e-02 3.961e-02 1.706e-01 -3.668e-02

Rotation
@ Top (rad)

-1.971e-02 6.763e-03 1.629e-02 -1.971e-02 6.763e-03 1.629e-02

Displacement
@ Bottom (m)

2.551e-03 1.261e-02 -3.482e-02 2.554e-03 1.261e-02 -3.483e-02

Rotation
@ Bottom

(rad)
-1.957e-03 -6.161e-04 7.998e-04 -1.957e-03 -6.159e-04 7.997e-04
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3 Static - Shell Element (Bending)
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3.1 B-01 (Plate Patch Test)

Objective

To verify the plate (MITC4 thick plate formulation) passes the patch test

Problem Description

A plate of size 0.12 x 0.24 in is subjected to forced displacements at the four corners as
shown below.  The boundary conditions are: 

w = 1.0e-3(x2 + xy + y2) / 2

Material properties: E = 1.0e6 psi, = 0.25

Geometry:  nodal coordinates are shown in the parenthesis below, thickness t = 0.001 in

Finite Element Model

5 shell elements

Model type: 2D Plate Bending (MITC4 thick plate formulation)
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Forced displacements on boundary nodes:

Units: displacement – in; rotation - rad

Boundary Nodes Displacement Dz Rotation Dox Rotation Doy

1 0 0 0

2 2.88e-5 1.20e-4 -2.40e-4

3 7.20e-6 1.20e-4 -6.00e-5

4 5.04e-5 2.40e-4 -3.00e-4

Results

The displacements of internal nodes can be calculated based on the boundary conditions. 
The generalized strains and stresses may be calculated as follows:

;

; 

;

The constant stresses are also given by [Ref 1].

Units: displacement – in; rotation - rad

Nodes
ENERCALC 3D Theoretical

Dz Dox Doy Dz Dox Doy

5 1.40e-6 4.00e-5 -5.00e-5 1.40e-6 4.00e-5 -5.00e-5

6 1.935e-5 1.20e-4 -1.95e-4 1.935e-5 1.20e-4 -1.95e-4

7 2.24e-5 1.60e-4 -2.00e-4 2.24e-5 1.60e-4 -2.00e-4

8 9.60e-6 1.20e-4 -1.20e-4 9.60e-6 1.20e-4 -1.20e-4
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Units: moment – lb-in/in

ENERCALC 3D [Ref 1]

Mxx Myy Mxy Mxx Myy Mxy

1.11e-7 1.11e-7 3.33e-8 1.11e-7 1.11e-7 3.33e-8

Comments

The results given by ENERCALC 3D are identical to the theoretical and referenced values.

A patch test consists of creating a small “patch” of elements and then imposing an assumed
displacement field at the boundary nodes.  The assumed displacement field is chosen such
that it causes a constant stress in the mesh.  To pass the patch test, computed
displacements at the interior nodes must be consistent with the assumed displacement field
and the computed stresses must be constant.  Patch tests are important because they
ensure solution convergence—so that increasing mesh fineness results in more accurate
results.

The MITC4 plate formulation passes the patch test.  The Kirchhoff plate formulation passes
the patch test if the elements are rectangular.  The Kirchhoff plate formulation is not
applicable here.

Reference

[1]. MacNeal & Harder, “A Proposed Standard Set of Problems to Test Finite Element
Accuracy”, Finite Elements in Analysis and Design, 1 (1985) 3-20

[2]. Cook, Malkus, Plesha, Witt, “Concept and Applications of Finite Element Analysis” 4th
Edition, pp238, John Wiley & Sons, Inc., 2002
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3.2 B-02 (Parapet)

Objective

To verify the plate (Kirchhoff thin plate formulation) element under constant twist.

Problem Description

A plate of size 240 x 240 in is subjected to a transverse point load of -10,000 lb at a corner D
as shown below.  The boundary lines AB and AC are simply supported. 

Material properties: E = 2.9e+007 psi, = 0.30

Thickness t = 10 in

Finite Element Model

100 shell elements

Model type: 2D Plate Bending (Kirchhoff thin plate formulation)

Results

The displacements, internal forces, and moments may be calculated as follows [Ref 1]:

; 

 lb-in/in

 in
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Units: displacement – in; moment – lb-in/in

ENERCALC 3D [Ref 1]

Moment Mxy
Displacement Dz @

point D
Moment Mxy

Displacement Dz @
point D

5,000 -0.1549 5,000 -0.1549

Comments

The results given by ENERCALC 3D are identical to the theoretical values.

This is an interesting problem which has practical applications (such as parapet at the corner
of a building).  It shows that a plate structure may have pure twist Mxy (Mxx = Myy = 0). 
Generally, for a homogeneous material such as steel, the strength should be checked based
on principal stresses.  For a non-homogeneous material such as concrete, the strength
should be checked based on principal moments (not just Mxx and Myy). In this example,
reinforcement should be placed as shown below.  The solid lines represent the top
reinforcement while the dashed lines do the bottom reinforcement.

In practical applications for concrete slabs, reinforcement placed based on principal moments
will be difficult.  Alternative methods are available.  One of these methods is the so-called
Wood-Armer method [Ref 2].  It takes into account Mxy as well as Mxx and Myy for calculating
top and bottom reinforcement in two orthogonal directions x and y.

Reference

[1]. Z.L Xu, “Elastic Mechanics” 3rd Ed., pp58, High Education Publishing House, China 1994

ISBN 7-04-002893-X/TB.159

[2]. Park & Gamble “Reinforced Concrete Slab”, pp202, John Wiley & Sons, Inc., 1980
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3.3 B-03 (Morley Skew Plate)

Objective

To verify the behavior of the MTC4 thick plate bending element in a skew shape

Problem Description

A skewed, simply supported plate is loaded with a uniform pressure load of 1 psi.

Material properties: E = 1e5 psi, = 0.3

Geometric properties: L = 100 in, h = 1 in

Finite Element Model

16, 64, 256, 1024 shell elements

Model type: 2D Plate Bending (MITC4 thick plate formulation)

Results

The displacement at the plate center (C) is given by [Ref 1].

Unit: displacement - in

Displacement Dz ENERCALC 3D [Ref 1]

4 x 4 mesh 3.9182 3.9182

8 x 8 mesh 3.8991 3.8991

16 x 16 mesh 4.1875 4.1875

32 x 32 mesh 4.4098 4.4098
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Comments

The displacements given by ENERCALC 3D are identical to the referenced values.  The
correct theoretical displacement is given as 4.640 in.

Reference

[1]. Sa, Jorge, Valente and Areias “Development of shear locking-free shell elements using an
enhanced assumed strain formulation”, International Journal of Numerical Methods in
Engineering, 2002; 53: 1721-1750



ENERCALC 3D Verifications Manual60

© 2026  ENERCALC, Inc.

3.4 B-04 (Fixed Rectangle)

Objective

To verify the behavior of the MTC4 thick plate and the Kirchhoff thin plate bending elements

Problem Description

A 3.2 x 2 in rectangular plate is fixed on all edges and subjected to a uniform pressure of q = -
1e-4 psi as shown below.

Material properties: E = 1.7472e7 psi, = 0.3

Thickness: t = 1e-4 in

Finite Element Model

100 shell elements

Model type: 2D Plate Bending (MITC4 thick plate and Kirchhoff thin plate)

Results

The displacements and stresses are compared with those produced by another program,
ADINA.  Theoretical results are calculated as follows [Ref 1]:

Displacement @ center: in

Stress @ center of long edge:  psi
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Stress @ center:  psi

Units: displacement – in; rotation – rad; stress - psi

ENERCALC 3D

ADINA Theoretical
MITC4
(thick)

Kirchhoff
(thin)

Displacement Dz @ center -2.274 -2.342 -2.274 2.299

Max Rotation Dox 3.653 3.608 3.653 -

Max Rotation Doy 2.502 2.373 2.502 -

Stress Sxx @ center of short edge 7507 12927 7507 -

Stress Sxx @ center -4880 -4763 -4880 -

Stress Syy @ center of long edge 13478 18743 13478 18720

Stress Syy @ center -9143 -9483 -9143 -9144

Max Stress Sxy 2556 2459 2556 -

Comments

The results given by ENERCALC 3D using the MITC4 are identical to those given by another
reputable finite element program, ADINA.  The results also compare well with the theoretical
results based on the thin plate theory.  The stress prediction of the MITC4 thick plate at the
boundary seems to be less accurate than that of the Kirchhoff thin plate.

The following illustrates displacement and stress contours (not smoothed) based on the
MITC4 thick plate.
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Dz Displacement Contour

Dox Displacement Contour
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Doy Displacement Contour

Sxx Stress Contour
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Syy Stress Contour

Sxy Stress Contour
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Reference

[1]. Roark & Yong, “Formulas for Stress and Strain” 5th Ed, pp392, McGraw-Hill Inc., 1975
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4 Static - Shell Element (Membrane)
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4.1 C-01 (Membrane Patch Test)

Objective

To verify membrane formulations pass the patch test

Problem Description

A plate of size 0.24 x 0.12 in is subjected to forced displacements at the four corners as

shown below.  The boundary conditions are: u = 10-3(x + y / 2); v = 10-3(y + x / 2)

Material properties: E = 1.0e6 psi, = 0.25

Geometry:  nodal coordinates are shown in the parenthesis below, thickness t = 0.001 in

Finite Element Model

5 shell elements

Model type: 2D Plane Stress

Forced displacements on boundary nodes:

Unit: displacement - in

Boundary Nodes Displacement Dx Displacement Dy

1 0 0

2 2.4e-4 1.2e-4

3 6.0e-5 1.2e-4

4 3.0e-4 2.4e-4
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Results

The displacements of internal nodes can be calculated based on the boundary conditions. 

The constant strains may be calculated as follows: ; ;

Constant stresses may be calculated accordingly and are given in [Ref 1].

Unit: displacement - in

Internal Node

ENERCALC 3D Theoretical

Displacement
Dx

Displacement
Dy

Displacement
Dx

Displacement Dy

5 5.00e-5 4.00e-5 5.00e-5 4.00e-5

6 1.95e-4 1.20e-4 1.95e-4 1.20e-4

7 2.00e-4 1.60e-4 2.00e-4 1.60e-4

8 1.20e-4 1.20e-4 1.20e-4 1.20e-4

Unit: stress - psi

ENERCALC 3D [Ref 1]

Stress Sxx Stress Syy Stress Sxy Stress Sxx Stress Syy Stress Sxy

1333 1333 400 1333 1333 400

Comments

The results given by ENERCALC 3D are identical to the theoretical and referenced values.

A patch test consists of creating a small “patch” of elements and then imposing an assumed
displacement field at the boundary nodes.  The assumed displacement field is chosen such
that it causes a constant stress in the mesh.  To pass the patch test, computed
displacements at the interior nodes must be consistent with the assumed displacement field
and the computed stresses must be constant.  Patch tests are important because they
ensure solution convergence—so that increasing mesh fineness results in more accurate
results.

Both compatible and incompatible membrane formulations pass the patch test.
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Reference

[1]. MacNeal & Harder, “A Proposed Standard Set of Problems to Test Finite Element
Accuracy”, Finite Elements in Analysis and Design, 1 (1985) 3-20

[2]. Cook, Malkus, Plesha, Witt, “Concept and Applications of Finite Element Analysis” 4th
Edition, pp238, John Wiley & Sons, Inc., 2002
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4.2 C-02 (Slender Cantilever)

Objective

To verify membrane formulation of the shell element using regular and irregular element
shapes

Problem Description

The slender cantilever beam shown below is modeled with a). regular shape elements; b).
trapezoidal shape elements; c). parallelogram shape elements.  Trapezoidal and

parallelogram shapes take 450 angle.  All elements have equal volume.

Material properties: E = 1.0e7 psi, = 0.3

Section properties: Length = 60 in, height = 0.2 in, thickness t = 0.1 in

Loads: a). unit axial force; b). unit in-plane shear

Finite Element Model

6 shell elements

Model type: 2D Plane Stress
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Results

The tip displacements are given by [Ref 1].  Theoretical stresses at the root are also given
here for comparison.

Units: displacement – in; stress - psi

Element Load type

ENERCALC 3D [Ref 1]

Displacements
@ tip

Stresses
@ root

Displacements
@ tip

Stresses
@ root

Compatible
Regular

Axial force 3.0e-5 -50 3.0e-5 -50

In-plane
shear

-0.01009 -846.2 0.1081 -9000

Incompatible
Regular

Axial force 3.0e-5 -50 3.0e-5 -50

In-plane
shear

-0.1073 -8250.0 0.1081 -9000

Incompatible
Trapezoidal

Axial force 3.0e-5 -50 3.0e-5 -50

In-plane
shear

-0.02385 -7071.6 0.1081 -9000

Incompatible
Parallelogram

Axial force 3.0e-5 -50 3.0e-5 -50

In-plane
shear

-0.08608 -6510.1 0.1081 -9000

Comments

The results given by ENERCALC 3D are mixed in comparison with the referenced values.

All meshes behave correctly in the axial force loading.  For in-plane shear, the regular mesh
using incompatible membrane formulation behaves the best.  The behavior of the regular
mesh using compatible formulation and the irregular mesh using compatible or incompatible
formulation can be improved by using more elements.  In practice, a rectangular element
shape with small aspect ratio should be used whenever possible.

Reference

[1]. MacNeal & Harder, “A Proposed Standard Set of Problems to Test Finite Element
Accuracy”, Finite Elements in Analysis and Design, 1 (1985) 3-20
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4.3 C-03 (Bathe Membrane Nodal Resultants)

Objective

To verify the calculation of nodal resultants for compatible membrane formulation 

Problem Description

The cantilever plate shown below is modeled with 2 x 2 mesh using compatible membrane
formulation.

Material properties: E = 2.7e6 psi, = 0.3

Thickness t = 0.1 in

Finite Element Model

4 shell elements

Model type: 2D Plane Stress (using compatible formulation)

Results

The nodal resultants given by ENERCALC 3D are identical to those given by [Ref 1].

As shown below, the nodal resultants are displayed in two lines at each node of each
element.  The first line denotes the local x component and the second line does the local y
component.  

The unit is N.
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Comments

The results given by ENERCALC 3D are identical to the referenced values.

The nodal resultants represent forces that hold each element in equilibrium.  Finite element
solutions must always satisfy nodal point equilibrium and element equilibrium.  This is true
whether a coarse or fine mesh is employed.

Reference

[1]. Bathe, “Finite Element Procedures”, pp 179, Prentice-Hall, Inc., 1996
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4.4 C-04 (Cook Membrane Problem)

Objective

To verify compatible and incompatible membrane formulations

Problem Description

The skewed cantilever plate shown below is subjected to a distributed shear of 1 lb at the
end.

Material properties: E = 1.0 psi, = 0.333

Thickness t = 1 in

Finite Element Model

4 shell elements

Model type: 2D Plane Stress (using compatible and incompatible formulations)

Results

The best results are given by [Ref 1] as follows:

Displacement Dy @ C:  23.9 in

Principal stress S1 @ A:  0.236 psi

Principal stress S2 @ B: -0.201 psi

Units: displacement – in; stress - psi



ENERCALC 3D Verifications Manual76

© 2026  ENERCALC, Inc.

Compatible formulation Incompatible formulation

Displacement
Dy @ C

Principal
Stress S1

@ A

Principal
Stress S2

@ B

Displacement
 Dy @ C

Principal
Stress S1

@ A

Principal
Stress S2

@ B

2 x 2
mesh

11.85 0.1078 -0.07762 21.05 0.1789 -0.1694

64x64 23.92 0.2376 -0.2038 23.96 0.2368 -0.2035

[Ref 1] 23.9 0.236 -0.201 23.9 0.236 -0.201

Comments

The results given by ENERCALC 3D are compared with the referenced values.  For the 2 x 2
coarse mesh, the incompatible formulation is superior to the compatible one.  For the 64 x 64
fine mesh, both compatible and incompatible formulations give satisfactory results.

Reference

[1]. Bergan & Filippa, “Triangular membrane element with rotational degrees of freedom”,
Comput. Meth. Appl. Mech. Engng., 50: 25-69, 1985
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5 Static - Shell Element
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5.1 D-01 (Bathe Membrane + Beam)

Objective

To verify the combined behavior of compatible membrane and beam elements

Problem Description

An 8 x 12 cm plate is fixed on three sides.  It is reinforced with a bar element in the middle as
shown below.  The free end of the bar is subjected to a horizontal force of 6000 N.

Material properties: E = 30e6 N/cm2, = 0.30

Plate thickness t = 0.1 cm

Bar cross sectional area = 1 cm2

Finite Element Model

2 shell elements + 1 beam element

Model type: 3D Frame & Shell (use compatible membrane formulation)

Results

The tip displacement of the bar given by ENERCALC 3D is compared with that given by [Ref
1] as follows:

Unit: displacement - cm
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ENERCALC 3D [Ref 1]

Tip displacement Dx @ N4 9.34e-4 9.34e-4

Comments

The result given by ENERCALC 3D is identical to the referenced value.

Reference

[1]. Bathe, “Finite Element Procedures”, pp361, Prentice-Hall, Inc., 1996
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5.2 D-02 (Curved Beam)

Objective

To verify the shell element using incompatible membrane and the MITC4 thick plate
formulations

Problem Description

The curved beam shown below [Ref 1] is fixed at the bottom and loaded with two sets of
loads at the tip: 1.0 lbf in-plane shear and 1.0 lbf unit out-of-plane shear.

Material properties: E = 1.0e7 psi, = 0.25

Plate thickness t = 0.1 in

Curved beam inner radius = 4.12 in, outer radius = 4.32 in, arc = 90o

Finite Element Model

6 shell elements

Model type: 3D Frame & Shell (use incompatible membrane and MITC4 thick plate
formulations)

Results

The tip displacements in the direction of loads given by ENERCALC 3D are compared with
that given by [Ref 1] as follows:

Unit: displacement - in
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Displacement in load direction ENERCALC 3D [Ref 1]

In-plane shear (in) 0.07751 0.08734 (see Note)

Out-of-plane shear (in) 0.4798 0.5022

Note:  The displacement given by [Ref 1] is smaller than the theoretical calculation based on
the following [Ref 2]:

 in

 in4

 in

Comments

The results given by ENERCALC 3D are very good considering the very coarse mesh
employed.  We would obtain better results if more elements were used along the beam
length.

Reference

[1]. MacNeal & Harder, “A Proposed Standard Set of Problems to Test Finite Element
Accuracy”, Finite Elements in Analysis and Design, 1 (1985) 3-20

[2]. Roark & Yong, “Formulas for Stress and Strain” 5th Ed, pp215, McGraw-Hill Inc., 1975
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5.3 D-03 (Pinched Cylinder)

Objective

To verify the membrane and bending behavior of the shell element in a curved structure

Problem Description

A thin cylindrical shell with diaphragm boundary conditions at both circular ends is loaded with
two opposed point loads at the center of the surface.

Material properties: E = 3.0e6 psi, = 0.3

Geometric properties: L = 600 in, R = 300 in, t = 3 in

Load: P = 1.0 lb

Finite Element Model

144 shell elements
Due to symmetry, one eighth of the cylinder is modeled with a12x12 mesh
Boundary conditions:

Edge N1-N13: Dz, Dox, Doy fixed
Edge N1-N157: Dy, Dox, Doz fixed
Edge N13-N169: Dx, Doy, Doz fixed
Edge N157-N169: Dx, Dy, Doz fixed

Note: N13 is restrained in Dx, Dz, Dox, Doy, Doz.

Model type: 3D Frame and Shell
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Results

The deflection under load is given by [Ref 1] as Dy = -1.825e-5 in.

Unit: displacement - in

ENERCALC 3D [Ref 1]

Displacement under load using different shell formulations

-1.825e-005

Compatible membrane Incompatible membrane

Kirchhoff MITC4 Kirchhoff MITC4

-1.819e-005 -1.595e-005 -1.833e-005 -1.605e-005

Comments

The results given by ENERCALC 3D are comparable to the referenced values.

It appears that the Kirchhoff thin plate bending formulation yields results close to the
referenced values.  This is especially true when plate/shell thickness is very thin.  Of course,
we have to remember that the Kirchhoff plate only applies to rectangular shell elements.

Reference

[1]. Cook, Malkus, Plesha, Witt, “Concept and Applications of Finite Element Analysis” 4th
Edition, pp583, John Wiley & Sons, Inc., 2002
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5.4 D-04 (Scordelis-Lo Roof)

Objective

To verify the membrane and bending behavior of the shell element in a curved structure

Problem Description
The Scordelis-Lo barrel roof below [Ref 1, Ref 2] has a length of 50 ft, a radius of 25 ft, and a
sweeping angle of 80 degrees.  The roof is supported on rigid diaphragms along its two
curved edges (Dx and Dy fixed, but not Dz). The two straight edges are free.  A surface load

of -90 lb/ft 2̂ in the global Y direction (self weight) is applied to the entire roof.

Material: E = 4.32e8 lb/ft 2̂ (3e6 psi); v = 0.0;

Thickness: t = 0.25 ft.

Finite Element Model

36 shell elements
Due to symmetry, one quarter of the roof is modeled with a 6x6 mesh. The boundary
conditions are specified in the following table.

Nodes Fixed DOFs

N1 to N6 Z, OX, OY

N7 X, Z, OX, OY, OZ

N14, N21, N26, N35, N42 X, OY, OZ

N43 to N48 X, Y, OZ

N49 X, Y, OY, OZ
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Model type: 3D Frame and Shell

Results

The results given by ENERCALC 3D compare well with benchmark values.

Units: displacement – ft; stress - ksf

Displacement
Dy @ N1

Displacement
 Dx @ N1

Top
Principal
Stress

S1 @ N7

Bottom
Principal
Stress

S2 @ N7

Top
Principal
Stress

S1 @ N1

Bottom
Principal
Stress

S1 @ N1

MITC4
Compatible

-0.291 -0.153 171.74 -197.69 242.55 349.35

MITC4
Incompatible

-0.307 -0.162 183.97 -210.78 225.09 352.77

Kirchhoff
Compatible

-0.290 -0.153 174.88 -200.62 238.73 351.68

Kirchhoff
Incompatible

-0.306 -0.161 187.55 -214.41 224.46 352.69

Benchmark
Value

-0.302 -0.159 191.23 -218.74 215.57 340.70

Comments

The results given by ENERCALC 3D are comparable to the referenced values.

Reference

[1]. MacNeal & Harder, “A Proposed Standard Set of Problems to Test Finite Element
Accuracy”, Finite Elements in Analysis and Design, 1 (1985) 3-20

[2]. Scordelis & Lo, “Computer Analysis of Cylindrical Shells”, Journal of the American
Concrete Institute, Volume 61, May, 1964
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5.5 D-05 (Hemispherical Shell with Point Loads)

Objective

To verify the membrane and bending behavior of the MITC4 shell element in a doubly-curved,
very thin shell structure

Problem Description
The hemispherical shell below [Ref 1] has a radius of 10 ft and a thickness of 0.04 ft.  The
equator is a free edge and is loaded with four 2-kip point loads alternating in sign at 90
degrees intervals.  The edge of the hole at the top (72 degrees from the axis of revolution) is
free.

Material: E = 6.825e7 kip/ft 2̂; v = 0.3;

Thickness: t = 0.04 ft;

Radius R = 10 ft.

Finite Element Model

8 x 32, 16 x 64 and 32 x 128 shell elements

For simplicity of boundary conditions, symmetry of the structure is not considered.  The
boundary restraints are applied to prevent instability of the structure.

Model type: 3D Frame and Shell
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Results

The results given by ENERCALC 3D compare well with benchmark values.

Units: displacement – ft

Radial displacement at load point

8 x 32 mesh 16 x 64 mesh 32 x 128 mesh

MITC4
Compatible

9.272e-2 9.289e-2 9.334e-2

MITC4
Incompatible

9.292e-2 9.313e-2 9.346e-2

Benchmark
Value

9.400e-2 9.400e-2 9.400e-2

Comments

The results given by ENERCALC 3D are comparable to the benchmark values.

This problem is one of the more challenging benchmark tests for shell elements.  The reason
is that the shell is doubly curved and shell thickness is very small in comparison with its span
(radius).  Both membrane and bending strains contribute significantly to the radial
displacement at the load point.  This example shows the superiority of the MITC4 shell
element.

We could have taken advantage of the symmetry and only model one quadrant of the
structure.  The boundary condition requires a little more thinking but is still straightforward in
this case.  An example is included with the program to illustrate this approach.

Modeling Tips

The most efficient way to construct this model in the program is as follows.  First generate
arc members using the command Create > Templates > Arc Members.  Then use Modify >
Revolve > Revolve Members to Shells command to generate doubly curved shell elements.

Reference

[1]. MacNeal & Harder, “A Proposed Standard Set of Problems to Test Finite Element
Accuracy”, Finite Elements in Analysis and Design, 1 (1985) 3-20
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6 Static - Brick Element
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6.1 E-01 (Slender Brick Beam)

Objective

To verify compatible and incompatible brick formulations using regular element shapes

Problem Description

The slender cantilever beam shown below is modeled with 6 rectangular brick elements.

Material properties: E = 1.0e7 psi, = 0.3

Section properties: Length = 60 in, height = 0.2 in, thickness t = 0.1 in

Loads: a). unit axial force; b). unit in-plane shear

Finite Element Model

6 brick elements

Model type: 3D Brick

Results

The tip displacements are given by [Ref 1].  Theoretical stresses at the root are also given
here for comparison.

Units: displacement – in; stress - psi
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Element Load type

ENERCALC 3D [Ref 1]

Displacements
@ tip

Stresses @
root

Displacements
@ tip

Stresses @
root

Compatible

Axial force 3.0e-5 -50 3.0e-5 -50

In-plane
shear

-0.01007 -854.0 0.1081 -9000

Incompatible

Axial force 3.0e-5 -50 3.0e-5 -50

In-plane
shear

-0.1072 -8173 0.1081 -9000

Comments

The results given by ENERCALC 3D are mixed in comparison with the referenced values.

Compatible and incompatible formulations behave correctly in the axial force loading.  For in-
plane shear, the incompatible brick formulation yields much better results than the compatible
one.  In practices, finer meshes should be used to achieve satisfactory results, especially for
compatible brick elements. 

Reference

[1]. MacNeal & Harder, “A Proposed Standard Set of Problems to Test Finite Element
Accuracy”, Finite Elements in Analysis and Design, 1 (1985) 3-20
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6.2 E-02 (Curved Brick Beam)

Objective

To verify the incompatible brick element in a curved structure

Problem Description

A curved beam as shown below [Ref 1] is fixed at the bottom and loaded with two sets of
loads at the tip: 1.0 lbf in-plane shear and 1.0 lbf out-of-plane shear.

Material properties: E = 1.0e7 psi, = 0.25

Plate thickness t = 0.1 in

Curved beam inner radius = 4.12 in, outer radius = 4.32 in, arc = 90o

Finite Element Model

6 brick elements

Model type: 3D Brick (use incompatible formulations)

Results

The tip displacements in the direction of loads given by ENERCALC 3D are compared with
that given by [Ref 1] as follows:

Unit: displacement - in
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Displacement in load
direction

ENERCALC 3D

[Ref 1]

6 x 1 mesh 20 x 1 mesh

In-plane shear (in) 0.07682 0.08814 0.08734 (see Note)

Out-of-plane shear
(in)

0.4116 0.4797 0.5022

Note:  The displacement given by [Ref 1] is smaller than the theoretical calculation based on
the following [Ref 2]:

  in

 in4

 in

Comments

The results given by ENERCALC 3D are very good considering the relatively coarse meshes
employed.  We would obtain better results if more elements were used along the beam
length.

Reference

[1]. MacNeal & Harder, “A Proposed Standard Set of Problems to Test Finite Element
Accuracy”, Finite Elements in Analysis and Design, 1 (1985) 3-20

[2]. Roark & Yong, “Formulas for Stress and Strain” 5th Ed, pp215, McGraw-Hill Inc., 1975
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6.3 E-03 (Incompatible Brick)

Objective

To verify the behavior of incompatible brick formulations using irregular meshes

Problem Description

A straight beam with distorted and trapezoidal elements is subjected to two sets of loading:
a). end moments; b). end shear.

Material properties: E = 1500 psi, = 0.25

Geometric properties: L = 10 in, h = 2 in, t = 1 in

Loads: a). F = 1000 lb; b). P = 300 lb



ENERCALC 3D Verifications Manual96

© 2026  ENERCALC, Inc.

Finite Element Model

5 brick (incompatible) elements

Model type: 3D Brick

Results

The displacements and stresses are given by [Ref 1].  The stresses given for ENERCALC
3D below are the average values at the top four nodes of each of the elements at the
supports.

Unit: displacement – in; stress - psi
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Mesh Loading

ENERCALC 3D Ref 1 (Theoretical)

Displacements
@ tip

Stresses
@ root

Displacements
@ tip

Stresses
@ root

Distorted

Moment 95.80 -2471
95.8
(100)

-3015
(3000)

Shear 97.90 -3223
97.9

(102.6)
-4138.5
(-4050)

Trapezoidal
Moment 76.27 -2503

76.252
(100)

-2883.5
(3000)

Shear 80.16 -3309
80.115
(102.6)

-3860
(-4050)

Comments

The displacements given by ENERCALC 3D are almost identical to the referenced values. 
The stresses are calculated by averaging the top four nodes of each element at the root.  The
stresses  given by ENERCALC 3D are different from the referenced values due to different
methods used in stress calculation.  The correct theoretical displacements and stresses are
given in parenthesis in the table.

Reference

[1]. Wilson, Ibrahimbegovic, “Use of incompatible displacement modes for the calculation of
element stiffness or stresses”, Finite Elements in Analysis and Design 7 (1990) 229-241
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6.4 E-04 (Brick Patch Test)

Problem Description

This is a patch test for a unit cube [Ref 1].  The cube is modeled with 7 eight-node brick
elements.  Nodal coordinates, element connectivity, and boundary conditions are given in the
following tables.  Boundary conditions are given as forced displacements.  No additional loads
are prescribed.

Material:  E = 1.e6 psi; = 0.25

Find stresses for each element.
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Nodal coordinates (inch)

Node X Y Z

1 0.249 0.342 0.192

2 0.826 0.288 0.288

3 0.85 0.649 0.263

4 0.273 0.75 0.23

5 0.32 0.186 0.643

6 0.677 0.305 0.683

7 0.788 0.693 0.644

8 0.165 0.745 0.702

9 0 0 0

10 1 0 0

11 1 1 0

12 0 1 0

13 0 0 1

14 1 0 1

15 1 1 1

16 0 1 1

Displacement field
u = 0.001 * (2x + y + z) / 2
v = 0.001 * (x + 2y + z) / 2
w = 0.001 * (x + y + 2z) / 2

Forced displacements (inch) on boundary

Node Dx Dy Dz

9 0 0 0

10 0.001 0.0005 0.0005

11 0.0015 0.0015 0.001

12 0.0005 0.001 0.0005

13 0.0005 0.0005 0.001

14 0.0015 0.001 0.0015

15 0.002 0.002 0.002

16 0.001 0.0015 0.0015

All strains are constant. For example



ENERCALC 3D Verifications Manual100

© 2026  ENERCALC, Inc.

Element Connectivity

Element Node1 Node2 Node3 Node4 Node5 Node6 Node7 Node8

1 1 2 3 4 5 6 7 8

2 4 3 11 12 8 7 15 16

3 9 10 2 1 13 14 6 5

4 2 10 11 3 6 14 15 7

5 9 1 4 12 13 5 8 16

6 9 10 11 12 1 2 3 4

7 5 6 7 8 13 14 15 16

Results

The displacements of internal nodes can be calculated based on the boundary conditions. 
The constant stresses are also given by [Ref 1].

Units: displacement – in

Nodes

ENERCALC 3D

(compatible and incompatible)
Theoretical

Dx Dy Dz Dx Dy Dz

1 5.16E-04 5.63E-04 4.88E-04 5.16E-04 5.63E-04 4.88E-04

2 1.11E-03 8.45E-04 8.45E-04 1.11E-03 8.45E-04 8.45E-04

3 1.31E-03 1.21E-03 1.01E-03 1.31E-03 1.21E-03 1.01E-03

4 7.63E-04 1.00E-03 7.42E-04 7.63E-04 1.00E-03 7.42E-04

5 7.35E-04 6.68E-04 8.96E-04 7.35E-04 6.68E-04 8.96E-04

6 1.17E-03 9.85E-04 1.17E-03 1.17E-03 9.85E-04 1.17E-03

7 1.46E-03 1.41E-03 1.38E-03 1.46E-03 1.41E-03 1.38E-03

8 8.89E-04 1.18E-03 1.16E-03 8.89E-04 1.18E-03 1.16E-03
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Units: stress - psi

Sxx Syy Szz Sxy Syz Sxz

ENERCALC 3D
(compatible) 1999.982 1999.982 1999.982 399.999 399.999 399.999

ENERCALC 3D
(incompatible) 1999.978 1999.978 1999.978 399.998 399.998 399.998

[Ref. 1] 2000 2000 2000 400 400 400

Comments

Both compatible and incompatible brick elements pass the patch test.  Therefore, “the results
for any problem solved with the element will converge toward the correct solution as the
elements are subdivided.” [Ref. 1]  The tiny differences in stresses are due to the penalty
approach employed in support enforcement during solution.

Reference

[1]. MacNeal & Harder, “A Proposed Standard Set of Problems to Test Finite Element
Accuracy”, Finite Elements in Analysis and Design, 1 (1985) 3-20
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6.5 E-05 (Hemispherical Shell with Point Loads)

Objective

To verify the behavior of the incompatible brick element in a doubly-curved, very thin shell
structure

Problem Description

This problem is the same as problem D-05.  Only this time we are using the 3D brick element
instead of the MITC4 shell element to model the structure.

Finite Element Model

48 x 48 x 1 incompatible brick elements

Due to symmetry of the structure, we model only a quadrant of the structure.  Restraints in
the direction of global X and Z are applied to the quadrant lines respectively.  A single vertical
restraint is applied at the center of the quadrant equator.  This is to prevent instability of the
structure.

Model type: 3D Brick

Results

The result given by ENERCALC 3D compares well with benchmark values.

Units: displacement – ft
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Radial displacement at load point

48 x 48 x 1 mesh

Incompatible brick element 9.262e-2

Benchmark
Value

9.400e-2

Comments

The result given by ENERCALC 3D is comparable to the benchmark value.

This problem is one of the more challenging benchmark tests for solid elements.  The reason
is that the shell is doubly curved and shell thickness is very small in comparison with its span
(radius).  We used a relatively fine mesh so the element aspect ratio (8:7:1) would not be too
large.  Also, we used incompatible brick element formulation.  Compatible brick element
formulation would be too stiff for this mesh model.

Modeling Tips

The most efficient way to construct this model in the program is as follows (see the figures
below).  First generate two sets of side arc members using the command Create >
Templates > Arc Members.  Then create one shell element at the top using the nodes on the
arc members.  Delete all generated members.  Now use Create > Entities from other Entities
> Shells by Nodes to generate 7 more shell elements using the existing nodes on the arcs. 
Lastly, use Modify > Revolve > Revolve Shells to Bricks command to generate brick
elements.  This method simplifies the generation procedure.
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Reference

[1]. MacNeal & Harder, “A Proposed Standard Set of Problems to Test Finite Element
Accuracy”, Finite Elements in Analysis and Design, 1 (1985) 3-20
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7 Dynamic
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7.1 F-01 (Simple 2D Frame Vibration)

Objective

To verify the behavior of beam element vibration

Problem Description

A right-angle frame [Ref 1] vibrates under its own weight as shown below. 

Material properties: E = 2e11 Pa, = 0.29, = 7860 Kg/m3

Section properties: square section 100 x 100 mm

Finite Element Model

50 beam elements

Model type: 2D Frame (shear deformation considered)

Results

The mode frequencies are given by [Ref 1]
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Unit: mode frequency - Hz

Mode Frequency ENERCALC 3D [Ref 1]

Mode 1 3.331 3.315

Mode 2 35.07 35.08

Mode 3 70.60 70.77

Mode 4 122.6 122.7

Mode 5 225.7 226.0

Mode 6 269.0 269.4

Mode 7 395.7 396.6

Mode 8 420.7 420.8

Mode 9 552.2 552.3

Mode 10 650.1 649.6
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First Four Mode Shapes:

Mode Shape 1 Mode Shape 2

Mode Shape 3 Mode Shape 4

Comments

The vibration frequencies given by ENERCALC 3D are very close to the referenced values.

Reference

[1]. Cook, Malkus, Plesha, Witt, “Concept and Applications of Finite Element Analysis” 4th
Edition, pp436, John Wiley & Sons, Inc., 2002
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7.2 F-02 (2D Truss Vibration)

Objective

To verify the behavior of truss element vibration

Problem Description

The 2D truss structure [Ref 1] shown below vibrates under its own weight.  Nodal coordinates
in meters are shown in parenthesis. 

Material properties: E = 7.17e10 N/m2, = 0.30, = 2768 Kg/m3

Section cross-sectional areas

Vertical trusses: 8.0e-5 m2

Horizontal trusses: 6.0e-5 m2

Diagonal trusses: 4.0e-5 m2

Finite Element Model

15 beam elements

Model type: 2D Truss
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Results

The mode frequencies are given by [Ref 1]

Unit: mode frequency – Hz

Mode Frequency ENERCALC 3D [Ref 1]

Mode 1 7.9822 7.9832

Mode 2 27.9952 28.0012

Mode 3 44.8770 44.8815

Mode 4 49.5731 49.5859

Mode 5 94.9018 94.925

Mode 6 116.3799 116.3882

Mode 7 125.6432 125.6551

Mode 8 126.1574 126.1727

Mode 9 132.1162 132.1308

Mode 10 152.2912 152.3021

Comments

The vibration frequencies given by ENERCALC 3D are very close to the referenced values.

Reference

[1]. Stejskal, Dehombreux, Eiber, Gupta, Okrouhlik, “Mechanics with Matlab” April 2001
Web: http://www.geniemeca.fpms.ac.be/mechmatHTML/
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7.3 F-03 (Cantilevered Tapered Membrane Vibration)

Objective

To verify the behavior of membrane plate vibration

Problem Description

The cantilevered tapered membrane plate [Ref 1] shown below vibrates under its own weight.
 

Material properties: E = 2.0e11 Pa, = 0.30, = 8000 Kg/m3

Plate thickness:, t = 0.05 m

Finite Element Model

128 shell elements

Model type: 2D Plane Stress

Results

The mode frequencies are given by [Ref 1].

Unit: mode frequency – Hz
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Mode Frequency

ENERCALC 3D

[Ref 1]

Compatible Membrane
Incompatible
Membrane

Mode 1 44.7076 44.4487 44.623

Mode 2 130.3669 129.2843 130.03

Mode 3 162.4766 162.4449 162.70

Mode 4 246.2847 243.6222 246.05

Mode 5 378.4229 373.7379 379.90

Mode 6 389.4256 389.2006 391.44

Comments

The vibration frequencies given by ENERCALC 3D are very close to the referenced values.

Reference

[1]. Abbassian, Dawswell, Knowles “Selected Benchmarks for Natural Frequency Analysis”,
Test No. 32, NAFEMS Finite Element Methods & Standards, Nov. 1987
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7.4 F-04 (Cantilever Plate Vibration)

Objective

To verify the behavior of plate bending vibration

Problem Description

The 24 x 24 in cantilever plate [Ref 1] shown below vibrates under its own weight.  

Material properties: E = 2.95e+007 psi, = 0.20, density = 0.28356 lb/in3

Plate thickness: t =1 in

Finite Element Model

361 shell elements (19 x 19 mesh)

Model type: 2D Plate Bending

Results

The mode frequencies are given by [Ref 1].

Unit: mode frequency – Hz
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Mode Frequency

ENERCALC 3D
[Ref 1]

MITC4 Thick Plate Kirchhoff Thin Plate

Mode 1 0.0176 0.0175 0.01790

Mode 2 0.0070 0.0069 0.00732

Mode 3 0.0028 0.0028 0.00292

Mode 4 0.0023 0.0022 0.00228

Mode 5 0.0019 0.0019 0.00201

Comments

The vibration frequencies given by ENERCALC 3D are very close to the referenced values.

Reference

[1]. Harris, Crede “Shock and Vibration Handbook”, McGraw-Hill, Inc, 1976
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7.5 F-05 (Cantilever Brick Vibration)

Objective

To verify the behavior of brick element vibration

Problem Description

A 1.0 m long cantilever beam fixed at the left end as shown below vibrates under its own
weight.  

Material properties: E = 2.0e11 N/m2, = 0, density = 7800 kg/m3

Beam section: b x h = 0.05 x 0.1 m

Finite Element Model

40 brick elements (20 x 2 x 1 mesh)

Model type: 3D Brick

Boundary conditions
Fixed Dx, Dy and Dz for nodes at left end
Fixed Dx for nodes along the middle line
Fixed Dz for all nodes

Results

The theoretical mode frequencies may be calculated as follows [Ref 1]:

 

Where K1 = 3.51602; K2 = 22.0345; K3 = 61.6972

Unit: mode frequency – Hz
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Mode Frequency

ENERCALC 3D
Theoretical

Compatible Brick Incompatible Brick

Mode 1 86.0831 81.1984 81.80

Mode 2 517.9047 489.7797 512.6

Mode 3 1370.6341 1300.4777 1435.4

Comments

The first and second vibration frequencies given by ENERCALC 3D are close to the
theoretical ones.  More elements need to be used to get accurate third and higher
frequencies.

The boundary conditions are chosen such that out-of-plane and axial directions are
suppressed so we can concentrate on the behavior of in-plane vibration.

Reference

[1]. Chopra, “Dynamics of Structures” 2nd Edition, pp 679, Prentice Hall, Inc., 2001
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7.6 F-06 (2D Steel Frame Vibration)

Objective

To verify the behavior of the beam element in large 2D steel frame vibration

Problem Description

A 5-span, 12-story 2D steel frame vibrates under its own weight as shown below.  All beams
are W24’s and all columns are W14’s

Material properties: E = 29000 ksi, = 0.3, density = 483.84 lb/ft3

Interior columns:  Exterior columns:
Floor 1 – 4: W14x120 Floor 1 – 4: W14x90
Floor 5 – 8: W14x90 Floor 5 – 8: W14x68
Floor 9 – 12: W14x68 Floor 9 – 12: W14x48

Beams:  
Floor 1 – 4: W24x131
Floor 5 – 8: W24x104
Floor 9 – 12: W24x84
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Units: Iz, Iy and J – in4, A, Ay and Az – in2

Section Iz Iy J A Ay Az

W14X120 1380 495 9.37 35.3 8.555 23.03

W14X90 999 362 4.06 26.5 6.16 17.1583

W14X68 722 121 3.01 20 5.81 12

W14X48 484 51.4 1.45 14.1 4.692 7.96308

W24X131 4020 340 9.5 38.5 14.8225 20.64

W24X104 3100 259 4.72 30.6 12.05 16

W24X84 2370 94.4 3.7 24.7 11.327 11.5757

Finite Element Model

132 beam elements

Model type: 2D Frame (shear deformation included)

Results

The first three natural frequencies are compared with another program, Frame Analysis &
Design (STRAAD) [Ref. 1].

Units: Hz

ENERCALC 3D
Frame Analysis & Design

(STRAAD)

Mode 1 1.7508 1.7402386

Mode 2 4.6904 4.6629050

Mode 3 7.9692 7.9228372

Comments

The results given by ENERCALC 3D are very close to the referenced values.

Reference

[1]. “Frame Analysis & Design”, Digital Canal Corporation, Dubuque, Iowa, USA
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7.7 F-07 (3D Frame Vibration)

Objective

To verify the behavior of the beam element in large 3D frame vibration

Problem Description

A 3D single story frame structure with a length = 27.25 in, width = 17.25 in and height =
18.625 in, is fixed at the bottom.  Nodes are inserted at 8.625 in from the top corner nodes
along the length, width and height.

Material: E = 2.79e+007 lb/in2, v = 0.3

Sections: A = 1.07453 in2, Ay = Az = 0.537266 in2, Iz = Iy = 0.665747 in4, J = 1.33149 in4

Masses: Corner nodes = 0.0253816 lb-sec2/in (X, Y and Z directions)

 All other nodes except supports: 0.00894223 lb-sec2/in (X, Y and Z directions)

Finite Element Model

18 beam elements

Model type: 2D Frame (shear deformation included)
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Results

The first 10 natural frequencies are compared with another independent program Larsa [Ref.
1]. 

Units: Hz

ENERCALC 3D Larsa

Mode 1 111.2088 111.21

Mode 2 115.7695 115.77

Mode 3 137.1354 137.13

Mode 4 215.7477 215.74

Mode 5 404.1712 404.16

Mode 6 422.5145 422.50

Mode 7 451.4604 451.45

Mode 8 548.8147 548.80

Mode 9 733.3148 733.29

Mode 10 758.2787 758.26

Comments

The results given by ENERCALC 3D are very close to the referenced values.
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7.8 F-08 (Response Spectrum Analysis of 4 Story Shear Building)

Objective

To verify the results of response spectrum analysis of a shear building using beam elements

Problem Description

A 4-story shear building [Ref 1] with corresponding mass and stiffness info shown below.
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The response spectrum is defined below (from Create > Generate Loads > Response
Spectra Library menu).

Period (sec)
Spectral Acceleration

(g)

0.0 0.15

0.1 0.18

0.2 0.25

0.3 0.38

0.4 0.50

0.5 0.50

0.6 0.40

0.8 0.32

1.0 0.25

1.2 0.19

We will use four 1m steel beam elements, with sectional area of A1 = 4 mm2, A2 = 8 mm2,

A3 = 12 mm2 and A4 = 16 mm2.  E = 199.948 KN/mm2, v = 0.3.  The axial stiffness EA/L will
match the shear building column stiffness.  We will use very large values for other section
properties such as Iz, Iy, J, Ay, Az.  This effectively allows us to focus beam element behavior
in axial direction only.

We will apply vertical loads F1 = 14.7 KN, F2 = 29.4 KN, F3 = 29.4 KN and F4 = 44.1 at the
four free nodes.  These forces will be converted to equivalent masses by the program during
frequency/response spectrum analysis.
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Results

The following lists different results by ENERCALC 3D against the reference [Ref. 1]. 

Vibration Periods (sec)

ENERCALC 3D Reference

Mode 1 0.5788 0.5789

Mode 2 0.2594 0.2595

Mode 3 0.1873 0.1873

Modal Displacements (cm)

Node ENERCALC 3D Reference

Mode 1 Mode 2 Mode 3 Mode 1 Mode 2 Mode 3

1
5.1930E+00 -3.9987E-01 5.8228E-02 5.19545e+00

-4.00257e-
01

5.82355e-02

2
4.0459E+00 3.9837E-02 -6.4594E-02 4.04779e+00 3.98752e-02

-6.46441e-
02

3 2.5786E+00 2.1588E-01 1.0244E-02 2.57982e+00 2.16095e-01 1.03938e-02

4 1.2207E+00 1.7499E-01 4.5731E-02 1.22125e+00 1.75157e-01 4.56209e-02

Inertia Forces (N)

Node ENERCALC 3D Reference

Mode 1 Mode 2 Mode 3 Mode 1 Mode 2 Mode 3

1
9.1746E+0

3
-3.5167E+03 9.8232E+02

9.18127e+0
3

-
3.52106e+0

3
9.83037e+02

2 1.4296E+0
4

7.0070E+02 -2.1794E+03
1.43063e+0

4
7.01546e+0

2
-

2.18364e+03

3 9.1113E+0
3

3.7973E+03 3.4565E+02
9.11798e+0

3
3.80201e+0

3
3.55155e+02

4 6.4698E+0
3

4.6169E+03 2.3145E+03
6.47450e+0

3
4.62254e+0

3
2.30532e+03
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Base Shear Forces (N)

ENERCALC 3D Reference

Maximum Likely
(SRSS)

3.9478e+004 3.951e+04

Maximum Possible
(ABSSUM)

4.6113e+004 4.614e+4

Comments

The results given by ENERCALC 3D are very close to the referenced values.  We did not
enter nodal masses directly.  Therefore, we need to make sure nodal forces are converted to
masses before frequency analysis (Analysis > Frequency Analysis).

Reference

[1]. “Earthquake Response Spectrum Analysis of 4 Story Shear Building”, 1996, Mark Austin,
Department of Civil Engineering, University of Maryland
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7.9 F-09 (Response Spectrum Analysis of 2D Frame)

Objective

To verify the results of response spectrum analysis on a 2D frame.

Problem Description

A 2-story concrete frame shown below [Ref 1] fixed at the bottom is subjected to ground
motion characterized by the design spectrum specified. 

Geometry: bay distance = 20 ft, each story height = 10 ft.

Material: E = 3000 ksi.

Section-1: Iz = 1000 in4; Section-2: Iz = 2000 in4. Other section properties are set to very
large values to simulate bending only actions.  

Masses: first floor center = 12.4368 kip-sec2/ft in X direction, second floor center = 6.2184

kip-sec2/ft in X direction.
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The design response spectrum is defined below (from Create > Generate Loads > Response
Spectra Library menu).

Period (sec)
Spectral Acceleration

(g)

0.000 0.500

0.030 0.500

0.125 1.355

0.587 1.355

0.660 1.355

1.562 0.576

4.120 0.218

10.000 0.037

Results

The following lists different results by ENERCALC 3D against the reference [Ref. 1]. 

Time Periods (sec)

ENERCALC 3D Reference

Mode 1 1.5621 1.562

Mode 2 0.5868 0.5868

Modal Displacements SRSS combination (in)

ENERCALC 3D Reference

First story 7.576e+000 7.566

Second story 1.884e+001 18.81
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Bending Moment (kip-ft)

Element Location
ENERCALC 3D Reference

Mode 1 Mode 2 Mode 1 Mode 2

First Floor
Beam

Left End -815.6 -56.54 -814 -57

Second Floor
Beam

Left End -396.9 178.5 -396 179

Bottom
Column

Top End 425.9 372.9 425 374

Bottom End 969.6 410.6 968 412

Top Column
Top End 396.9 -178.5 396 -179

Bottom End 389.7 -316.4 389 -317

Comments

The results given by ENERCALC 3D are very close to the referenced values. The bending
moments are from load combinations INERTIA_LOADCOMB_X_MODE_1 and
INERTIA_LOADCOMB_X_MODE_2 which are generated automatically during the response
spectrum analysis process.

Reference

[1]. pp 562, “Dynamics of Structures – Theory and Applications To Earthquake Engineering”,
2001, Second Edition, by Anil K. Chopra, Prentice Hall.
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7.10 F-10 (Response Spectrum Analysis of 3D Frame)

Objective

To verify the results of response spectrum analysis on a 3D frame

Problem Description

A 2-story 3D frame shown below [Ref 1] fixed at the bottom is subjected to ground motion
characterized by constant 0.4g for all modes, with 5% damping.

Geometry: X direction = 2 x 35 ft; Y direction = 2 x 13 ft; Z direction = 2 x 25 ft.

Columns: E = 350,000 k/ft2.  A = 4 ft2, Iz = 1.25 ft4, Iy = 1.25 ft4, J = 1.25 ft4, Ay =Az = 0 ft2

Beams: E = 500,000 k/ft2.  A = 5 ft2, Iz = 2.61 ft4, Iy = 1.67 ft4, J = 1.25 ft4, Ay =Az = 0 ft2

Two additional nodes 28 (38, 13, 27) and 29 (38, 26, 27) are placed on the first and second
floors as they are the center of masses for the respective floors.

Masses: 6.2112 k-sec2/ft at nodes 28 and 29 (X and Z directions).

To prevent nodes 28 and 29 from being orphaned nodes, we will add two additional beams

with very small section properties (Iz = Iy = J = 1e-5 ft4, A = 1e-5 ft2) to connect node 28 with
node 14 (or any other node on the first floor) and nodes 29 with node 17 (or any other node on
the second floor).
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Results

The following lists different results by ENERCALC 3D against the reference [Ref. 1]. 

ENERCALC 3D Reference

Mode 1 period (sec) 0.2269 0.2271

Mode 2 period (sec) 0.2152 0.2156

Mode 3 period (sec) 0.0733 0.0733

Mode 4 period (sec) 0.0719 0.0720

X displacement at node 29
ABSSUM modal combination (ft)

0.02045 0.02050

X displacement at node 29 SRSS
modal combination (ft)

0.02010 0.02012

X displacement at node 29 CQC
modal combination (ft)

0.02011 0.02014

Comments

The results given by ENERCALC 3D are very close to the referenced values. This verification
problem also confirms the robustness of rigid diaphragm implementation.  Due to program
limitation, we have to add couple of weak beams on the floors to prevent center-of-mass
nodes (node 28 and 29) from being orphaned.   

Reference

[1]. Example 1-024, Sap2000 Software Verification Manual, 2007, Computers and Structures,
Inc., Berkeley, California.
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8 Concrete Design
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8.1 G-01 (Flexural Design of Concrete Beams)

Objective

To verify the design of the rectangular and Tee concrete beams

Problem Description

The following concrete beams are to be designed according to ACI 318-02 code.  The flange
width and thickness are given in parenthesis for Tee beams.

Beam B x H [Bf x Tf]  (in) fc (ksi) fy (ksi) dt (in) d’ (in)
Mu (ft-

kips)

1 10 x 16 4 60 13.5 2.5 123.2

2 14 x 23 4 60 20.5 2.5 516

3 10 x 21.5 [30 x 2.5] 4 60 19.0 2.5 227

4 10 x 21.5 [30 x 2.5] 4 60 19.0 2.5 400

5 10 x 22.5 3 40 20.0 2.5 129

6 11 x 25 3 60 22.5 2.5 403

7 10 x 20 4 60 16.0 2.5 211

Finite Element Model

7 beam elements with appropriate material and design criteria assigned

Model type: 2D Frame
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Results

The design results of these beams are compared with the references.

Beam
ENERCALC 3D References

As As’ As As’ Reference Page

1 2.41 0 2.40 0 Ref [1] pp. 7-23

2 6.59 1.44 6.58 1.43 Ref [1] pp. 6-30

3 2.77 0 2.77 0 Ref [1] pp. 7-33

4 5.10 0 5.10 0 Ref [1] pp. 7-35

5 2.37 0 2.37 0 Ref [2] pp. 133

6 4.66 1.31 4.74 1.20 Ref [2] pp. 191

7 3.48 0.70 3.48 0.70 Ref [3] pp. 102

Comments

The results given by ENERCALC 3D are very close to the referenced values.  The model
consists of multiple simply supported beams.  Nodal moments of opposite signs are applied
to nodes to achieve uniform moments in each member. The program is very versatile to
design multiple isolated beams as well as to design members in integrated frames.

Reference

[1]. “Notes on ACI 318-02 Building Code Requirements for Structural Concrete”, 8th Edition,
Portland Cement Association, 2002

[2]. James G. MacGregor & James K. Wight, “Reinforced Concrete – Mechanics and
Design”, 4th Edition, Pearson Prentice Hall, 2005

[3]. Arthur H. Nilson, David Darwin, Charles W. Dolan, “Design of Concrete Structures”, 13th
Edition, McGraw-Hill Higher Education, 2004
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8.2 G-02 (Shear Design of Concrete Beams)

Objective

To verify the shear design the rectangular and circular concrete beams (columns)

Problem Description

The following concrete beams (columns) are to be designed according to ACI 318-02 code. 
The concrete cover to stirrup is 1.5 inches.

Beam Dimension (in) fc (ksi)
fys

(ksi)

Longitudinal
Bar Size

Stirrup
Size

Pu (kips)
Vu

(kips)

1
Rectangular

12 x 16
4 40 #6 #3

160
(compression)

20

2
Circular

Diameter 14
4 40 #6 #3

10
(compression)

30

Finite Element Model

2 beam elements with appropriate material and design criteria assigned

Model type: 2D Frame

Results

The design result of the first beam element is compared with the [Ref 1].  The second beam
element is a round column subjected to compression and is designed as follows:

 lbs

 kips

 in.

Note: For circular section, bw = 2R, d = 0.8(2R) are used to compute Vc and Vs, according to

ACI 318-02 11.3.3 and 11.5.7.3
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The following table shows and required stirrup spacing for the two beam elements.  The
program does not round the required stirrup spacing to the practical dimension.

Beam
ENERCALC 3D Reference / Theoretical

(kips) s (in) (kips) s (in)

1 22.175 6.88 22.2 6.9

2 15.359 5.05 15.358 5.05

Comments

The results given by ENERCALC 3D are very close to the reference and theoretical values. 
The model consists of multiple simply supported beams.  Nodal moments of same signs are
applied to nodes to achieve uniform shears in each member.

Reference

[1]. “Notes on ACI 318-02 Building Code Requirements for Structural Concrete”, 8th Edition,
pp. 12-19, Portland Cement Association, 2002
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8.3 G-03 (Axial-Flexural Design of Concrete Columns)

Objective

To verify the axial-flexural design of the rectangular and circular concrete columns

Problem Description

The following concrete columns [Ref 1, 2] are to be designed according to ACI 318-02 code.  

Beam Dimension (in) fc (ksi) fys (ksi) Pu (kips) Mux (ft-
kips)

Muy (ft-
kips)

1 
[Ref.1]

Rectangular
16 x 16

3 60
249

(compression)
55 110

2
[Ref. 2]

Circular
26

4 60
1600

(compression)
150 0

3
[Ref. 3]

Rectangular
20 x 12

4 60
255

(compression)
63.75 127

Finite Element Model

3 beam elements with appropriate material and design criteria assigned

Model type: 3D Frame

Results

The design results are compared with the [Ref 1] and [Ref 2] in the following table.  

Beam
ENERCALC 3D Reference

Bars Unity Check Bars

1
12#7 

(4 on each side)
0.976

12#7 (4 on each side) or
8#8 (3 on each side)

2 13#10 0.982 12#10

3
8#9 

(3 on each side)
0.915

8#9
(3 on each side)

Comments

The first column is biaxially loaded and therefore a 3D frame model is used.  [Ref 1] gives
12#7 (4 on each side) bars or 8#8 (3 on each side) bars based on Equivalent Eccentricity
Method and Bresler Reciprocal Load Method respectively.  The program gives 12#7 bars (4#7
on each side) if trial bar size starts with #7 and bar layout uses ‘equal sides’ option.  If 8#8
bars (3#8 on each side) are used, the program gives a unity check value of 1.024 (and
therefore the design fails).  Since the program always tries to find the first section that will
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pass the unity check (< 1.0), we need to limit the maximum reinforcement ratio (say 3% in
this case) in order to see the unity check of the 8#8 bars (3#8 on each side) section.  In
addition, we also need to set the start and end bar sizes to be #8 and bar layout to be ‘equal
sides’ in the column design criteria for comparison.

The second column is a circular spiral column.  The program gives 13#10 bars while [Ref 2]
gives 12#10.  If 12#10 bars are used, the program gives a unity check value of 1.008 (and
therefore the design fails).  Practically speaking, 12#10 should be regarded as ok.

Each column is modeled with one 3D beam element with one support flag of 111100 (fixed in
Dx, Dy, Dz and Dox) and the other support flag of 011100 (fixed in Dy, Dz and Dox).  Nodal
moments and forces are applied in respective directions.  Since no slenderness is
considered, very small effective length factors are used.

Reference

[1]. James G. MacGregor & James K. Wight, “Reinforced Concrete – Mechanics and
Design”, 4th Edition, pp.529-532, Pearson Prentice Hall, 2005

[2]. James G. MacGregor & James K. Wight, “Reinforced Concrete – Mechanics and
Design”, 4th Edition, pp.519, Pearson Prentice Hall, 2005

[3]. Arthur H. Nilson, David Darwin, Charles W. Dolan, “Design of Concrete Structures”, 13th
Edition, pp. 278, McGraw-Hill Higher Education, 2004
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8.4 G-04 (Axial-Flexural Design of Concrete Slender Columns)

Objective

To verify the axial-flexural design of the rectangular concrete column (braced)

Problem Description

The following concrete braced column [Ref 1] is to be designed according to ACI 318-02
code.  The clear concrete cover to stirrup is 1.5 inches.  Use fc = 4 ksi, fy = 60 ksi

Size (in) 18 x 18

Total length (ft) 13

Unbraced length (ft) 13

Effective length factor 0.87

Dead Pu (kips) 230 (compression)

Dead Mu-top (ft-kips) 2

Dead Mu-bottom (ft-kips) -2

Live Pu (kips) 173 (compression)

Live Mu-top (ft-kips) 108

Live Mu-bottom (ft-kips) 100

Finite Element Model

1 beam elements with appropriate material and design criteria assigned

Model type: 2D Frame
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Results

The following table shows some intermediate and final results during the design.  The
program gives comparable results with the reference [Ref 1].

ENERCALC 3D [Ref 1]

Cm 0.960 0.96

 d. 0.499 0.50

Moment magnification factor 1.145 1.15

Pu (kips) 552.8 553

Mu (ft-kips) 200.6 201

Bars 8 # 9 4 # 10 + 4 # 9

Comments

Since this is a braced column, we do not need to perform the 2nd order analysis for the
design.

Reference

[1]. Arthur H. Nilson, David Darwin, Charles W. Dolan, “Design of Concrete Structures”, 13th
Edition, pp. 304, McGraw-Hill Higher Education, 2004
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8.5 G-05 (Flexural Design of Cantilever Concrete Slab)

Objective

To verify the flexural design of the concrete slab

Problem Description

The 6 ft cantilever concrete slab shown below has a length of 30 ft and a thickness of 7.5 in. 
It is subjected to a uniform load of 350 lb/ft 2̂.  Design the flexural reinforcement for the slab
according to ACI 318-02 code.  The concrete cover (c.c.) is 1.0 inch.  Use fc = 4 ksi, fy = 60
ksi
E = 3644 ksi, v = 0.15

Finite Element Model

12 x 60 shell elements, each of which has a size of 0.5 x 0.5 ft. 

Model type: 2D Plate Bending, Use Kirchhoff thin plate bending

Results

The maximum design moment (Wood-Armer moment) in top-X direction Top-Mux  = -6.381

kip-ft/ft.  The program gives the corresponding top-X direction steel Top-Asx = 0.2238 in2/ft,
which is consistent with the following hand calculation.

 in2/ft
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The contour (rotated) of the top steel required in X-direction is shown below.

Comments

No minimum top or bottom reinforcement is considered in this example.  The Kirchhoff thin
plate (instead of the MITC4 thick plate) formulation is used for analysis.  This is generally
recommended for models that contain only rectangular elements of thin or moderately thick
plates (shells).

Reference

None
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9 Steel Design



Steel Design 145

© 2026  ENERCALC, Inc.

9.1 H-01 (W Steel Beam)

Objective

To verify the steel W-shaped beam design in flexure

Problem Description

Select the lightest W section for the simply supported beam of L = 50ft, Lb = 25 ft.  The
superimposed load is 0.4 kip/ft dead load and 1.0 kip/ft live load.  

Use A992 steel.

[Ref 1, pp 435-437].  

Finite Element Model

1 beam elements with appropriate material and design criteria assigned

Model type: 2D Frame

Results

The following table shows some intermediate and final results during the design.  The
program gives comparable results with the reference [Ref 1].

ENERCALC 3D [Ref 1]

Cb 1.30073 1.30

Lp (ft) 9.36033  9.36

Lr (ft) 30.3592 30.3

Mu (ft-kips) 686.295 688

Phi-Mnx (ft-kips) 740.751 740

Reference

[1]. Charles Salmon, John Johnson and Faris Malhas, “Steel Structures” 5th Edition, Pearson
Prentice Hall, 2009
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9.2 H-02 (W Steel Column)

Objective

To verify the steel W-shape column design in combined axial and flexure

Problem Description [Ref .1, Example H.4]  

Select an ASTM A992 W-shape with a 10-in nominal depth to carry the following load effects:

Pu = 30 kips, Mux = 90 kip-ft, Muy = 12 kip-ft.  

The unbraced length is 14 ft and the ends are pinned.  Cb = 1.14.  The member is non-sway.

Finite Element Model

1 beam elements with appropriate material and design criteria assigned

Model type: 3D Frame

Results

The following table shows some intermediate and final results during the design.  The
program gives comparable results with the reference [Ref 1].

ENERCALC 3D [Ref 1]

Designed Section W10x33 W10x33

B1  1.0176 1.02

Lp (ft) 6.85247 6.85

Lr (ft) 21.7757 21.8

Phi-Pn (kips) 252.522 253

Phi-Mnx (ft-kips)  136.59  137

Phi-Mny (ft-kips)  52.5 52.5

Critical Ratio 0.978576 0.979

Reference

[1]. AISC “Design Examples”, Version 14.1
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9.3 H-03 (C Steel Beam)

Objective

To verify the steel channel beam capacity check in flexural and deflection 

Problem Description [Ref .1, Example F.2-1A]  

Check the capacity of the channel section C15x33.9 for the following beam

Simply supported L = 25 ft.

Limit the live load deflection to L/360.

The nominal loads are a uniform dead load of 0.23 kip/ft and a uniform live load of 0.69 kip/ft.

The beam is continuously braced.  

Finite Element Model

1 beam elements with appropriate material and design criteria assigned

Model type: 2D Frame

Results

The following table shows some intermediate and final results during the design.  The
program gives comparable results with the reference [Ref 1].

ENERCALC 3D [Ref 1]

Mu (kips-ft) 107.813 108

Phi-Mnx (ft-kips) 137.16 137

Max live load deflection (in) 0.663206 0.664

Live load deflection limit (in) 0.833333 0.833

Reference

[1]. AISC “Design Examples”, Version 14.1
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9.4 H-04 (HSS Steel Column)

Objective

To verify the steel HSS column capacity check in axial direction 

Problem Description [Ref .1, Example E.10]  

Check the capacity of HSS12x8x3/16 column in axial compression. 

Fy = 46 ksi, L = 30 ft, Kx = Ky = 0.8, Kz = 1.0, Lu = 30 ft, Cb = 1.0.

Finite Element Model

1 beam elements with appropriate material and design criteria assigned

Model type: 3D Frame

Results

The following table shows some intermediate and final results during the design.  The
program gives comparable results with the reference [Ref 1].

ENERCALC 3D [Ref 1]

Phi-Pn (kips) 142.063 142

Reference

[1]. AISC “Design Examples”, Version 14.1
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9.5 H-05 (Round HSS Steel Column)

Objective

To verify the steel round HSS column capacity check in shear 

Problem Description [Ref .1, Example G.5]  

Check the capacity of HSS16X0.375 column in shear. 

Fy = 42 ksi, L = 32 ft

Finite Element Model

1 beam elements with appropriate material and design criteria assigned

Model type: 3D Frame

Results

The following table shows some intermediate and final results during the design.  The
program gives comparable results with the reference [Ref 1].

ENERCALC 3D [Ref 1]

Phi-Vnx (kips) 195.048 195

Reference

[1]. AISC “Design Examples”, Version 14.1
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9.6 H-06 (Double Angle Steel Column)

Objective

To verify the steel double angle column axial capacity

Problem Description [Ref .1, Example E.6]  

Check the capacity of 2L5x3x1/4x3/4LLBB column in axial compression. 

Fy = 36 ksi, L = 8 ft, Kx = Ky = Kz = 1.0, Lux = Luy = Luz = 8 ft. 

Connector distance = 32 in = 2.66667 ft.

Finite Element Model

1 beam elements with appropriate material and design criteria assigned

Model type: 3D Frame

Results

The following table shows some intermediate and final results during the design.  The
program gives comparable results with the reference [Ref 1].

ENERCALC 3D [Ref 1]

Phi-Pn (kips) 64.2975 64.3

Reference

[1]. AISC “Design Examples”, Version 14.1
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9.7 H-07 (WT Steel Beam)

Objective

To verify the steel WT beam flexural capacity

Problem Description [Ref .1, Example F.10]  

Check the capacity of WT6x5 in flexure for the simply supported beam of L = 6 ft.  The load is
0.08 kip/ft dead load and 0.24 kip/ft live load.  

Use A992 steel.  The beam is continuously braced.

Finite Element Model

1 beam elements with appropriate material and design criteria assigned

Model type: 2D Frame

Results

The following table shows some intermediate and final results during the design.  The
program gives identical results with the reference [Ref 1]. In the next few pages, we will
include the step-by-step calculation procedures output by the program.

ENERCALC 3D [Ref 1]

Mu (kip-ft) 2.16 2.16

Phi-Mnx (kip-ft) 7.32 7.32

Reference

[1]. AISC “Design Examples”, Version 14.1
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10 Step-By-Step Examples

This part of the documentation contains example problems solved by ENERCALC 3D.  They
are used to demonstrate the capabilities and reliabilities of the program.  They may also serve
as simple tutorials for the program.

Each example contains:
§ A brief description of the problem,
§ Suggested steps to create the model in the program,
§ Comparison of program results with theoretical or published results,
§ Comments.

Many of the example problems are simple and may even be verified by hand calculations. 
This is deliberate because simple models are easy to construct and hand calculation is the
most reliable verification method.  The data files for all of the example problems are provided
in the “Verifications” subdirectory under the program directory. They have the file extensions
of “r3a”.  You may open these files, perform the analyses, and review the results.  However, in
order to get yourself familiar with the program, you are strongly encouraged to create these
models from scratch.  

Suggested modeling steps list the major steps to create each model.  These steps serve only
as a guide and not an exact step-by-step procedure in the creation of the model.  We trust
you as an engineer to be creative in using the many different model-creation methods in the
program.  The General Modeling Guide on the following page is a good starting point.  All
examples use the default settings in the program unless specified.  For example, if no load
case or load combination is defined, the “Default” load case or “Default” combination will be
used.  No stress averaging is used for finite elements unless explicitly specified.

Result checking for each problem usually starts with displacements.  The reason for this is
simple. The program uses the stiffness method and therefore is displacement-based.  If the
displacements were wrong, nothing else would be right.  Other results such as forces and
moments may be more relevant or important to you as an engineer.  However, they are not
the primary verification parameters and are provided where applicable.

Important comments are summarized at the end of each example.  They explain the modeling
techniques and results.
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10.1 General Modeling Guide

Activity Menus

Set up units. Settings and Tools > Units & Precisions

Define materials, sections, and
thicknesses

Create > Member Properties > Materials (or Sections),
Create > Shell Properties > Materials (or Thicknesses)

Construct geometry.  Start with
generating commands whenever
possible; draw individual nodes and
elements whenever necessary

Create > Templates > 2D Truss/Frame, Rectangular
Frames, etc.; Create > Nodes, Members, Shells

Select nodes or elements
Create > Window/Point Select, Line Select, Select by
Properties, Invert Selection, etc.

Hide or Show View > Hide Selected, Show All, etc.

Assign materials, sections, and
thicknesses

Create (or Modify) > Member Properties > Materials
(or Sections), 
Create (or Modify) > Shell Properties > Materials (or
Thicknesses)

Define boundary conditions
Create > Boundary Conditions > Supports, Springs,
etc.

Define load cases and load
combinations

Create > Load Cases, Load Combinations

Assign loads
Create > Draw Loads > Nodal Loads, Point Loads,
Line Loads, Surface Loads, etc.

Assign masses Create > Generate Loads > Additional Masses

Modify input data Modify or Tables

Define response spectra Tables > Response Spectra Library

Review Input View > Display Options, Load Diagram, Quick Render

Set analysis options Analysis > Analysis Options

Perform analysis
Analysis > Static Analysis, Frequency Analysis,
Response Spectrum Analysis

Review analysis results
Analysis Results > Shear & Moment Diagram,
Contour Diagram, Deflection Diagram, Mode Shape

View or print reports
Reporting > Print Options, Print Text Report, Print
Current View, etc.
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Tips:

1.  Use Modify > Undo to undo the last step.

2.  Use table input when you want to combine it with graphical input, or when you are not
comfortable with graphical input.

3.  Try to remember some useful keyboard shortcuts
UP or DOWN or LEFT or RIGHT for panning
[CTRL] + UP or DOWN or LEFT or RIGHT for zooming
[SHIFT] + UP or DOWN or LEFT or RIGHT for rotating
F8 for quick rendering
ESC to clear selection or get out of trouble.  Press twice if you have to.

4. Views and selections may be saved and recalled.

5. Use 128-bit floating point skyline solver for numerically sensitive structures such as one
with rigid diaphragms. 
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10.2 Example 1: A Cantilever Beam

Problem Description

A 100-inch long cantilever beam is subjected to a tip load of -10,000 lbs.

Material properties: E = 2.9e7 psi, = 0.3

Section properties: Ix = 200 in 4̂, Ay = 8.33333 in 2̂

Analyze the beam for the following two cases:
a). Model the beam with one frame element.  Verify the vertical displacement and rotation at
the tip of the beam, with/without the shear deformation considered.  
b). Model the beam with 1,000; 10,000; 20,000; and 50,000 members.  Analyze the each
model with the 64-bit and 128-bit floating point solver.  Compare the vertical displacements
without shear deformation considered.

Suggested Modeling Steps

§ Set proper units from Settings and Tools > Units & Precisions.
§ Generate the beam geometry by Create > Templates > Rectangular Frames.  For

example, to generate 1,000 members (each with 0.1 inch in length), enter a distance
list of “1000@0.1” in the X direction.  Do not enter anything for the Y and Z directions. 

§ Select all members, define and assign the material properties by Modify > Member
Properties > Materials. Make sure “Assign active material to currently selected
elements” is checked in the dialog box.

§ Select all members, define and assign the section properties by Modify > Member
Properties > Sections.  Make sure “Assign active section to currently selected
members” is checked in the dialog box.

§ Press ESC key to unselect all nodes and elements.  Select the first node by Create >
Select > Select Nodes, and assign it a fixed support by Create > Boundary Conditions
> Support.

§ Select the last node by Create > Select > Select Nodes, and assign it a nodal load of -
10,000 lb in the global Y direction.  The load is assigned to the built-in load case called
“Default”.  ENERCALC 3D also provides a load combination called “Default” which is
1.0 * “Default” load case by default.

§ Set the analysis options by Analysis > Analysis Options.  Choose the model type “2D
Frame”. Check or uncheck “Consider shear deformation on members”.  Select the
64-bit or 128-bit floating point skyline solver.
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Results

The displacement at the tip of the beam may be calculated by hand as follows:

 psi

 in (shear deformation ignored)

 in (shear deformation considered)

radian

The following table shows the tip displacement and rotation of the beam modeled with one
element.  The comparison between the program and theoretical results is excellent.

Without shear deformation With shear deformation

ENERCALC 3D Theoretical ENERCALC 3D Theoretical

Displacement -0.5747 -0.5747 -0.5855 -0.5855

Rotation -0.00862 -0.00862 -0.00862 -0.00862

The following table shows the tip displacements of the beam modeled with 1000; 10,000;
20,000; and 50,000 elements.  Shear deformations are ignored.  The four models are solved
with the 64-bit (skyline) floating point and the 128-bit floating point solvers of the program.

Solver
Number of elements

1,000 10,000 20,000 50,000

64-bit 
floating point

-0.5748 -0.6522 -0.1534 No solution

128-bit 
floating point

-0.5747 -0.5747 -0.5747 -0.5747
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Comments

This is probably the simplest structural model that can be solved by either hand or an analysis
program.  However, it could be turned into a very challenging numerical problem as shown in
the example.  The standard 64-bit floating point (double precision) solver, which is the
predominant and only solver in almost all other analysis programs, tends to deteriorate in
solution accuracy as the number of elements increases.  In the example, the 64-bit floating
point becomes unstable after 10,000 elements.  For the model with 50,000 elements, some
diagonal terms in the global stiffness matrix even become negative during factorization
process. The solver has to terminate and the solution is not obtainable anymore.  Getting no
results is better than getting incorrect results.  Try this model on your familiar
structural analysis software!

ENERCALC 3D implements a unique 128-bit floating point (quad precision) solver that is
extremely accurate and stable in solution.  Its superiority is demonstrated in that it gives
consistent and correct results up to 50,000 elements. You are encouraged to try even more
elements to solve this problem.  Just make sure you have enough computer memory to
handle large models.  If you generate a large model by splitting existing members, make sure
you renumber the nodes after splitting to minimize the bandwidth in the model.
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10.3 Example 2: A Truss

Problem Description

A truss with a span of 30 ft and a height of 7.5 ft is loaded with six concentrated loads at joints
[Ref. 9, pp355].  

Default material and section properties in the program are used.

Determine the axial forces of the truss members and the support reactions

Suggested Modeling Steps

§ Set proper units from Settings and Tools > Units & Precisions.
§ Generate the drawing grid by Create > Grids & Snaps > Drawing Grid Setup.  Enter a

distance list of “4@7.5” for the X direction and a distance list of “2@3.75” for the Y
direction.

§ Draw the truss members by Create > Members.  Point to the intersections of the
drawing grid and left-click the mouse from point to point.  The drawing action is
continuous.  Right click the mouse to start drawing from a new location.

§ Assign the nodal loads to the joints by Create > Draw Loads > Nodal Loads.
§ Set the analysis options by Analysis > Analysis Options.  Choose the model type “2D

Truss”.   

Results

The comparison between the program and the referenced results is excellent.

ENERCALC 3D  [Ref. 9]

Chord B1 – Axial force (kips) 4.44 4.44

Chord B8 – Axial force (kips) -4.964 -4.96

Support  Reaction (kips) 3.12 3.12
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Comments

No displacements are given in the reference and therefore not compared.  Default material
and section properties are used because the truss is determinant and the displacements are
not desired.
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10.4 Example 3: Linear and Non-linear Nodal Springs

Problem Description

A 2-span continuous beam is supported by three springs.  Each span is 10 inches long.  

A concentrated moment M = 100 lb-in is applied at the middle spring.  

Default material and section properties in the program are used.

Spring constants: Ky = 10 lb/in

The left and middle springs are linear.
Analyze the model for the following two cases.
a). The right spring is linear
b). The right spring is compression only

Suggested Modeling Steps

§ Set proper units from Settings and Tools > Units & Precisions.
§ Input nodal coordinates for Nodes 1, 2, 3 by Tables > Nodes
§ Input the two members by Tables > Members.  Use default material (=1), section (=1),

and local angle (=0) for both members.
§ Input the three nodal springs by Tables > Springs > Nodal Springs.  Spring flags for

the left and middle springs are “000000”.  Spring flag for the right spring is “000000” for
case a) and “010000” for case b).  Enter the spring constant Ky = 10 for all springs. 

§ Input a support at the N1 by Tables > Supports.  The support has the flag of “100000”
and 0s for all forced displacements. 

§ Input the nodal moment for N2 by Tables > Nodal Loads. Enter “5” for the load
direction (OZ) and “100” for the load value.

§ Set the analysis options by Analysis > Analysis Options.  Choose the model type “2D
Frame”.  Set the maximum nonlinear iterations to be “10”.

Results

In case a), a force couple is developed in the left and right springs.  The middle spring has a
zero force.  Fcouple = M / (20 in) = 5 lb.   3y = Fcouple / Ky = 0.5 in.

In case b), a force couple is developed in the left and middle springs.  The right spring is
eliminated because it is compression-only and a positive displacement occurs at N3. 
Fcouple = M / (10 in) = 10 lb.   2y = Fcouple / Ky = 1 in.



Step-By-Step Examples 169

© 2026  ENERCALC, Inc.

Displacements and spring reactions from ENERCALC 3D are shown in the following table. 
They are identical to the theoretical results.

Displacements (in) Spring reactions (lb)

N1 N2 N3 N1 N2 N3

Case a -0.5 0 0.5 5 0 -5

Case b -1 1 3 10 -10 0

Comments

The problem is linear for case a) and nonlinear for case b).  The program performs 3
iterations for case b).  The first iteration includes all three springs.  The second iteration
eliminates the compression spring.  The third iteration checks for convergence.  

This is a very simple problem that involves nodal springs only.  More complicated problems
may be solved just as easily.  The program supports line and surface springs that may be
applied to members and shells.  Line springs may be used in modeling beams on grade and
surface springs may be used in modeling mat (Winkler) foundations.  Both line and surface
springs may be linear or nonlinear (compression-only or tension only). 

Default material and section properties are used because they do not affect the results in the
example.
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10.5 Example 4: A Portal Frame With P-Delta

Problem Description

The following portal frame [Ref. 7, pp252] has a span of 60 ft and a column height of 24 ft. 
The beam is vertically loaded with 60 kips placed at 20 ft from the left end of the beam.  The
right column is vertically loaded with 120 kips.  A horizontal load of 6 kips is applied at the joint
of the beam and the left column.  Each column is modeled with 2 members.  The beam is
modeled with a single frame element.

Columns:  W10x45, A = 13.3 in2, Iz = 248 in4

Beam: W27x84, A = 24.8 in2, Iz = 2850 in4

Material: E = 2.9e7 psi, = 0.3
Perform analysis for the following two cases:
a). First order (Linear) elastic analysis
b). Second order (P-Delta) elastic analysis

Suggested Modeling Steps

§ Set proper units from Settings and Tools > Units & Precisions.
§ Generate the 2D frame by Create > Templates > Rectangular Frames.  Enter a

distance list of “60” for the X direction and a distance list of “24” for the Y direction.  Do
not enter anything for the Z direction.  Select “Pinned” supports at the bottom of the
dialog.

§ Select the lower horizontal beam generated and delete it by Modify > Delete.
§ Select the two columns and split each into 2 members by Modify > Split > Split

Members.
§ Select all members, define and assign the material properties by Modify > Member

Properties > Materials. Make sure “Assign active material to currently selected
elements” is checked in the dialog box.
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§ Select the four columns, define and assign the column section properties by Modify >
Member Properties > Sections.  Make sure “Assign active section to currently
selected members” is checked in the dialog box.

§ Select the horizontal beam, define and assign the member section properties by
Modify > Member Properties > Sections.  Make sure “Assign active section to currently
selected members” is checked in the dialog box.

§ Assign the nodal loads and point loads of “Default” load case by Create > Draw Loads
> Nodal Loads, Point Loads.  Make sure you select the nodes or member beforehand.

§ Create two load combinations by Create > Load Combinations.  Set a load factor of
1.0 for the “Default” load case for each combination. Set the second combination to
perform the P-Delta analysis.

§ Set the analysis options by Analysis > Analysis Options.  Choose the model type “2D
Frame”.  Uncheck “Consider shear deformation on members”.

Results

The comparison between the program and the referenced results is good.

ENERCALC 3D [Ref. 7]

Linear

Maximum Displacement (in) 4.387 4.4

Max + moment in beam (in-kips) 8707.7 8708

Max – moment in beam (in-kips) 2044.3 2044

P-Delta

Maximum Displacement (in) 8.26 8.1

Max + moment in beam (in-kips) 9079.4 9078

Max – moment in beam (in-kips) 2663.3 2661

Comments

The portal frame is analyzed by first order and second order elastic methods.  Significant
stress stiffening effect is observed.  Although each physical column is modeled by 2
members, the program accounts for the P-Delta effect very well even without splitting
columns.  However, you must split each column into more segments to account for p-delta

effect.  The same is also true when buckling analysis is desired.

The program does not perform buckling analysis directly.  You may estimate the buckling load
through trial-and-error with different load factors in the P-Delta load combination.  The
buckling load factor given by the reference [Ref. 7] is 2.2.  
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10.6 Example 5: Rectangular Plate

Problem Description

Two 2 x 2 inch square plates [Ref. 4, pp3-20] are clamped and simply supported along their
edges respectively.  Each plate is loaded with two sets of loads in two different load cases. 
The first set load is a point load applied at the center of the plate.  The second set load is a
uniform pressure applied to the entire plate.  Use a 10x10 mesh.

Material:  E = 1.7472e7 psi; = 0.3

Thicknesses: t = 1.0e-4 inch.  

Point load P = 4e-4 lb

Uniform pressure p = 1e-4 lb/in 2̂

Determine the deflections at the center of plates, using both the thin Kirchhoff and the thick
MITC4 plate formulations.
 

Suggested Modeling Steps

§ Set proper units from Settings and Tools > Units & Precisions.
§ Generate the first plate by Create > Templates > Rectangular Shells.  Enter a

distance list of “10@0.2” for the X direction and a distance list of “10@0.2” for the Y
direction.

§ Select all shell elements generated and copy them to a new location by Modify >
Copy.  Enter valid copy distances so the new plates will not overlap with the existing
shells.  For example, DeltaX=3, DeltaY=0, and DeltaZ = 0.

§ Select all shell elements, define and assign material properties by Modify > Shell
Properties > Materials. Make sure “Assign active material to currently selected
elements” is checked in the dialog box.
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§ Select all shell elements, define and assign the shell thickness properties by Modify >
Shell Properties > Thicknesses.  Make sure “Assign active thickness to currently
selected shells” is checked in the dialog box.

§ Press ESC key to unselect all.  Select the nodes along all edges of the first plate
model and assign them pinned supports by Create > Boundary Conditions > Support.
 Select the nodes along all edges of the second plate model and assign them fixed
supports by Create > Boundary Conditions > Support.  

§ Define two load cases named “Point” and “Uniform”.
§ Define two load combinations.  In the first load combination, set the load factor of 1.0

for load case “Point” and 0s for other load cases.  In the second load combination, set
the load factor of 1.0 for load case “Uniform” and 0s for other load cases.  

§ Select center nodes of the two plate models, assign them the point loads of load case
“Point” by Create > Draw Loads > Nodal Loads.

§ Select all shell elements, assign them the uniform loads of case “Uniform” by Create
> Draw Loads > Surface Loads.

§ Set the analysis options by Analysis > Analysis Options.  Choose the model type “2D
Plate Bending”.   Check or uncheck “Use Kirchhoff thin plate bending formulation for
rectangular shells”.

Results

The comparison of the deflections (inches) at the center of each plate between the program
and the referenced results is excellent.

Boundary Loading
ENERCALC 3D

[Ref. 4]
MITC4 Kirchhoff

Simple
Point 11.555 11.762 11.60

Uniform 4.049 4.044 4.062

Clamped
Point 5.475 5.750 5.60

Uniform 1.256 1.29 1.26

Comments

This is one of the standard test problems proposed to test the effectiveness of plate elements
in bending [Ref. 4].  Closed form solutions exist for both plates under point and uniform
loading [Ref. 5, 6].  The problem is solved using both thick (MITC4) and thin (Kirchhoff) plate
bending formulations.  The results from both formulations are very close and compared well
with those given by the reference.  

It is important to point out that the MITC4 thick plate element can be used to model both a
thick plate where shear deformation may be significant and a thin plate where shear
deformation is negligible.  When it is used to model a very thin plate as in this example, the
MITC4 produces results close to those produced by the Kirchhoff thin plate element.  The
MITC4 plate element is free from shear locking, and is insensitive to distortion of element
geometry.  It is arguably the best plate bending element currently available. 
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10.7 Example 6: Circular Plate On Grade

Problem Description

A circular steel plate with a thickness of 0.2 inch and a diameter of 20 inches is simply
supported along its edge [Ref. 6 pp326-327 & pp 380-381].  The plate is loaded with a uniform

load of 3 lb/in2.  

Material:  E = 3e7 psi; = 0.285

Thicknesses: t = 0.2 inch.  

Determine the deflection and moment at the center for the following two cases: 
a). No elastic foundation.

b). An elastic foundation with a modulus of 20 lb/in3.

Suggested Modeling Steps

§ Set proper units from Settings and Tools > Units & Precisions.
§ Generate the circular plate by Create > Templates > Circular Shells.  Enter a radius of

10 and segments of 80.  Select “Pinned” supports along the edge.
§ Select all shell elements, define and assign material properties by Modify > Shell

Properties > Materials. Make sure “Assign active material to currently selected
elements ” is checked in the dialog box.

§ Select all plate elements, define and assign the shell thickness properties by Modify >
Shell Properties > Thicknesses.  Make sure “Assign active thickness to currently
selected shells” is checked in the dialog box.

§ Select all shell elements, assign them the surface load by Create > Draw Loads >
Surface Loads. 

§ For case b) only, Select all shell elements, assign them surface springs by Create >
Boundary Conditions > Springs.
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§ Set the analysis options by Analysis > Analysis Options.  Choose the model type “2D
Plate Bending”.   Uncheck “Use Kirchhoff thin plate bending formulation for rectangular
shells”.

Results

The comparison of deflections and moments (absolute values) at the center of each plate
between the program and the referenced results is excellent.  Moments are the same in all
directions at the center.

@ center ENERCALC 3D [Ref. 6]

Case a
without elastic foundation

Deflection (in) 0.089 0.0883

Moment (in-lb/in) 61.54 61.5

Case b
with elastic foundation

Deflection (in) 0.064 0.0637

Moment (in-lb/in) 43.21 43.3

Comments

This example problem tests the reliability of the MITC4 plate bending element.  It also shows
how surface springs may be used to model an elastic (Winkler) foundation.  Two separate
models are used for case a) and case b).  The generated shell elements are mostly
rectangular.  Some non-rectangular shell elements exist along the edge.

A relatively fine mesh is employed in order to minimize the discretization error along the edge.
 The default MITC4 thick plate element is used.  It is important to point out that Kirchhoff thin
plate elements should not be used here due to the existence of non-rectangular elements.
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10.8 Example 7: A Cantilever Plate (In-Plane)

Problem Description

A 6 x 0.2 inch cantilever plate is loaded with two separate sets of loads [Ref. 4, pp3-20].
a). An in-plane shear of 1 lb at the tip.
b). An axial load of 1 lb at the tip.
Material:  E = 1.0e7 psi; = 0.3
Thicknesses: t = 0.1 inch.
Determine the tip displacements in the directions of applied loads, using a 6 x 1 mesh as
suggested by the reference.

Suggested Modeling Steps

§ Set proper units from Settings and Tools > Units & Precisions.
§ Generate the first plate by Create > Templates > Rectangular Shells.  Enter a

distance list of “6@1” for the X direction and a distance list of “0.2” for the Y direction.
§ Select all shell elements, define and assign material properties by Modify > Shell

Properties > Materials. Make sure “Assign active material to currently selected
elements” is checked in the dialog box.

§ Select all shell elements, define and assign the shell thickness properties by Modify >
Shell Properties > Thicknesses.  Make sure “Assign active thickness to currently
selected shells” is checked in the dialog box.

§ Press ESC key to unselect all.  Select the bottom-left node and assign it a fixed
support.  Select the top-left node and assign it a support restrained in Dx.

§ Define two load cases named “InPlaneShear” and “Axial”.
§ Define two load combinations.  In the first load combination, set the load factor of 1.0

for load case “InPlaneShear” and 0s for other load cases.  In the second load
combination, set the load factor of 1.0 for load case “Axial” and 0s for other load
cases.  

§ Select two nodes at the tip, assign each node a 0.5 lb, Y-direction nodal loads of load
case “InPlaneShear” by Create > Draw Loads > Nodal Loads.  Select two nodes at
the tip, assign each node a 0.5 lb, X-direction nodal loads of load case “Axial” by
Create > Draw Loads > Nodal Loads.

§ Set the analysis options by Analysis > Analysis Options.  Choose the model type “2D
Plane Stress”.   Check or uncheck “Use incompatible formulation for shell membrane
actions or bricks”.
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Results

The comparison of the displacements (inches) in the directions of loads between the program
and the referenced results is mixed.

Membrane formulation ENERCALC 3D [Ref. 4]

Case a)
Compatible -0.0101 0.1081

Incompatible -0.1073 0.1081

Case b) Compatible or Incompatible 3.0e-5 3.0e-5

Comments

The example problem tests the in-plane (membrane) component of the shell element.  Two
separate analyses are performed for case a) and case b).  The incompatible membrane
formulation models in-plane bending very well.  The compatible membrane formulation is too
stiff to model in-plane bending when a coarse mesh is used.  However, both formulations
work well when fine element meshes are used.
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10.9 Example 8: Brick Patch Test

Problem Description

This is a patch test for a unit cube [Ref. 4 pp3-20].  The cube is modeled with 7 eight-node
brick elements.  Nodal coordinates, element connectivity and boundary conditions are given in
the following tables.  Boundary conditions are given as forced displacements.  No additional
loads are prescribed.

Material:  E = 1.e6 psi; = 0.25

Find stresses for each element.
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Nodal coordinates (inch)

Node X Y Z

1 0.249 0.342 0.192

2 0.826 0.288 0.288

3 0.85 0.649 0.263

4 0.273 0.75 0.23

5 0.32 0.186 0.643

6 0.677 0.305 0.683

7 0.788 0.693 0.644

8 0.165 0.745 0.702

9 0 0 0

10 1 0 0

11 1 1 0

12 0 1 0

13 0 0 1

14 1 0 1

15 1 1 1

16 0 1 1

Displacement field
u = 0.001 * (2x + y + z) / 2
v = 0.001 * (x + 2y + z) / 2
w = 0.001 * (x + y + 2z) / 2

Forced displacements (inch) on boundary

NODE Dx Dy Dz

9 0 0 0

10 0.001 0.0005 0.0005

11 0.0015 0.0015 0.001

12 0.0005 0.001 0.0005

13 0.0005 0.0005 0.001

14 0.0015 0.001 0.0015

15 0.002 0.002 0.002

16 0.001 0.0015 0.0015

All strains are constant. For example
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Element Connectivity

Element Node1 Node2 Node3 Node4 Node5 Node6 Node7 Node8

1 1 2 3 4 5 6 7 8

2 4 3 11 12 8 7 15 16

3 9 10 2 1 13 14 6 5

4 2 10 11 3 6 14 15 7

5 9 1 4 12 13 5 8 16

6 9 10 11 12 1 2 3 4

7 5 6 7 8 13 14 15 16

Suggested Modeling Steps

§ Set proper units from Settings and Tools > Units & Precisions.
§ Input the nodal coordinates by Tables > Nodes.
§ Modify the default material by Tables > Materials.
§ Input the bricks by Tables > Bricks.  Use the default material (=1).
§ Input the boundary conditions by Tables > Supports.  Enter the support flag “111000”

for each support.  Enter the forced displacements according to the table above.
§ Set the analysis options by Analysis > Analysis Options.  Choose the model type “3D

Brick”.

Results

The comparison of stresses (psi) between the program and the referenced results is
excellent.  Each stress component is uniform in all seven elements.

Sxx Syy Szz Sxy Syz Sxz

ENERCALC
3D 1999.982 1999.982 1999.982 399.999 399.999 399.999

[Ref. 4] 2000 2000 2000 400 400 400

Comments

The brick element passes the patch test.  Therefore, “the results for any problem solved with
the element will converge toward the correct solution as the elements are subdivided.” [Ref.
4]  The tiny differences in stresses are due to the penalty approach employed in support
enforcement.
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10.10 Example 9: Scodelis-Lo Roof

Problem Description

The Scodelis-Lo barrel roof [Ref. 4 pp3-20, Ref. 2] has a length of 50 ft, a radius of 25 ft, and
a sweeping angle of 80 degrees.  The roof is supported on rigid diaphragms along its two
curved edges (Dx and Dy fixed, but not Dz). The two straight edges are free.  A surface load

of -90 lb/ft 2̂ in the global Y direction (self weight) is applied to the entire roof.

Material: E = 4.32e8 lb/ft 2̂ (3e6 psi);  v = 0.0;

Thickness: t = 0.25 ft.

Find the maximum deflection and moments.

Suggested Modeling Steps

Due to the symmetry, only a quarter of the roof is modeled.  A 6 x 6 mesh is used.  The
boundary conditions are specified in the following table.

Nodes Fixed DOFs

N1 to N6 Z, OX, OY

N7 X, Z, OX, OY, OZ

N14, N21, N26, N35, N42 X, OY, OZ

N43 to N48 X, Y, OZ

N49 X, Y, OY, OZ

§ Set proper units from Settings and Tools > Units & Precisions.
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§ Generate members along an arc by Create > Templates > Arc Members.  Enter a
radius of 25, segments of 6, start angle 50, end angle 90.

§ Select all nodes and members, extrude members to shells by Modify > Extrude >
Extrude Members to Shells.   Enter a distance list of “6@4.1666” and direction of the
global Z.  Check both “Merge nodes and elements” and “Delete selected members
after extrusion”.

§ Select all shell elements, define and assign the shell thickness properties by Modify >
Shell Properties > Thicknesses.  Make sure “Assign active thickness to currently
selected shells” is checked in the dialog box.

§ Select the boundary nodes and apply proper supports as specified above by Create >
Boundary Conditions > Support.  You need to select and apply multiple times.

§ Select all shell elements, assign surface load by Create > Draw Loads > Surface
Loads

§ Set the analysis options by Analysis > Analysis Options.  Choose the model type “3D
Frame & Shell”.  Check or uncheck “Use Kirchhoff thin plate bending formulation for
rectangular shells”.  Check or uncheck “Use incompatible formulation for shell
membrane actions or bricks”.  
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Results

The comparison of displacements and moments between the program and the referenced
results is excellent.  Theoretical maximum vertical displacement is given by MacNeal &
Harder [Ref. 4, pp3-20]. Other theoretical values are approximate readings (with different sign
convention for moments) from graphs given by Zienkiewicz [Ref. 2 pp350-351].  The
maximum Dy and Myy occur at the mid-point along the free edges.  The maximum Mxx
occurs at the center of the longitudinal middle section.  The maximum Dz and Mxy occur at

the corner points at supports.

Membrane Compatible Incompatible
References

Bending Kirchhoff MITC4 Kirchhoff MITC4

Displacement
Vertical (in)

-3.475 -3.489 -3.672 -3.687
-3.629
[Ref. 4]

Displacement
Longitudinal (in)

0.1317 0.1317 0.1414 0.1414
app. 0.144

[Ref. 2]

Mxx (ft-lb/ft) -1954 -1923 -2093 -2056
app. 2100
[Ref. 2]

Myy (ft-lb/ft) 636.0 633.9 667.9 666
app.-650
[Ref. 2]

Mxy (ft-lb/ft) -1204 -1199 -1264 -1260
app. 1300
[Ref. 2]

Displacement contour (MITC4-bending, compatible formulation)
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.
Mxx contour (MITC4-bending, compatible formulation)

Comments

The example is the de-facto standard test problem for shells due to the strong coupling of the
bending and membrane actions.  The problem is solved using the shell element with different
membrane and bending formulations from which excellent results are obtained.  The
incompatible membrane formulation yields results closer to the referenced values.  

The use of symmetry saves computing time and memory, but requires careful thinking with
regard to the boundary conditions.  You may model the entire roof by simply fixing Dx, Dy
along the curved edges and Dz at the longitudinal central section.
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10.11 Example 10: A Shear Wall

Problem Description

A two-story concrete shear wall is subjected to two horizontal point forces at the floor levels. 
The wall is 37.5 ft long and 21 ft high, with six openings of 7.5 x 4.5 ft.

Material:  E = 4e6 psi; = 0.15

Thicknesses: t = 12 inch.

Suggested Modeling Steps

§ Set proper units from Settings and Tools > Units & Precisions.
§ Generate the plate by Create > Templates > Rectangular Shells.  Enter a distance list

of “3@1, 21@1.5, 3@1” for the X direction and a distance list of “3@1, 10@1.5, 3@1”
for the Y direction.

§ Select the middle eight nodes at each opening and delete them.  The shells that are
connected to these nodes are deleted automatically.

§ Select all shell elements, define and assign material properties by Modify > Shell
Properties > Materials. Make sure “Assign active material to currently selected
elements” is checked in the dialog box.

§ Select all shell elements, define and assign the shell thickness properties by Modify >
Shell Properties > Thicknesses.  Make sure “Assign active thickness to currently
selected shells” is checked in the dialog box.

§ Press ESC key to unselect all.  Select the nodes at the bottom and assign them fixed
supports.

§ Select the two nodes at each story level and assign them nodal loads by Create >
Draw Loads > Nodal Loads.

§ Set the analysis options by Analysis > Analysis Options.  Choose the model type “2D
Plane Stress”.   Check “Use incompatible formulation for shell membrane actions or
bricks”.
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Results

No comparison of results is available.  Displacement Dx contour and Stress Syy contour is

provided in the following.

Displacement Dx contour on deflected shape

Stress Syy contour

To verify the results, the horizontal shear is checked at the middle elevation of the second
story openings.  The following table shows the “Membrane nodal resultants” of four piers by
View > Display Options (annotation mode = “Annotate selected entities” to avoid congestion
of texts).  You may also view the same nodal resultants in a spreadsheet by Analysis Results
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> Shell Forces, Moments & Stresses > Shell Nodal Resultants.  You can then copy and paste
selected data to your preferred spreadsheet program to perform summation or other
computations.  It is important to point out that nodal resultants are expressed in the element
local coordinate systems.

Pier 1

 Fx = 

0.432 + 0.654 
+ 0.602 + 1.269 
+ 0.445 - 0.427

= 2.975 kips

Pier 2

 Fx = 

1.758 + 3.226 
+ 7.226 + 5.786 
+ 3.144 + 2.722
= 23.862 kips

Pier 3

 Fx = 

1.401 + 2.325
+ 5.068 + 4.486
+ 2.323 + 1.875 

= 17.478 kips

Pier 4

 Fx = 

0.153 + 0.729
+ 1.83 + 1.334
+ 0.965 + 0.673

= 5.684 kips

All Piers  Fx = 2.975 + 23.862 + 17.478 + 5.684  = 49.999 (app.= 50 kips) 

Membrane nodal resultants of four piers at the middle elevation of the second story
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Comments

The example problem shows how to perform structural analysis on a shear wall.  Although no
comparison of results is available, we demonstrate the reliability of the program by checking
the horizontal shear. 

In designing concrete sections, we generally need forces and moments instead of stresses. 
We may acquire axial forces and moments in the same manner as in shears.  For example,
to determine the moment at the second pier above, we may sum the moments by nodal
resultants Fy about the center of the pier.

Fyi (kips) Xi (ft) Fyi * Xi (ft-kips)

-2.284 -2.25 5.139

1.663 -0.75 -1.24725

-8.458 -0.75 6.3435

4.611 0.75 3.45825

-3.718 0.75 -2.7885

3.082 2.25 6.9345

 Fy = -5.104
sum = 17.8395

Internal Forces and Moment at middle of the second pier
Axial Force = -5.104 kips
Shear Force = 23.862 kips
Moment = 17.8395 ft-kips

You are encouraged to model this wall with members and compare the results with those in
this example.  Care should be exercised in segmenting the members and assigning them
appropriate section properties.  Since the sections of the members are relatively deep, shear
deformations must be considered.
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10.12 Example 11: Frequencies of Cantilever Beam

Problem Description

Analyze the vibration frequencies for the following cantilever beam (L = 6m) under its own
weight.

Material properties: E = 20600 KN/cm 2̂, = 0.3, weight density = 7850 Kgf/m 3̂

Section properties: Ix = 4079.07 cm 4̂, Ax = 53.1612 cm 2̂, Ay = Az = 0

The beam is optionally subjected to a compressive horizontal tip load of P = 500 KN
Analyze the beam for the following two cases:
a). Find the lowest 3 frequencies without the effect of axial load
b). Find the lowest 3 frequencies with the effect of axial load

Suggested Modeling Steps

§ Set proper units from Settings and Tools > Units & Precisions.
§ Generate the beam geometry by Create > Templates > Rectangular Frames.  For

example, to generate 8 members (each with 0.75 m), enter a distance list of “8@0.75”
in the X direction.  Do not enter anything for the Y and Z directions. 

§ Select all members, define and assign the material properties by Modify > Member
Properties > Materials. Make sure “Assign active material to currently selected
elements” is checked in the dialog box.

§ Select all members, define and assign the section properties by Modify > Member
Properties > Sections.  Make sure “Assign active section to currently selected
members” is checked in the dialog box.

§ Press ESC key to unselect all nodes and elements.  Select the first node by Create >
Select > Select Nodes, and assign it a fixed support by Create > Boundary Conditions
> Support.

§ Apply self weight by running Create > Draw Loads > Self Weights.  Set self weight
direction to be global Y and self weight multiplier -1.

§ Set the analysis options by Analysis > Analysis Options.  Choose the model type “2D
Frame”.  Uncheck “Consider shear deformation on members”.  

§ From Analysis > Frequency Analysis, check “Convert loads to masses”, set number
of modes 3, number of iteration vectors 8, tolerance of eigenvalue 1e-6 and maximum
number of subspace iterations 18.

For Case a), do the following steps
§ Run Frequency Analysis from Analysis > Frequency Analysis
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For Case b) do the following steps
§ From Tables > Masses > Calculated Masses, click on “Convert to Additional Masses”.

 This is to avoid converting the external load to mass (although it is not necessary in
this case because the load is not in the gravity direction).

§ Select the last node by Create > Select > Nodes, and assign it a nodal load of -500 KN
in the global X direction.

§ From Create > Load Combinations, set the default load combination to “Perform P-
Delta Analysis on this load combination”.

§ From Analysis > Frequency Analysis, make sure “Convert loads to masses” is
unchecked.  Then click on Run Frequency Analysis.

Results

The frequencies without considering axial load can be calculated based with the following
formulae [Ref. 14]:

and 
where m is the linear mass density
m = 7850 * 53.1612 = 41.731542 kg/m

I = 4.07907 10-5 m 4̂
L = 6 m

E = 2.06 10-11 N/m 2̂

; ; 

There are no closed form formulae for calculating frequencies when axial load influence is
considered.  The results are therefore compared with another finite element program, AxisVM
6.0

The following table shows the first three frequencies modeled with 8 elements.  The
comparison between the program and theoretical results is excellent.  The comparison
between the program and AxisVM 6.0 is identical.

Frequency

Without axial load considered With axial load considered

ENERCALC 3D
Theoretical

(exact)
ENERCALC 3D AxisVM 6.0

 (Hz) 6.9255 6.98 2.6005 2.60

 (Hz) 42.6551 43.71 39.4754 39.48

 (Hz) 117.5983 122.39 115.0347 115.03
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Comments

The comparison between the program and theoretical results is deemed excellent because
we used only 8 elements for the discretization.  The frequencies given by the program are
lower than the exact ones.  Notice the mass allocated to the support is lost in the
computation.  If we employed more elements, the finite element frequencies would definitely
be closer to the exact continuous ones.

When axial load is considered, as in Case b, the stress-stiffness concept used by
ENERCALC 3D to determine P-Delta effects is applied.  In this approach, compressive axial
load effectively reduces the flexural stiffness of a member (axial tension increases the flexural
stiffness).  With a lower stiffness, and equal mass, the frequencies are reduced.
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10.13 Example 12: Frequencies of Rectangular Plate

Problem Description

A 9 x 6 inch plate is simply supported along its edges. 

Material:  E = 3e7 psi; = 0.3, weight density = 0.282938 lb/in 3̂

Thicknesses: t = 0.15 inch.  

Use a 30x20 mesh.

Determine the first three circular frequencies of the plate, using both the thin Kirchhoff and the
thick MITC4 plate formulations.
 

Suggested Modeling Steps

§ Set proper units from Settings and Tools > Units & Precisions.
§ Generate the plate by Create > Templates > Rectangular Shells.  Enter a distance list

of “30@0.3” for the X direction and a distance list of “20@0.3” for the Y direction.
§ Select all shell elements, define and assign material properties by Modify > Shell

Properties > Materials. Make sure “Assign active material to currently selected
elements” is checked in the dialog box.

§ Select all shell elements, define and assign the plate thickness properties by Modify >
Shell Properties > Thicknesses.  Make sure “Assign active thickness to currently
selected shells” is checked in the dialog box.

§ Press ESC key to unselect all.  Select the nodes along all edges of the model and
assign them pinned supports by Create > Boundary Conditions > Support.

§ Apply self weight by running Create > Draw Loads > Self Weights.  Set self weight
direction to be global Z and self weight multiplier 1.

§ Set the analysis options by Analysis > Analysis Options.  Choose the model type “2D
Plate Bending”.   Check or uncheck “Use Kirchhoff thin plate bending formulation for
rectangular shells”.
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§ From Analysis > Frequency Analysis, check “Convert loads to masses”, set number
of modes 3, number of iteration vectors 8, tolerance of eigenvalue 1e-6, and maximum
number of subspace iterations 18. Click on Run Frequency Analysis.

Results

The circular frequencies of a simply supported rectangular plate are calculated according to
the following [Ref. 6]:

where E = 3e7 psi; t = 0.15 in; = 0.3; a = 9 in; b = 6 in; = 0.282938 / 386 * 0.15 = 1.0995e-
4 lb-sec 2̂/in 3̂

For m = 1, n = 1: rad/sec

For m = 2, n = 1: rad/sec

For m = 1, n = 2: rad/sec

The comparison of the circular frequencies between the program and the theoretical results
is excellent.

Circular
frequencies

Thin Plate
Formulation

Thick Plate
Formulation

Theoretical

 (rad/sec) 3633 3616 3636

 (rad/sec) 6982 6938 6993

 (rad/sec) 11179 11150 11189

Comments

A relatively fine mesh is employed in this example.  The thin plate finite element frequencies
are closer to the theoretical results based on classical thin plate theory.  The frequencies
given by thick plate formulation are a little smaller than those given by thin plate formulation. 
This is expected because thick plate formulation accounts for shear deformation and the plate
is therefore modeled with less stiffness.
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10.14 Example 13: Design of Two Braced Concrete Columns

Problem Description

Two concrete columns A and B are part of a braced frame [Ref 16, pp568].  The frame is
analyzed and the results of the two columns are listed below.

Column A Column B

Size (in) 14 x14 14 x14

Total length (ft) 20 24

Unbraced length (ft) 18 22

Effective length factor 0.77 0.86

Dead Pu (kips) 80 50

Dead Mu-top (ft-kips) -60 42.4

Dead Mu-bottom (ft-kips) -21 -32

Live Pu (kips) 24 14

Live Mu-top (ft-kips) -14 11

Live Mu-bottom (ft-kips) -8 -8

Design the columns according to ACI 318-02/05 .  Use fc = 3 ksi, fy = 60 ksi

Suggested Modeling Steps

§ Set proper units from Settings and Tools > Units & Precisions.
§ Create two beam elements:  element 1 – 20 ft, element 2– 24 ft.
§ Select element 1 and 2, define and assign the standard material (Concrete fc = 3.0

ksi) by Modify > Member Properties > Materials. Make sure “Assign active material to
currently selected elements” is checked in the dialog.

§ Select element 1 and 2, define and assign the standard section (Rectangle 14 x 14
inch) by Modify > Member Properties > Sections.  Make sure “Assign active section to
currently selected members” is checked in the dialog.

§ Select and assign pinned support to the start node of each member by Create >
Boundary Conditions > Support.  Select and assign roller support to the end node of
each member by Create > Boundary Conditions > Support.

§ Define Dead and Live load cases by Create > Load Cases.
§ Define two load combinations:  one with 1.0Dead and the other with 1.2Dead +

1.6Live.  The former combination contains only the sustained load cases and will be
used to calculate  d. Combination two will be used to perform the actual design. 

Make sure “Perform Concrete Design using this Load Combination” is checked.  Also
enter sustained load factor (1.2 in this case).

§ Define and apply nodal loads and moments for Dead and Live cases by Create >
Draw Loads > Nodal Loads.

§ Set the analysis options by Analysis > Analysis Options.  Choose the model type “2D
Frame”.  Uncheck “Consider shear deformation on members”.  
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§ Select ASTM_615 (English) rebar database by Concrete Design > Concrete Design
Tools > Rebar Database.

§ Define and assign two column design criteria by Concrete Design > RC Design
Criteria > RC Column Design Criteria.  Make sure “Assign active criteria to selected
members” is checked in the dialog box.
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§ Set model concrete design criteria by Concrete Design > RC Model Design Criteria. 
Make sure the sustained load combination is selected for computing  d.

§ Perform the static analysis by Analysis > Static Analysis.
§ Perform concrete design by Concrete Design > Perform Concrete Design.  Concrete

sections will be generated automatically based on column design criteria.  Exact 3D
P-Mx-My capacity surfaces will be generated and are used to check against the
column internal forces and moments.

§ View column design results by Concrete Design > Concrete Design Output > RC
Column Results.  Detailed column section results such as interaction diagrams may
be viewed or printed by Concrete Design > Flexural/Axial Interaction.
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Results

The following table shows some intermediate results during the design.  The program gives
comparable results with the reference [Ref 16].

Column A Column B

ENERCALC 3D [Ref 16] ENERCALC 3D [Ref 16]

Cm 0.439 0.438 0.899 0.900

 d 0.714 0.714 0.728 0.728

Moment magnification
factor

1.000 1.000 1.191 1.200

The program chooses 6#8 bars for column A and 4#8 bars for column B.  The reference
gives 4#8 bars for both column A and column B.  The program gives the unit check of 1.038
for column A if 4#8 bars were used.  For practical applications, a unit check of slightly over
1.0 is probably acceptable. 

Comments

This example shows the program can be used to design multiple concrete columns in a fast
fashion.  The loads are applied as nodal forces and moments.  These loads are usually
obtained from analysis results.  For columns that are part of an unbraced frame, second-
order analysis must be used, with consideration to stiffness adjustment according to ACI 318-
02/05.
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10.15 Example 14: Design of a Continuous Concrete Beam

Problem Description

The following sub-frame [Ref 17, pp 7-43], which consists of one continuous beam plus top
and bottom columns framing into the beam, is used to perform flexural and shear design of
the continuous beam under vertical loads.

Member sizes: beam = 36 x 19.5 in; exterior columns =16 x 16 in; interior columns = 18 x 18
in.  Story height = 13 ft.

Service Loads: Dead = 3.9 kips/ft (including self-weight); Live = 1.8 kips/ft

 
Design the continuous beam according to ACI 318-02/05.  Use fc = 4 ksi, fy = 60 ksi

Suggested Modeling Steps

§ Set proper units from Settings and Tools > Units & Precisions.
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§ Generate rectangular frame by Create > Templates > Rectangular Frames as follows:

§ Select and delete top and bottom beam elements (element 1, 2, 3, 7, 8 and 9 that
were generated).   

§ Select far end nodes of columns and assign fixed supports to them.
§ Select all members and renumber each selected member by running Modify >

Renumber > Renumber Selected Members, as shown below

§ Define three rectangular sections 36 x 19.5 in, 18 x 18 in and 16 x 16 in using Regular
Section in Modify > Member Properties > Sections.  Assign each of these sections to
appropriate elements

§ Define 4.0 ksi material using Std Material in Modify > Member Properties > Materials. 
Assign this material to all.

§ Define five load cases: Dead, Live1, Live2, Live3 and Live4 by Create > Load Cases. 
Note Live1, 2, 3 and 4 cases are used for live load patterning.  Live1 loading is applied
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to element 1 and 2.  Live2 loading is applied to elements 1 and 3.  Live3 is applied to
element 2 only. Live4 is applied to elements 2 and 3.

§ Define four new load combinations: a). 1.2Dead + 1.6Live1, b). 1.2Dead + 1.6Live2
and c). 1.2Dead + 1.6Live3.  d). 1.2Dead + 1.6Live4.  Make sure “Perform Concrete
Design using this Load Combination” is checked.  Also enter sustained load factor
(1.2 in this case).

§ Define and apply line loads for Dead, Live1, 2, 3 and 4 cases Create > Draw Loads >
Line Loads.  Use View > Load Diagram to check that the loads are applied correctly.

§ Set the analysis options by Analysis > Analysis Options.  Choose the model type “2D
Frame”.  Uncheck “Consider shear deformation on members”.  Run Static Analysis to
make sure the model is correct before we proceed to the concrete design.

§ Select ASTM_615 (English) rebar database by Concrete Design > Concrete Design
Tools > Rebar Database.

§ Define and assign beam design criteria by Concrete Design > RC Design Criteria >
RC Beam Design Criteria.  
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§ Set model concrete design criteria by Concrete Design > RC Model Design Criteria. 
Make sure to select the checkbox “Automatically compute support widths”.

§ Select all columns and exclude them from concrete design by Concrete Design >
Exclude Elements.

§ Perform concrete design by Concrete Design > Perform Concrete Design.
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§ To view the beam design results in tabulated form, run Concrete Design > Concrete
Design Output > RC Beam Results for flexural design and Concrete Design >
Concrete Design Output > Member Shear Results for shear design.
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§ To view the beam design result in graphics, run Concrete Design > Concrete Design
Diagrams > RC Member Envelope Diagram.  The following shows the member
moment envelope diagram.

Results

The following table compares the design moments between the program and the reference
[Ref 17, pp 7-43]:

Moment (ft-kips) ENERCALC 3D [Ref 17, pp 7-43]

End Span

Ext (-) moment -232.0 -385.9

(+) moment 356.1 441.1

Int (-) moment -523.6 -615.8

Interior Span (+) moment 274.9 383.8

Comments

The reference [Ref 17, pp 7-43] uses the approximate coefficients method while the program
uses the exact stiffness method.  It is apparent the former method is quite conservative.
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10.16 Example 15: Design of Concrete Slab

Problem Description

The following 34 x 34 ft flat plate is supported by two fixed edges and two simply supported
edges as well as a 16 x 16 in column in the middle. [Ref 20, pp 536-540].  

Factored load = 170 psf (including self-weight) 
fc = 4 ksi, fy = 60 ksi
Slab thickness h = 6.5 in
Concrete cover: d = 1.25 in over the central column and near the intersection of the two fixed
edges, d = 1.0 in for the rest of the area.
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Suggested Modeling Steps

§ Set proper units from Settings and Tools > Units & Precisions.  In particular, set the
length unit to be inch for easy mesh generation.

§ Generate rectangular shells by Create > Templates > Rectangular Shells as follows:  
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§ Define 4.0 ksi concrete material using Std Material in Modify > Shell Properties >
Materials.  Assign this material to all plates.  

§ Define a thicknesses of 6 inches using Modify > Shell Properties > Thicknesses. 
Assign this thickness to all plates.

 

§ Using Create > Boundary Conditions > Support, assign fixed supports to nodes along
the left and bottom edges.  Assign pinned supports to nodes along the right and top
edges as well as to the column node.
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§ Assign normal surface load of 170 lb/ft 2̂ to all plates by Create > Draw Loads >
Surface Loads.

§ You may turn off the display of surface loads by View > Load Diagram.

§ Use the default load combination for concrete design from Create > Load
Combinations.
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§ Set the analysis options by Analysis > Analysis Options.  Choose the model type “2D
Plate Bending”.  Uncheck “Consider shear deformation on members”.  Check “Use
Kirchhoff thin plate bending formulation for rectangular shells”.  The Kirchhoff element
formulation is recommended over the MITC4 bending formulation for thin plate
models that contain only rectangular elements.  Run Static Analysis to make sure the
model is correct before we proceed to the concrete design.



Step-By-Step Examples 209

© 2026  ENERCALC, Inc.

§ Various analysis results may be viewed by Analysis Results > Contour Diagram.  The
following are Dz displacement, plate Mxx and Mxy contours.

Dz Displacement Contour
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Plate Mxx Contour

Plate Mxy Contour

§ Select ASTM_615 (English) rebar database by Concrete Design > Concrete Design
Tools > Rebar Database.
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§ Define two plate design criteria by Concrete Design > RC Design Criteria > RC Plate
Design Criteria as follows.  Assign the stackArea criteria to area where bar stacking
occurs – that is, over the central column and near the intersection of the two fixed
edges.  

§ Select the four plates over the column node and exclude these plates from concrete
design by Concrete Design > Exclude Elements.

§ Perform concrete design by Concrete Design > Perform Concrete Design.



ENERCALC 3D Verifications Manual212

© 2026  ENERCALC, Inc.

§ To view the plate flexural design results in tabulated form, run Concrete Design >
Concrete Design Output > RC Plate Results.
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§ To view the plate design result in graphics, run Concrete Design > Concrete Design
Diagrams > RC Plate Envelope Contour. For illustration purposes, the X-top and X-
bottom design (Wood-Armer) moment and the corresponding required steel contours
are shown below.  Based on reinforcement contours and some common sense, the
actual reinforcement can be provided for final design.

Wood-Armer Top-Mux
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Wood-Armer Bottom-Mux

Required Top-Asx
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Required Bottom-Asx

Results

ENERCALC 3D Ref 20

Negative moment over column (lb-ft/ft) -11,510 -10,528

Negative steel over column (in 2̂/ft) 0.5259 0.48

Negative moment along fixed edges (lb-ft/ft) -4,412 -3,509

Negative steel along the fixed edges (in 2̂/ft) 0.183 0.15

Positive moment in outer spans (lb-ft/ft) 4,234 3,789

Positive steel in outer spans (in 2̂/ft) 0.1752 0.16

Comments

The reference used Advanced Strip Method to compute the design moments and therefore is
approximate in nature.  The program computes the design (Wood-Armer) moments based on
the plate element Mxx, Myy and Mxy.  Although the two methods are fundamentally different,
comparable results are obtained.

One of the difficulties in using finite element results to perform concrete plate (or slab) design
is stress singularity.  In this example, the slab stress around the column is theoretically
infinite.  This is reflected in stress and reinforcement spikes at the slab/column interface area.
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 Finer finite element mesh will generally exacerbate the problem.  We alleviated the problem
by excluding the four finite elements over the column from design.  Appropriate averaging or
redistribution of reinforcement should also be applied before the actual reinforcement is
provided.
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10.17 Example 16: Design of Steel Beam

Problem Description

Select the lightest W section for the simply supported beam of L = 50ft, Lb = 25 ft.  The
superimposed load is 0.4 kip/ft dead load and 1.0 kip/ft live load.  Use A992 steel.
[Ref 22, pp 435-437].  

Suggested Modeling Steps

§ Set proper units from Settings and Tools > Units & Precisions.  

§ Define load cases from Create > Load Cases
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§ Define the load combination from Create > Load Combinations: make sure “Perform
Steel Design using this Load Combination” is checked.

§ Define the material from Modify > Member Properties > Materials using the standard
steel Steel-A992--Fy50.  Steel properties such as Fy and Fu are set automatically.
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§ Define the section W18x97 from Modify > Member Properties > Sections using the
AISC table.  

§ Define the two nodes from Tables > Nodes.  
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§ Define the one beam from Tables > Members
 

§ Define the two supports from Tables > Supports
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§ Define both the dead and live line loads from Tables > Line Loads

§ Define the self weight from Tables > Self Weights.  Make sure the self weight acts in
the negative global Y direction.
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§ Set structural model as 2D Frame from Analysis > Analysis Options.  Run Static
Analysis to make static analysis results available for steel design.
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§ Define the steel member design criteria from Steel Design > Steel Design Criteria >
Steel Member Design Criteria.  Use “W” as the section prefix as we want to find the
light W section.  We could also use “W12, W18” for the section prefix if we would
want to use either W12 or W18x sections.  Make sure Cb = 0 so we will have the
program calculate it automatically.  Important: If 0 is entered for Lb for non-
continuously braced, then Lb is taken as the member length.  If the member is
fully braced laterally, you must enter 0 for Lb.

§ Define the steel member input from Steel Design > Steel Member Input.  

§ Perform the steel design from Steel Design > Perform Steel Design.  
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§ View the steel design results from Steel Design > Steel Design Results.  By default,
up to 10 candidate sections are available.  The W18x97 happens to be the lightest
section.  Also notice that Cb is calculated automatically (Cb = 1.3).  If desired, we
could now update the member with a different section candidate, reanalyze the model
and perform the steel design again.  

You can also view the detailed step-by-step calculation procedures for the most
critical load condition on each member.



Step-By-Step Examples 225

© 2026  ENERCALC, Inc.

10.18 Example 17: Design of Steel Column

Problem Description

Select an ASTM A992 W-shape with a 10-in nominal depth to carry the following load effects:
Pu = 30 kips, Mux = 90 kip-ft, Muy = 12 kip-ft.  
The unbraced length is 14 ft and the ends are pinned.  Cb = 1.14.  The member is non-sway.
[Ref 23, Example H.4].  

Suggested Modeling Steps

§ Set proper units from Settings and Tools > Units & Precisions.  

§ Define the material from Modify > Member Properties > Materials using the standard
steel Steel-A992--Fy50.  Steel properties such as Fy and Fu are set automatically.



ENERCALC 3D Verifications Manual226

© 2026  ENERCALC, Inc.

§ Define the section W10x12 (or any W-shape) from Modify > Member Properties >
Sections using the AISC table.  

§ Define the two nodes from Tables > Nodes.  
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§ Define the one beam from Tables > Members
 

§ Define the one supports from Tables > Supports.  Please note the first node has X, Y
Z, and OX DOFs fixed.  The second node has Y and Z DOFs fixed.  The fixity in OX
direction at the first node is needed to ensure the stability of the 3D Frame.
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§ Define the nodal loads from Tables > Nodal Loads.  Please note we enter the load
effects as nodal loads as we do not have the exact load condition in the original
example.  We need to enter Cb manually later instead of letting the program to
calculate it for us automatically.
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§ Define the load combination from Create > Load Combinations.  Make sure the
“Perform Steel Design using this Load Combination” is checked.
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§ Set structural model as 3D Frame from Analysis > Analysis Options.  Run Static
Analysis to make static analysis results available for steel design.
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§ Define the model design option from Steel Design > Steel Design Criteria > Steel
Design Criteria.  Make sure the “Consider moment magnification factor B1” is
checked.

§ Define the steel member design criteria from Steel Design > Steel Design Criteria >
Steel Member Design Criteria.  Use “W10” as the section prefix as we want to find the
lightest W10 section.  For this example, we manually enter Cb = 1.14 (The program
would calculate Cb automatically if Cb is entered 0.0). Also, since we set Lb, Lux, Luy
and Luz to be zero, the program will use the member actual length for each of them.
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§ Define the steel member input from Steel Design > Steel Member Input.  

§ Perform the steel design from Steel Design > Perform Steel Design.  

§ View the steel design results from Steel Design > Steel Design Results.  By default,
up to 10 candidate sections are available.  The original section W10x12 is not
adequate with critical ratio = 9.64318 (> 1.0).  The first section that is adequate is
W10x33 with critical ratio = 0.978576 (< 1.0).  At this point, you can update the
member section to be W10x33, reanalyze the model and perform steel design again.



Step-By-Step Examples 233

© 2026  ENERCALC, Inc.

You can also view the detailed step-by-step calculation procedures for the most
critical load condition on each member.
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10.19 Example 18: Response Spectrum Analysis of a Beam

Problem Description

A simply supported beam (L = 20 ft) [Ref 24, Problem.4.8] is subjected to a response
spectrum in the vertical direction at both supports. The beam section is of size 1.458 in x 14
in. 

Material: E = 30 e6 psi, density = 6538.08 lb/ft 3̂

Damping: 0.0

Spectrum Definition:

Suggested Modeling Steps

§ Set proper units from Settings and Tools > Units & Precisions.  
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§ Define the material from Modify > Member Properties > Materials 

§ Define the section from Modify > Member Properties > Sections using the Regular
Section button.  
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§ Define the two nodes from Tables > Nodes.  

§ Define the one beam from Tables > Members. Make sure the correct material and
section are used for this beam.
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§ Select the beam we just created. Use Modify > Split > Split Members to split it to 10
elements of equal lengths.

§ Use Create > Boundary Conditions > Support to assign supports to node 1 and 2
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§ From Create > Generate Loads > Response Spectra Library > Add, define the
spectrum.
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§ We will convert self-weight to calculate masses. So from Create > Draw Loads > Self
Weights, define the self-weight multiplier as -1 in Global Y direction.  By default, self
weight will be of load case “Default”, which is included in the default load combination
“Default”.

§ Set structural model as 2D Frame from Analysis > Analysis Options. We will not
consider shear deformation on members. 
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§ Frequency analysis must be run prior to response spectrum analysis.  So run
frequency analysis from Analysis > Frequency Analysis. We will compute the first 10
modes.

.

§ Run response spectrum analysis from Analysis > Response Spectrum Analysis. 
Make sure we use the correct spectrum and apply directional factor only in Y direction.

§ After the response spectrum analysis is done, we can then exam results such as
Analysis Results > Dynamics > Eigenvalues, Analysis Results > Dynamics > Modal
Nodal Displacements, Analysis Results > Dynamics > Modal Member End Forces &
Moments, etc.
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The following is a result comparison between ENERCALC 3D and the reference [Ref 24].  

ENERCALC 3D Reference

First Mode Frequency 6.0979 Hz 6.098 Hz

Midspan Displacement Dy  0.5446 in 0.549 in

Midspan moment
9.40764e5 lb-in
(78.397 kip-ft)

9.493e5 lb-in
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Part
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